Community Forum

Xfi Pods provide fast internet, but FAIL to load "speed test" pages

Highlighted
New Poster

Xfi Pods provide fast internet, but FAIL to load "speed test" pages

I installed six Xfi Pods today for a client, and the only hitch is that, even though we get good wifi & internet throughout the house, any "speed test" website fails to load. (Whether I connect computer to xfi pods via wifi or the lan port)

 

If I'm near the XB3 router / wifi home base, and am presumably connected to that wifi, I CAN run speed test pages fine.

 

But if I am connected (wifi or ethernet) through the xfi pods at the far end of the house, even though I do get fast internet, I still get an error / timeout when I run speed tests at any of the following: "google speed test", "ookla", "speedof.me"

 

Any ideas why?

Silver Problem Solver

Re: Xfi Pods provide fast internet, but FAIL to load "speed test" pages


@PhillipJC wrote:

I installed six Xfi Pods today for a client, and the only hitch is that, even though we get good wifi & internet throughout the house, any "speed test" website fails to load. (Whether I connect computer to xfi pods via wifi or the lan port)

 

If I'm near the XB3 router / wifi home base, and am presumably connected to that wifi, I CAN run speed test pages fine.

 

But if I am connected (wifi or ethernet) through the xfi pods at the far end of the house, even though I do get fast internet, I still get an error / timeout when I run speed tests at any of the following: "google speed test", "ookla", "speedof.me"

 

Any ideas why?


No clue (I don't have Pods).  What happens when you use the Xfinity Speed Test?

http://speedtest.xfinity.com/

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Official Employee

Re: Xfi Pods provide fast internet, but FAIL to load "speed test" pages

PhillipJC -- 

Thanks for reaching out! From your post, it sounds like the Pods are working as intended & providing WiFi coverage throughout the home.

A few questions regarding the speed tests you're running –

How are you determining that you are connecting to the Pod vs the Gateway when running the Speed Test? (Just because a device is right next to a Pod, it may not be using that Pod as its connection point. Pods communicate with each other and the Gateway to monitor the number of devices connected in the home, their location, and the type of WiFi connection that each device needs. This ensures that your device is operating with the best signal. Think of it the same way that your GPS directs you to an alternate route to get you to your destination faster when there's too much traffic on the main road.)  You can determine how a device is connected by looking in the xFi app -- Tap Devices > then tap the device you're using to perform the speed test > Device Details > from there, you'll be able to see the Connection Point.


Can you try running the Xfinity Speed Test?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!