Community Forum

XFi claims I have an old browser

Highlighted
New Poster

XFi claims I have an old browser

I try to open XFi on my desktop to do some simple router maintenance, and I get the message:

Please update your browser
To continue, you\'ll have to install the latest version of your current browser or download one of these instead.

I am running Chrome Version 70.0.3538.67 (Official Build) (64-bit), which I believe it the very latest production build, so the error message is garbage.

All I need to do is change the name of the 5 GHz signal. This is really frustrating to get a meaningless error message. It tells me someone is checking the wrong thing in their javascript.

Highlighted
Silver Problem Solver

Re: XFi claims I have an old browser


@susannecessary wrote:

I try to open XFi on my desktop to do some simple router maintenance, and I get the message:

Please update your browser
To continue, you\'ll have to install the latest version of your current browser or download one of these instead.

I am running Chrome Version 70.0.3538.67 (Official Build) (64-bit), which I believe it the very latest production build, so the error message is garbage.

All I need to do is change the name of the 5 GHz signal. This is really frustrating to get a meaningless error message. It tells me someone is checking the wrong thing in their javascript.


https://www.xfinity.com/support/articles/view-change-wifi-password

Can you try that link?


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
Official Employee

Re: XFi claims I have an old browser

Hi @susannecessary, to ensure your Chrome browser is up date, I would suggest opening a browser window and navigating to chrome://settings/help. If you are not on the latest version, it will automatically start the update and then prompt you to restart your browser. 

 

The xFi website supports the latest the latest two versions in Google Chrome. It looks like the current version is 76, so versions 74-76 should be supported. 

 

Once you are able to update versions, please check xFi and let me know if you are continuing to experience issues. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Valued Contributor

Re: XFi claims I have an old browser


@susannecessary wrote:

I try to open XFi on my desktop to do some simple router maintenance, and I get the message:

Please update your browser
To continue, you\'ll have to install the latest version of your current browser or download one of these instead.

I am running Chrome Version 70.0.3538.67 (Official Build) (64-bit), which I believe it the very latest production build, so the error message is garbage.

All I need to do is change the name of the 5 GHz signal. This is really frustrating to get a meaningless error message. It tells me someone is checking the wrong thing in their javascript.


 

 

@susannecessary,

 

As mentioned by ComcastBrittany, Google Chrome version 70.0.3538.67 is not the latest version as of 08/15/19.

 

Also, per the Google support site

 

"Normally Chrome updates happen in the background when you close and reopen your computer's browser. But if you haven't closed your browser in a while, you might see a pending update:

  1. On your computer, open Chrome.
  2. At the top right, look at More More
  3. If an update is pending, the icon will be colored:
    • Green: An update was released less than 2 days ago.
    • Orange: An update was released about 4 days ago.
    • Red: An update was released at least a week ago.

 

To update Google Chrome:

  1. On your computer, open Chrome.
  2. At the top right, click More More
  3. Click Update Google Chrome.
    • Important: If you don't see this button, you're on the latest version.
  4. Click Relaunch.

The browser saves your opened tabs and windows and reopens them automatically when it restarts. If you'd prefer not to restart right away, click Not now. The next time you restart your browser, the update will be applied."

Highlighted
New Poster

Re: XFi claims I have an old browser

I have tried everything, my chrome is up to date and i still get the same message i need to update......way to go once again comcast
Highlighted
New Poster

Re: XFi claims I have an old browser

THis started happening to me about a month ago. I have yet to solve it. Its so frustrating becasue I can not access my device settings. I cant pause the kids wifi usage, I cant see how many devices are connected, ect... My PC runs on chrome and its old so I cant update it. I use a CHrome book and obviously I can only use chrome on it. FIrefox will not work. THis is so frustrating!!! Only way is to use the phone APp and I do not want the appon my already full storage phone.  I need this fixed COmacast..please. 

 

Highlighted
New Poster

Re: XFi claims I have an old browser

I'm up to date as of Google Chrome update settings 12-28-19 @3:40pm 

 

Your Chromebook is up to date
Version 76.0.3809.136 (Official Build) (64-bit)
Highlighted
New Poster

Re: XFi claims I have an old browser

nearly 6 months later, i have encountered the same problem.

here is my current version as of  01/23/2020:

    Google Chrome is up to date
    Version 79.0.3945.130 (Official Build) (64-bit)

what's going on, xFi?

Highlighted
Silver Problem Solver

Re: XFi claims I have an old browser


@clmayer wrote:

nearly 6 months later, i have encountered the same problem.

here is my current version as of  01/23/2020:

    Google Chrome is up to date
    Version 79.0.3945.130 (Official Build) (64-bit)

what's going on, xFi?


Is it a Chromebook?


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
Official Employee

Re: XFi claims I have an old browser


@clmayer wrote:

nearly 6 months later, i have encountered the same problem.

here is my current version as of  01/23/2020:

    Google Chrome is up to date
    Version 79.0.3945.130 (Official Build) (64-bit)

what's going on, xFi?


Are you still experiencing this error?  If so, please let us know. 

 

I ran into this issue myself this morning, however after updating my Chrome browser to v79, I am able to access xFi. I had to close down all browser tabs in order for the update to complete. 

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: XFi claims I have an old browser

On Chrome Os 

Version 76.0.3809.136 (Official Build) (64-bit), yet still get message to upgrade browser
 
 
Highlighted
New Poster

Re: XFi claims I have an old browser

I have the same problem. Trying to use Chrome on my android. My version is 81.0.4044.117 and checked that this is indeed the latest version. The problem is, when I click on "Change WiFI Setting Using xFi> ", the app isn't opening my Chrome. The app doesn't recognize that I have Chrome installed at all, it seems.