Xfinity plant
Xfinity globe
Community Forum

XFi app port forwarding not working

Regular Visitor

XFi app port forwarding not working

I am having problem to get port forwarding work, why Comcast move the setting to a web base? Can anyone can solve this problem? I talk to the customer service on the phone andnone of them can fix it. Than set up appointment have a tech come out on Tuesday, but the Tech call back said the site still down and even he come out they cannot do anything, and rescheduling to Friday, and now is Thursday and the port forwarding page still not working........ I am so sick and tired. Comcast fix it please
DD856CF3-0252-47C1-BFA3-76134C888F54.png

Accepted Solutions
New Poster

Re: XFi app port forwarding not working

after beating my head against the wall for a couple of weeks and several calls to Comcast I think I may have stumbled upon a fix...

In the 10.0.0.1 router managment, under Connected Devices...change the device from DHCP to Reserved IP.  You may have to change your DHCP range before you can change it.

Once I changed it to Reserved IP, I was able to add port forwarding from the web app.  Hope this helps.

Tags (1)

All Replies
New Poster

Re: XFi app port forwarding not working

This really needs to get fixed! ASAP

 

I am at my wits end with Comcast and I am moving in January you can bet your bottom dollar I won't be bringing Comcast with me!!

Official Employee

Re: XFi app port forwarding not working

Hi NCNeill, wngan,

This issue should be resolved. Please check xFi when you get the chance and let me know if you still experience issues accessing the port forward page. 

New Poster

Re: XFi app port forwarding not working

Still not working.

How can a company remove this from the modem capabilities and not have it working on an app?

Pitiful.

Official Employee

Re: XFi app port forwarding not working

Captain911, can you confirm if the error message you are seeing is when you first try to access the Port Forward page? 

Or are you receiving an error when you attempt to port forward a device?

If it's specific to port forwarding a device, please send me a private message with a screenshot and also the MAC address for the device. 

Thanks!

New Poster

Re: XFi app port forwarding not working

i am also not able to use port forwarding can you just put it back on my modem can i just use my own modem

Regular Visitor

Re: XFi app port forwarding not working

Yesterday I try to port forward with no success because my two Xfinity apps are still not working now for the third week in a row is someone doing something about this so that I can access my modem and my router
Regular Visitor

Re: XFi app port forwarding not working

I have the same problem before, what i do is request a Tech come out, and request replace the modem, than you will be all set.

New Poster

Re: XFi app port forwarding not working

I am having the same issue. My camera system was working fine until the Comcast router had to be replaced. The new one has XFi web based controls and will only allow the port fordwarding of one port. Comcast said they won't open more than one port and have also blamed the promlem of the app. I'm thinking the only fix is to buy my own router and get rid of theirs.

Regular Visitor

Re: XFi app port forwarding not working

After I replace the Xfinity modem everything working fine
Regular Visitor

Re: XFi app port forwarding not working

Did you purchase your own or was it replaced?

what do you have now?

 

Regular Contributor

Re: XFi app port forwarding not working

Hello everyone,

 

I apologize for any frustration caused by the modem interface. Many customer have found that they have all the control the require by utilizing their own router. Issues like port forwarding, QoS, or gaming system connections are just a few reasons why many choose their own network equipment. If you like I can double check he configuration on your modem to ensure it is provisioned correctly. If you would like me to go over please send me a private message with your account name, phone number, and service address. Thank you




Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon



Regular Visitor

Re: XFi app port forwarding not working

Im having the same problem as well. It's not letting me port forward anything. I don't understand why they switched over the port forwarding system.

New Poster

Re: XFi app port forwarding not working

I'm in the same place, not a single port will forward no matter what settings I use and even using the DMZ option on the modem or XFI doesn't work. This has been extremely frustrating because getting my PC forwarded behind all switches in my network was hard enough, then they took away the tool that I'm familiar with and replaced it with a broken one that can't even forward a single port!

New Poster

Re: XFi app port forwarding not working

I seem to be having the same problem... I can't seem to get port forwarding working correctly... it shows the ports are forwarded but when I try to access it just times out or says connection refused...

Frequent Visitor

Re: XFi app port forwarding not working

I’ve been experiencing the same issues for over a month now.. I keep getting an error message saying to try again later. I was able to open ports on one of my devices, but I have a few other devices I’d like to open ports for. Is their a way for this to be resolved or should I have a technician come change out my modem?
New Poster

Re: XFi app port forwarding not working

Same exact thing here. Any resolution that doesn't actually involve replacing the router?

Regular Contributor

Re: XFi app port forwarding not working

I apologize to everyone that has been impacted by this issue. Considering the variety of modems involved I do not believe they are the issue. It may be that the user profile connected to XFi may need to be refreshed. I can review the profile and go over the modem firmware to confirm these are not the issue. You also have the option to connect directly to the modem, visit 10.0.0.1 (un: admin pwd: password), then make your port forwarding configuration to see if they hold. If the configuration holds it is an issue with the respective profiles. If it does not, updates or replacements to the modem can be addressed.

 

If you would like me to review your profile please send me a private message with your account name, phone number, and service address so I can begin.

 

Thank You




Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon



Frequent Visitor

Re: XFi app port forwarding not working

Thank you ComcastMichaelP, I didn’t think we could still access the modem that way, I should of tried that first I guess lol! Ken noticed some issues and he private messaged me after I messaged you, so he will be restarting my modem to see if that fixes the problem 🤞! Thank you!
New Poster

Re: XFi app port forwarding not working

I can't seem to send you a message Michael, but I'm having the same problem with xfi tossing me the error everytime I try to apply the port forwarding on the xfi page. I'm using all wired connections too, this is insane as it shouldn't be this much of a chore to do something as simple as port forwarding.

Regular Contributor

Re: XFi app port forwarding not working

Sorry to hear about that Lord_of_Dawn,

 

Have you tried resetting your modem to see if the access restores? Have you tried accessing the modem directly to make the change?

 

On a side note Lord_of_Dawn, I have contacted our forum developers to check into your access to send private messages.




Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon



New Poster

Re: XFi app port forwarding not working

Is there any way to forward an external port to a different internal port? That feature was available before the XFi service showed up.

Official Employee

Re: XFi app port forwarding not working

Lord_of_Dawn, you have to post publicly first before you can send a private message. Now that you've done that, you should be good to go. 

 

XL_Ninja, I don't  think that can be done via xFi. 

 

Everyone, the device you are trying to port forward to, please ensure the device is active. Inactive devices do not register an IP address for xFi to read. Additionally, xFi cannot set up a port forward to an IPv6 device. 

 

KenF

New Poster

Re: XFi app port forwarding not working

So Ken,

What option do I have if xFi can't accomplish what was able to be done prior to xFi? Can I undo xFi? What if I purchase my own gateway and repalce the Comcast-provided modem/router?

Expert

Re: XFi app port forwarding not working


XL_Ninja wrote:

So Ken,

What option do I have if xFi can't accomplish what was able to be done prior to xFi? Can I undo xFi? What if I purchase my own gateway and repalce the Comcast-provided modem/router?


I have Comcast Voice, so i don't have that option.  Fortunately, i have no need to port-forward.

New Poster

Re: XFi app port forwarding not working

Yep, doesnt work for me either...tried to setup with port 8080, and when that didn't work (and since there is the rumor that 8080 is reserved for remote admin EVEN THO NO DOCUMENTATION ABOUT IT!),

I switched to port 8008 and still it just hangs trying to access it from outside the LAN and inside!

New Poster

Re: XFi app port forwarding not working

Hello. Is there a way to undo xFi and never have to use it again? Prior to this absolutely stupid implementation, I had spent hours getting my ports forwarded and set up on my network only to have that work ruined by a service that absolutely does not work. Is there a way to disable xFi and re-enable the port forwarding ability on my router/modem side so I can continue to work without issue? This app is unreliable, poorly built, has a god awful UI and honestly shouldn't have even be put into effect if it wasn't properly tested. 

Regular Visitor

Re: XFi app port forwarding not working

Could not agree more with MicTheMic!!

New Poster

Re: XFi app port forwarding not working

after beating my head against the wall for a couple of weeks and several calls to Comcast I think I may have stumbled upon a fix...

In the 10.0.0.1 router managment, under Connected Devices...change the device from DHCP to Reserved IP.  You may have to change your DHCP range before you can change it.

Once I changed it to Reserved IP, I was able to add port forwarding from the web app.  Hope this helps.

Tags (1)
New Poster

Re: XFi app port forwarding not working

the device I wan't to forward my port to isnt even in the list. on vfi. it is on my router when I log in though.

New Poster

Re: XFi app port forwarding not working


@ wrote:

after beating my head against the wall for a couple of weeks and several calls to Comcast I think I may have stumbled upon a fix...

In the 10.0.0.1 router managment, under Connected Devices...change the device from DHCP to Reserved IP.  You may have to change your DHCP range before you can change it.

Once I changed it to Reserved IP, I was able to add port forwarding from the web app.  Hope this helps.


THIS IS THE SOLUTION!  I too was beating my head against the wall until I tried your suggestion.

 

 Thank you so much!

New Poster

Re: XFi app port forwarding not working

Thanks!! This was the correct answer!

New Poster

Re: XFi app port forwarding not working

were you able to go back using the modem for opening ports or did the app just work?

Regular Visitor

Re: XFi app port forwarding not working

Just sent you an Email.  Hope you can help!

New Poster

Re: XFi app port forwarding not working

I’m having the same issue as well when I try set up the proper ports for my Xbox one. Could you call my personal line to discuss this matter.
773-457-0350
Official Employee

Re: XFi app port forwarding not working


@Home_Office1 wrote:
I’m having the same issue as well when I try set up the proper ports for my Xbox one. Could you call my personal line to discuss this matter.
773-457-0350

When setting up the ports for your xbox one, is the device connected to your network (showing a green dot in xFi) and are you using the default configuration in xFi Port Forwarding?

Did you have a previous port forward set up for this in the local admin page? 

What error are you getting?

New Poster

Re: XFi app port forwarding not working

I found a simple fix for me that worked. I kept getting a please wait and try again message every time I tried to forward a port through the app. The app showed one port and device being forwarded as if that was all I was able to forward however a reset of the modem fixed this temporarily giving me the ability to forward as many ports and devices I desired via the xfi app. However after changing back my settings and passwords I found the port forwarding service to be not working again providing me the same message. Long story short. It was simply due to my firewall settings in the router being set too high. Moderate is what it wanted not high. A modem reset was most likely unnecessary as the symptom returned and disappeared again after this setting was changed. Again moderate was the option that worked for my comcasts' modem router to allow port forwarding once again via the app. I hope this may be the solution to some of those on here having forwarding issues as well.
New Poster

Re: XFi app port forwarding not working

The device is connected to the WiFi and yes I’m using the default settings for it. It keeps saying something went wrong
Regular Visitor

Re: XFi app port forwarding not working

Firewall settings work for me.  My firewall settings were already on low.  Maybe a change to those is what did it for you?  I was able to get this working, once and only once, by changing my dhcp ending address under gateway->connection->local ip network->ipv4->dhcp ending address, changing the value there, then saving changes, then going to the xfi app and added a port forward successfully.  However, when I tried this again I was never able to get it to work again.  This thread says the accepted answer is replace the cable modem.  Did anybody else end up having to do that?

New Poster

Re: XFi app port forwarding not working

@stilinsm: I don't know what you beat your head against but it sure solved this problem. Thank you for your suffering. As a side note, I had to adjust my DHCP range. I usually use the lower IP addresses for static use and start DHCP above 100. I couldn't "reserve the IP" until I lowered my DHCP range or moved the device's IP into the DHCP range.
New Poster

Re: XFi app port forwarding not working

I am configuring port forwarding through my netgear router. BUt after I put the new modem in I could no longer access my cameras through port forwarding. Are you using a seperate router or are you using the Comcast modem for port forwarding?
New Poster

Re: XFi app port forwarding not working

I am using the Arris Comcast gateway.