Xfinity plant
Community Forum
Xfinity globe

XFi Pods

New Poster

XFi Pods

Just received the xFi pods, but when i go to activate them the app is telling me i need to upgrade the firmware on my router (Cisco 3941T) by rebooting the router. I have done this twice now bit it is still telling me i need to upgrade....

Accepted Solutions
Official Employee

Re: XFi Pods


@chris_guay wrote:

I will be back home later tonight. Is there a number I can call when I get back home ? 


Apologies as I am just seeing this today, but your Cisco firmware update has been pushed. You are now on the v2.8 required for Pods. Please reboot your Gateway twice (power cycle) and then try onboarding your Pods. 

Let me know if you run into any more issues. 


All Replies
Expert

Re: XFi Pods

You can try the reset button on the back but you will have to reset your wifi password(s) to what you are using now.

Official Employee

Re: XFi Pods


@chris_guay wrote:
Just received the xFi pods, but when i go to activate them the app is telling me i need to upgrade the firmware on my router (Cisco 3941T) by rebooting the router. I have done this twice now bit it is still telling me i need to upgrade....

We will need to have the engineering team push this firmware through for you. I have requested this and will provide an update on timing when I hear back. 

New Poster

Re: XFi Pods

I will be back home later tonight. Is there a number I can call when I get back home ? 

Official Employee

Re: XFi Pods


@chris_guay wrote:

I will be back home later tonight. Is there a number I can call when I get back home ? 


Apologies as I am just seeing this today, but your Cisco firmware update has been pushed. You are now on the v2.8 required for Pods. Please reboot your Gateway twice (power cycle) and then try onboarding your Pods. 

Let me know if you run into any more issues. 

New Poster

Re: XFi Pods

Hi,

thank you , after the reboot I was able to finish the installation.