Community Forum

XFi Pods Firmware Update Required after replacing gateway

Regular Visitor

XFi Pods Firmware Update Required after replacing gateway

I had 3 xfi pods connected to my old gateway, but due to issues with itI had to have it replaced with a new gateway.  I no longer see my xfi pods in the xfi app and when I try to add it I get a "Firmware Update Required" message.  I had customer support push the firmware update and have restarted new gateway a few times, but I am still unable to add it to new gateway.

 

Does the xfi pods need to be moved by customer support to my new gateway?

Highlighted
Official Employee

Re: XFi Pods Firmware Update Required after replacing gateway

Hello JJBC2002. Your xFi pods don't need to be removed to support your new gateway. We may need to refresh your equipment. I can assist with troubleshooting your xFi Pods not working with your new gateway. Please reach out to me via private message and include your full name and account primary phone number so I can assist you. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: XFi Pods Firmware Update Required after replacing gateway

I just checked again and I’m able to add my xfi pods again. It is working now. Was anything done to fix it? Thanks
New Poster

Re: XFi Pods Firmware Update Required after replacing gateway

I seemed to be having a similar issue. I recently moved into a new place and got the new Xb6. This had to be replaces a few days after receiving it. After the old(new) one was replaced, i tried to set up the XFi Pods in my house. I logged into the app and tried to set the pods up but got an error message stating "Sorry, this won't Work. This pod is still listed on another account. The previous owner must go to xFi and remove the Pod before you can use it."  The funny thing is that I am the previous owner and I called in and verified everything was transfered over to the new house and account. I have rebooted the gateway several times, tried the other 5 pods, and looked up on my account if there is a way to remove and add back in the pods with no luck.

 

Is there any way to reset these pods once you move and get a new gateway so that they can work in the new house?

 

Any help would be appreciated.

Tags (2)
Official Employee

Re: XFi Pods Firmware Update Required after replacing gateway


@G-FAM6 wrote:

I seemed to be having a similar issue. I recently moved into a new place and got the new Xb6. This had to be replaces a few days after receiving it. After the old(new) one was replaced, i tried to set up the XFi Pods in my house. I logged into the app and tried to set the pods up but got an error message stating "Sorry, this won't Work. This pod is still listed on another account. The previous owner must go to xFi and remove the Pod before you can use it."  The funny thing is that I am the previous owner and I called in and verified everything was transfered over to the new house and account. I have rebooted the gateway several times, tried the other 5 pods, and looked up on my account if there is a way to remove and add back in the pods with no luck.

 

Is there any way to reset these pods once you move and get a new gateway so that they can work in the new house?

 

Any help would be appreciated.


It sounds like your Pods are still associated to the old Gateway. If the new/current Gateway that you have was activated through the xFi App, xFi would have made the connection and moved the Pods over to the new Gateway. However if it's installed through other channels they will not. 

I will need to follow up with the team to see if they can take care of this. I will let you know when I hear back. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XFi Pods Firmware Update Required after replacing gateway

I am having the same issue.. I got a new router and installed my xFi pods yesterday.. they worked great! Woke up this morning and all the pods were offline. Was told to uninstall them and start over.. now I get “firmware must be updated”. I have been on the phone with 4 people and 2.5 hours with xfinity and no one knows what to do. This is infuriating
Official Employee

Re: XFi Pods Firmware Update Required after replacing gateway

I'm so sorry you experienced this - are you still having this problem?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: XFi Pods Firmware Update Required after replacing gateway

Good afternoon!

 

  I am having the same issue with the 3941T with the older firmware.  Have recieved the pods here in NJ and I have tried rebooting, resetting.. hard reset and thru the app.  It continues to stay the same. Any help would be appreciated before I swap to the 1682 or the XB6.  Thanks

Official Employee

Re: XFi Pods Firmware Update Required after replacing gateway


@NJTech wrote:

Good afternoon!

 

  I am having the same issue with the 3941T with the older firmware.  Have recieved the pods here in NJ and I have tried rebooting, resetting.. hard reset and thru the app.  It continues to stay the same. Any help would be appreciated before I swap to the 1682 or the XB6.  Thanks


I'll make sure your Gateway gets the firmware update and will let you know when it's completed. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: XFi Pods Firmware Update Required after replacing gateway

@NJTech, you should be good to proceed with onboaridng your xFi Pods. Prior to beginning the activation, please reboot (or power cycle) your Gateway device twice to ensure the required 2.8 firmware completes the download. 

 

Let me know if you run into any issues. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XFi Pods Firmware Update Required after replacing gateway

Apparently my xFi router just did a firmware update and now my pods wont connect. Help!?
Official Employee

Re: XFi Pods Firmware Update Required after replacing gateway

I can assist you. So that I can take a look at your account, please send me a private message and include your full name and account primary email address. Please click on my name to see my profile, and then hit the blue "Send Message" button.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XFi Pods Firmware Update Required after replacing gateway

I am having a simliar issue with my Xpods, the Modem was restarted after a change of service, now the XPod will not associate with the gateway.

Official Employee

Re: XFi Pods Firmware Update Required after replacing gateway

Pogmothon -- Thanks for reaching out.  I pulled up your account & see Pods online.  I also see you recently were in touch with us via phone.  Can you please let me know if you're still experiencing an issue?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!