Community Forum

XFi Pod slow speeds

Highlighted
Frequent Visitor

XFi Pod slow speeds

Hi all,

 

I've seen numerous posts here about XFi pods not getting the job done, and in fact slowing speeds down.  I had decided to try them anyway and picked some up Saturday.  Install wasn't quite perfect but eventually finished successfully.

 

How long should I wait patiently for the mesh to "sync up" and settle into it's normal speeds?   In most spaces where the pods are located I am now seeing speeds of <10 Mbps down and <4 Mbps up despite having Gigabit speed at the source gateway.

 

I'm willing to give it a little time, but if this isn't going to settle into reasonable performance soon I will need to return the pods and look to third party solutions that provide the speeds needed for reasonable application use.

Highlighted
Silver Problem Solver

Re: XFi Pod slow speeds


@kjwcpm wrote:

Hi all,

 

I've seen numerous posts here about XFi pods not getting the job done, and in fact slowing speeds down.  I had decided to try them anyway and picked some up Saturday.  Install wasn't quite perfect but eventually finished successfully.

 

How long should I wait patiently for the mesh to "sync up" and settle into it's normal speeds?   In most spaces where the pods are located I am now seeing speeds of <10 Mbps down and Mbps up despite having Gigabit speed at the source gateway.

 

I'm willing to give it a little time, but if this isn't going to settle into reasonable performance soon I will need to return the pods and look to third party solutions that provide the speeds needed for reasonable application use.


I've seen posts that say it can take 5-7 days.

I decided to purchase the Orbi and it has been rock-solid ever since I got it.

https://www.amazon.com/NETGEAR-Orbi-Ultra-Performance-Whole-System/dp/B01K4CZOBS


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
Contributor

Re: XFi Pod slow speeds

Xfi pods only have a max speed of 200mbps. Xfi pods are to help expand WiFi coverage to dead spots but doesn’t guarantee speeds.
Let’s say you have a 3 pack of PODs and you set them up going down a hall. The last POD may provide interent to a room that was a dead zone but that POD is sending it’s traffic back threw all the other PODs to the gateway so it will take longer so you will see a lot slower speeds. Proper spacing is also very important. Dont space them 2 far apart from each other or gateway and don’t keep them to close. You have to find the perfect locations or you could see slow speeds, network dropping off randomly or no interent.
Highlighted
Official Employee

Re: XFi Pod slow speeds

Hello @kjwcpm, thanks for reaching out to our Forums! I hope the useful information provided thus far was helpful. It can take up to a week for the "sync up" to occur. Please let us know if you are still having issues with this after a week. We're here to help! Thanks and we appreciate you having Comcast as your service provider. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Frequent Visitor

Re: XFi Pod slow speeds

After providing about 2 weeks for sync, I’ll be returning the XFi pods for credit.  At best they provided about 30 Mbps performance, at times as low as 7 Mbps.   Uploads frequently dropped to 3-5 Mbps speeds.

 

As suggested in this discussion by another poster, I bought a Netgear Orbi setup.   Immediately after setup I am seeing 250 to 300 Mbps speed at it’s worst, and no less than 25 Mbps upload.  It also appears more stable, although I won’t know that until after a few weeks of use.

Highlighted
Official Employee

Re: XFi Pod slow speeds

Hello @kjwcpm, this is upsetting to hear and I'm sorry to hear about the troubles you have experienced with the pods. I would be more than happy to further troubleshoot and run some diagnostics on my end. Can you please send me a Private Message including the full name as it appears on the account and your full name if different? 

 

To send me a Private Message, please click my name “ComcastAmira” and click “send a message


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Silver Problem Solver

Re: XFi Pod slow speeds


@kjwcpm wrote:

After providing about 2 weeks for sync, I’ll be returning the XFi pods for credit.  At best they provided about 30 Mbps performance, at times as low as 7 Mbps.   Uploads frequently dropped to 3-5 Mbps speeds.

 

As suggested in this discussion by another poster, I bought a Netgear Orbi setup.   Immediately after setup I am seeing 250 to 300 Mbps speed at it’s worst, and no less than 25 Mbps upload.  It also appears more stable, although I won’t know that until after a few weeks of use.


I passed on the Pods and bought an Orbi; much better wifi speeds:

https://www.amazon.com/NETGEAR-Orbi-Ultra-Performance-Whole-System/dp/B01K4CZOBS/ref=sr_1_1_sspa?key...


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
Official Employee

Re: XFi Pod slow speeds

@kjwcpm, I'm sorry that the xFi Pods did not work well for you, but I am happy to hear you were able to find a solution. Please reach out to us for any future issues or concerns, we're here to help. Thanks and we appreciate you being the best part of Comcast. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!