Xfinity plant
Community Forum
Xfinity globe

XFi App "We Need An Internet Connection"

New Poster

XFi App "We Need An Internet Connection"

I have had sporadic issues with the app not allowing me in. It just tells me, "We need an Internet connection." I certainly have an internet connection. It has been this way for a few days, and it has worked for me recently. Nothing has changed with my network.
Expert

Re: XFi App "We Need An Internet Connection"


merrittjr wrote:
I have had sporadic issues with the app not allowing me in. It just tells me, "We need an Internet connection." I certainly have an internet connection. It has been this way for a few days, and it has worked for me recently. Nothing has changed with my network.

It sounds like you are out of range of the gateway's wi-fi signal?

New Poster

Re: XFi App "We Need An Internet Connection"

I am having the same problem for the last several days. I am about 15 feet away from the router so range is not the problem.
Expert

Re: XFi App "We Need An Internet Connection"

How may bars are you getting on the signal?

Official Employee

Re: XFi App "We Need An Internet Connection"

@merrittjr@markz68

If you are using an Android device to access to xFi app, please try going into Settings and clearing out the App Cache and App Data for xFi. There was a setting introduced in v1.6 of the app that was causing the message to pop errantly; it has since been reverted.

 

If this does not work or you are receiving this message with an Apple device, please send me a Private Message.