Community Forum

XFI is slow and drops to devices

New Poster

XFI is slow and drops to devices

We upgraded to XFI in September ‘17 and my wife and I have had the most frustrating experience ever since. The internet connection on our phones disconnects all of the time leaving us with “no internet connection” on websites and apps. We called and were told by an xfinity CSR that we had to add more speed to our service so we did. Didn’t Help. Yet we continue to pay for a sub-par Service and when asking for help were told to pay more $$.

Anyone know of a solution?
Tags (3)
Official Employee

Re: XFI is slow and drops to devices

Hi, Aspenajlb - I see several issues with RF signal on your account. This is something that should be addressed by a field technician and an appointment has been scheduled. I will follow up with you on Sunday to make sure all issues got resolved.  


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: XFI is slow and drops to devices

@Aspenajlb - How was your tech visit? Any changes?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XFI is slow and drops to devices

Unfortunately the internet is just as bad after as it was before. I’m at a loss.
Official Employee

Re: XFI is slow and drops to devices

@Aspenajlb - Did the tech check the wiring? 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XFI is slow and drops to devices

I believe so. He replaced the modem. I’d like to return to the old, non-XFi internet modem.
Official Employee

Re: XFI is slow and drops to devices

@Aspenajlb - I think there are only 2 gateway models that do not support xFi at this moment: Cisco 3939 and Technicolor TC8717. Your RF signal levels are very good at this moment. What issues are you experiencing with the internet service? 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XFI is slow and drops to devices

I have had the same problem since I Joined two years ago despite multiple service techs including on that was here for 3 hours this week. Now the tv buffers as well as devices dropping. I too upgraded , bought an extender. Paying for subpar service all this time is not fair
Highlighted
Regular Contributor

Re: XFI is slow and drops to devices

Hello lulu91,

 

I apologize for any frustration this has caused you. I would like to review the modem provisioning to see if I ca resolve this. Can I get you to send me a private message just to verify your account. All I need is your account name, phone number, and service address to get started. Thank You




Community Icon
I am a Retired Official Comcast Employee, and I no longer actively support the forum.
Official Employees are from multiple teams within Comcast: Product, Support, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.

Was your question answered? Mark a Best Answer!solution Icon
Community Icon
I am an Retired Official Comcast Employee.
Official Employees are from multiple teams within Comcast.
We ask that you post publicly so people with similar questions may benefit.
Was your question answered? Mark a Best Answer!solution Icon
Community Icon
Retired Comcast Employee.
Please post so people with similar questions may benefit.
Was your question answered?
Mark a Best Answer!solution Icon



New Poster

Re: XFI is slow and drops to devices

It will be 2 years come this March since I upgraded as well. I have had multiple technicians out. None can fix the problem. I lose my signal intermittently and often. Rarely do I see the results of the high speed. Working from home is frustrating...I fill the swear jar weekly. I am waiting for a new Gig service from another vendor and will more than likely cut the TV/phone cord. I will miss some TV but won't miss my land line. It won't hurt that I will save about $170 per month.
New Poster

Re: XFI is slow and drops to devices

I just got xFi and I am getting the same results. Sorry to say
Frequent Visitor

Re: XFI is slow and drops to devices

I am seeing the same thing and have a service call scheduled on Saturday which is somewhat against my wishes but I don't know what else to do.  Internet to modem is fine and I am getting proper speeds to wired devices, but WiFi connected devices drop often and the router reboots from time to time.  I really dont want to pay this kind of money to go back to a separate access point.

Silver Problem Solver

Re: XFI is slow and drops to devices

Start here;

 

https://forums.xfinity.com/t5/Your-Home-Network/Connection-Troubleshooting-Tips/m-p/1253575#M94474

 

https://forums.xfinity.com/t5/Your-Home-Network/Information-Requested-for-Connection-Related-Posts/m...

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: XFI is slow and drops to devices

I have had the same problem. Also the pods dont work efficiently in areas that are at the farthest distance from the gateway (which is the problem and why we got it in the first place).  Had difficulty in adding echo plus as a device, printers as well. All in all, it didnt do the job we wanted it to and it caused problems. Whole thing is a gimmick.

New Poster

Re: XFI is slow and drops to devices

I have just put the Xfi Gateway in my house. And it is worse now. I just did speed test and it was 

Download: 1.4mbps, Upload: 3.6mbps, latency 45ms. I see many people are/were having trouble, I just wanted to add my comment. The other modem was bad but this is worse. Help?!

Silver Problem Solver

Re: XFI is slow and drops to devices


@phobos2995 wrote:

I have just put the Xfi Gateway in my house. And it is worse now. I just did speed test and it was 

Download: 1.4mbps, Upload: 3.6mbps, latency 45ms. I see many people are/were having trouble, I just wanted to add my comment. The other modem was bad but this is worse. Help?!


Start here;

 

https://forums.xfinity.com/t5/Your-Home-Network/Connection-Troubleshooting-Tips/m-p/1253575#M94474

 

https://forums.xfinity.com/t5/Your-Home-Network/Information-Requested-for-Connection-Related-Posts/m...

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Official Employee

Re: XFI is slow and drops to devices

@phobos2995 wrote:

I have just put the Xfi Gateway in my house. And it is worse now. I just did speed test and it was 

Download: 1.4mbps, Upload: 3.6mbps, latency 45ms. I see many people are/were having trouble, I just wanted to add my comment. The other modem was bad but this is worse. Help?!

Start here;

 

https://forums.xfinity.com/t5/Your-Home-Network/Connection-Troubleshooting-Tips/m-p/1253575#M94474

 

https://forums.xfinity.com/t5/Your-Home-Network/Information-Requested-for-Connection-Related-Posts/m...

Definitely start here: https://forums.xfinity.com/t5/Your-Home-Network/Connection-Troubleshooting-Tips/m-p/1253575#M94474

 

It is the troubleshooting bible. After troubleshooting and the speed problems persist, let me know and I'll take a closer look. 

 

Ken


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XFI is slow and drops to devices

Thanks Ken, the technician was here today and he went on ladder , put up new line, put the Gateway upstairs out of the basement and when he left he told me the internet was still on and off! He said we were at the "end of the line" and that he would tell them and they would have to come and check wiring on poles around us.  So I am still paying for lousy internet.

Official Employee

Re: XFI is slow and drops to devices

My apologies for the delay, phobos2995. I can check if the order to check the lines around your house was put to the system. Could you please send me a message with your first and last name?  Click on my name ComcastElla, then click Send a message.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!