Community Forum

XFI Pods don’t help

New Poster

XFI Pods don’t help

So I’ve installed my new Pods, they do not improve poor signal or through put in the area I need it most. And when I move from one room to another assuming it switches pods I lost connection to the WiFi and have to turn off my iPhone WiFi on and off. If there is a fix or if it takes time for the XFI pods to settle I would love to know it, otherwise these are going back.
New Poster

Re: XFI Pods don’t help

And I couldn’t stand it, I unplugged the XFI pods, the lack of helping dead spots or low throughput. Coupled with my cell apparently not switching well between pods, the XFI pods are ideal for me. Will Be Be sending them back.
New Poster

Re: XFI Pods don’t help

That should have read NOT ideal for me 😊
Silver Problem Solver

Re: XFI Pods don’t help

I skipped the Pods and purchased an Orbi wifi solution; my wifi has worked better than any other solution I have tried.  None of the Comcast gateways I have used over the years had good wifi performance.

https://www.amazon.com/NETGEAR-Orbi-Ultra-Performance-Whole-System/dp/B01K4CZOBS/ref=sr_1_1_sspa?key...

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: XFI Pods don’t help

Thank you I will give this a look! I appreciate the time you took to reply!
Silver Problem Solver

Re: XFI Pods don’t help


@TimG1 wrote:
Thank you I will give this a look! I appreciate the time you took to reply!

BTW, Orbi is pretty expensive.  There are other solutions - check this out:

https://www.smallnetbuilder.com/tools/rankers/wifi-system/view

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Valued Contributor

Re: XFI Pods don’t help

Have had nothing but problems with the PODs.  The Comcast techs can't support them as they have never been given any training on them.  If they are sent out on a call and show up they will tell you that they can't do anything with them.  They aren't given samples to test, they are told that they have to buy them which most don't want to have to do.  The last one that came to my house said (get rid of them and purchase these.  https://smile.amazon.com/gp/product/B01MAW2294/ref=ox_sc_saved_title_4?smid=ATVPDKIKX0DER&psc=1.

 

Next time mine go off line and won't reconnect (have had this happen 3 times and the only solution is to replace all the pods as well as the modem), I will be getting these.  Really poor customer relations to sell a product that you can't support.

 

Official Employee

Re: XFI Pods don’t help

Hi spacecadet57. We appreciate you visiting and posting on the Xfinity Forums. I can assist with troubleshooting your xFi Pods connectivity issues. Please reach out to me via private message and include your full name so I can assist you. You can click my name (ComcastJoeTru) to view my profile and send me a private message. Click "Send a private message" and private message me.
 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Official Employee

Re: XFI Pods don’t help

Hi TimG1.  I did not receive a private message from you. This thread is now locked. Please send a private message if you continue to need help with this, or create a new post if you need assistance with anything else. Thank you.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!