Community Forum

XB6 Modem 5ghz Modem Problem

Highlighted
New Poster

XB6 Modem 5ghz Modem Problem

Hey guys!

 

So I just got the new XB6 modem and have had nothing but trouble with network connectivity since I got it. Could connect to the 2.4ghz and 5ghz, but the modem itself couldnt connect to the internet. 

 

So here's what I've done so far.

 

Comcast support for all the basics. 

Reset Modem

Reset Network

Factory Reset Modem

Disabled/Reinabled Wireless Networks. 

 

NONE OF THESE WORKED.

 

So I had it replaced. 

 

When I got this one home I hooked it all up, now I can connect to the 2.4ghz network just fine and get internet, but when I connect to the 5ghz network, it still says "no internet access" on MULTIPLE DEVICES. I don't know what to do at this point. My old modem from Comcast was slowing down and it was terrible. I thought the upgrade to the XB6 was the key, unfortunately, with a non working 5ghz network, I might have to go back to an old one?

 

I need internet for my job, but I definitely need fast internet to get things done efficiently. I know it's a first world problems, but any input would be helpful! I am very familiar with tech, so even if the answers are nerdy, I'm in!

Highlighted
Silver Problem Solver

Re: XB6 Modem 5ghz Modem Problem


@DJCredo540 wrote:

Hey guys!

 

So I just got the new XB6 modem and have had nothing but trouble with network connectivity since I got it. Could connect to the 2.4ghz and 5ghz, but the modem itself couldnt connect to the internet. 

 

So here's what I've done so far.

 

Comcast support for all the basics. 

Reset Modem

Reset Network

Factory Reset Modem

Disabled/Reinabled Wireless Networks. 

 

NONE OF THESE WORKED.

 

So I had it replaced. 

 

When I got this one home I hooked it all up, now I can connect to the 2.4ghz network just fine and get internet, but when I connect to the 5ghz network, it still says "no internet access" on MULTIPLE DEVICES. I don't know what to do at this point. My old modem from Comcast was slowing down and it was terrible. I thought the upgrade to the XB6 was the key, unfortunately, with a non working 5ghz network, I might have to go back to an old one?

 

I need internet for my job, but I definitely need fast internet to get things done efficiently. I know it's a first world problems, but any input would be helpful! I am very familiar with tech, so even if the answers are nerdy, I'm in!


Is the XB6 set with one SSID or two?

https://www.xfinity.com/support/articles/view-change-wifi-password

If it is set for one, 2.4 and 5.0 devices should be able to connect to the single SSID.

If it is set for two SSID's, you should be able to connect to both; I have an older iPad that only supports 2.4 and it connects fine to my single SSID.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Highlighted
New Poster

Re: XB6 Modem 5ghz Modem Problem

Yep! I get that! I had to set it to two different networks because the 5 gigahertz that my devices were defaulting to was not connecting to the internet. Only the 2.4ghz is. Therein being the problem. So I made the two networks separate so I could connect all my devices to the 2.4ghz since the 5ghz will not connect to the internet. The 5ghz DOES broadcast, and I can connect devices to it, however it does not connect to the xfinity internet.
Highlighted
Official Employee

Re: XB6 Modem 5ghz Modem Problem

DJCredo540, thank you for the update! I can help out with the internet connection. Please send over a PM with your first and last name so I can take a look at the account further. Thanks! 

To send me a Private Message, please click my name “ComcastAlly” and click “send a message.”


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!