Community Forum

WiFi pods up/down, replaced, still down. Next?

New Poster

WiFi pods up/down, replaced, still down. Next?

I purchased 3 pack pods online installed easily and immediately provided better coverage. FFW 3 months, they all drop, fail to complete reconnect and show up as ghosts on the xFi app. I replaced the pods (zero value) at the local store and same results as the original pods. Later a technician came out and mentioned a “power issue on the outside” was repaired and to proceed to add the pods. I think we can rule out the pods at this point, is the router/modem next to get swapped out? Could this be a result of firmware introducing incompatibility
Highlighted
Official Employee

Re: WiFi pods up/down, replaced, still down. Next?

Rosenserg - Thanks for reaching out.  I was able to pull up your account & am seeing one Pod online.  Can you provide any additional detail?  Did you try onboarding the other two Pods?  Are you getting an error message when trying to onboard?  Any timestamps you can provide would be helpful for troubleshooting.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: WiFi pods up/down, replaced, still down. Next?

I just noticed that too, thanks for replying, I will try the other 2 pods and let you know.
New Poster

Re: WiFi pods up/down, replaced, still down. Next?

I was able to add the other 2 pods and all three are online now. I’m not sure if I just had to wait until whatever “power issues” that we’re fixed the other day took affect or if anything else was done remotely but I’m back in business now. Thanks!