Community Forum

When will xFi support port forwarding to devices with an IPv6 address?

Frequent Visitor

When will xFi support port forwarding to devices with an IPv6 address?

I learned the hard way that the xFi software is unable to port forward to a device that has both an IPv4 and IPv6 address, and that you have to disable IPv6.

I don't like the idea of that, but to make matters worse because that Linux box at one point in time had an IPv6 address, the modem will NOT forget it, despite unplugging it and power cycling the modem.

If you're going to force us to disable IPv6 (which IMHO is silly, and should be fixed), at least give us a way to "forget" a connected device's old IPv6 address, or tell us how absurdly long we have to wait for it to forget about it.

New Poster

Re: When will xFi support port forwarding to devices with an IPv6 address?

Does your device show up after you disable it? I've disabled the IPV6 protocol and left my IPV4 to set automatically and still no luck. My PC doesn't show up as a device in the port-forwarding page.

Frequent Visitor

Re: When will xFi support port forwarding to devices with an IPv6 address?

No it doesn't, I disabled IPv6 a while ago, still hasn't figured it out. I've also left the Linux box unplugged while I power cycled the modem, to no avail. Really annoying.

I guess my next step is going to be spoofing a different MAC address to force it to think it's a different "device" so it doesn't have an IPv6 address. It's utterly ridiculous that Comcast decided to dummy down port forwarding any only allow it on the xFi portal and in doing so made a feature most normal users won't use unusable.

Frequent Visitor

Re: When will xFi support port forwarding to devices with an IPv6 address?

Finally got this to work. Here's what I did:

- disable IPv6 on Linux box, confirming it did NOT have any IPv6 on the ethernet interface
- disconnect Linux box from ethernet
- unplug cable modem for 5 minutes
- plug back in and wait 15 minutes

- plug Linux box back into ethernet


At that point, the connection showed up in the port forwarding list. Hope that helps!