Community Forum

Unable to remove/deactive xFi Pods from my account

Regular Visitor

Unable to remove/deactive xFi Pods from my account

I recently disconnected my Xfinity service and gifted my xFi Pods to a friend but I did not deactivate the pods before the account closed.  My friend is unable to activate the pods and I cannot deactivate them on my end.  Please help.

Official Employee

Re: Unable to remove/deactive xFi Pods from my account

Happy to assist.  Can you please send me a Private Message & provide the serial numbers of the Pods? You can send a Private Message by clicking on my username "ComcastRachelH" & then on the blue "Send a Message" button from my profile. Thanks!


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Unable to remove/deactive xFi Pods from my account

Thanks Rachel, I sent you a PM with the details.

Regular Visitor

Re: Unable to remove/deactive xFi Pods from my account

I’m having the same problem. Can you please help me too?
Highlighted
Official Employee

Re: Unable to remove/deactive xFi Pods from my account

Jonnywa123 - Thank you for sending the additional detail via PM.  I will respond to you there when I have more information.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Unable to remove/deactive xFi Pods from my account

RachelH, I also have the same issue. I installed Xfi pods yesterday. I then removed it and deactivated it using the Xfi app. My account still belives it is there. Not able to remove it. I am not able to get manual settings. It still says that 2.4G and 5G networsk are being managed automatically. Because of this I am not able to manage any settings automatically. Especially the Channel width and selection. Can you please help me in that. I have send a private message also. It would be highly appreciated if one of Comcast employee can help me with this request. I spend almost 8 hours with Comcast support and i was transferred repeatedly and nobody was able to help me with that.