Community Forum

The Now apparently infamous Xfi Pods

Highlighted
New Poster

The Now apparently infamous Xfi Pods

Hi,

I had a perfectly operating system with the new Xfi modem, 20+ devices running and over 250mb download speed on hardwire ethernet, plus exellent wifi connections for 4 TV's, two laptops, two phones, tablets, etc. My package offered free Xfi Pods to improve service, so I requested a set of three. I work a fair amount of computer and network stuff, and I have tried all the suggestions made in nearly a dozen question threads.

My setup with the Xfi pods went normally, but within a couple of hours the wifi system slowed to a crawl, dropped off and on, as well as the pods dropping off and not being "resettable." After 4-5 attempts, including a couple of modem/router resets, and waiting 24 hours to see if the system learned anything from itself, I finally gave up and uninstalled the three Xfi Pods. My system immediately went back to its original "excellent" service.

 

I do not know what the issue is with the pods, but they certainly did not help my system. I used Google pods (wifi mesh) before I got the new Xfinity supermodem, and never had any issues with them, so I assumed I would get the same "betterness" with the Xfi pods -- not so. They cost me nothing in theory, so I do not have much of a beef other than wasting 4-6 hours on them. Has I paid real money, I would be quite irritated. They are still plugged in, but offline and "disonnected." In a few days, I'll pull them completely unless someone can assure me that there is a way to make them work without reducing wifi speed to nothing or dropping off entirely.

 

My bottom line would be to try something other than the Xfi pods, but certainly not to pay $119 for a set of three. 😞  That said, the new modem (Xfi Gateway) and package (Xfi Advantage) are fantastic and I am overall a quite happy customer!

 

Ed P.

Highlighted
Official Employee

Re: The Now apparently infamous Xfi Pods

Hi Ed -- Thanks for reaching out & taking the time to share your experience with Pods. It sounds like the performance issues you've described could be due to the initial placement of the Pods and the network not having the chance to fully optimize.

Let us know if you have any performance issues with the new Gateway & we can help troubleshoot.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: The Now apparently infamous Xfi Pods

Nope I had the same experience and unfortunately I paid for mine. I love how I bought these to “IMPROVE” my network and yet it did the exact opposite and now I’m out of that money I spent on them. Complete trash.
Highlighted
New Poster

Re: The Now apparently infamous Xfi Pods

Same issue here! Pods don’t do a darn thing! Husband is now asking if we can just go back to AT&T. Slower speed, but at least the service is consistent.