Community Forum

Re: xFi Pods Going Offline

New Poster

Re: xFi Pods Going Offline

I’ve been having the same issue for the last week. I’ve been using the pods for 6 months and have 0 issues. Last few weeks they go offline multiple times a day. I’m about to pull them down completely. What a waste of money as I bought 2 packs.
Highlighted
Official Employee

Re: xFi Pods Going Offline

jakobfisher - Thanks for reaching out. I apologize for the frustration. I've pulled up your account & would like to share this issue with engineering to troubleshoot. Can you please send me a Private Message & provide some additional details -- Can you provide any timestamps that the Pods went offline?  Additionally, can you confirm that the Pods are currently plugged in?  Can you also confirm the Serial Numbers of the Pods?

 You can send a Private Message by clicking on my username "ComcastRachelH" & then on the blue "Send a Message" button from my profile. Thanks!


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: xFi Pods Going Offline

I’m having the same issue.  I have 6 pods.  3 are staying connected, 3 continually disconnect and after a few minutes, reconnect.  The ones that are disconnect are using the others as “pass through” devices.  These worked great for several months, now they are acting up again.  Tonight, they have gone offline 5 times so far.  

New Poster

Re: xFi Pods Going Offline

I have been having the same problem for about a month. Very frustrating. Suddenly all pods are offline. And now on my app, sometimes it shows that all pods are offline, and sometimes it doesn’t even remember that I ever had pods. Ugh.
Regular Visitor

Re: xFi Pods Going Offline

Since I posted, mine have been more stable. I’m looking at putting in a second network with another mesh network for better stability. My entire security system runs off this and it’s not good when it drops all the time.
Frequent Visitor

Re: xFi Pods Going Offline

I am seeing the same thing for the last week or so all 3 of my pods are permanently offline unplugging and unplugging them does not seem to reconnect them. The app shows only 2 of the 3 and those as offline
New Poster

Re: xFi Pods Going Offline

Had a mind bending 3 HOURS of trying to get Comcast to help me get my pods back online when they dropped off the planet entirely. My app wasn’t even showing them as offline: they were not listed at all.
After hanging up on them. I deleted and reinstalled the app, unplugged the pods, and plugged back in. Nothing.
Then I unplugged one, plugged it back in, and started a new setup process in my iPhone. The app spun and spun and didn’t connect. When I abandoned the process, suddenly a screen of all 6 pods trying to connect appeared. Low and behold, they each connected one at a time, and even their names reappeared. Black magic.
How long will it last? Who’s to know.
I guess the crux of this is to unplug all pods, delete and reinstall the app, plug pods back in, log in to app, go to re-set-up one, and cross your fingers!