Community Forum

Re: Pods

New Poster

Re: Pods

I have the same issue with three new pods, all online and no devices connected. Meanwhile I have the “dot” (no bars) on my WiFi indicator on my laptop with an xFi pod in the same room. It will not connect to my laptop.
Official Employee

Re: Pods

Hi, Lisamm! Welcome to our community! When did you install the pods? 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Pods

Hello. I installed them on Sunday 5/26/19. They all show online on the xFi app.
Official Employee

Re: Pods

@Lisamm - The xFi Pods will work together with your gateway to determine the best connection for your devices. It does take time to create the "mesh" network. Are all pods online? 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Pods

Yes all pods are online. How long does it take to create the “mesh?”
Official Employee

Re: Pods

@Lisamm - It depends on your network, WiFi coverage, "dead spots", and on the number of the devices you have. I'm happy to follow up on Sunday 6/02 to check in on your services. If it still won't get connected - I can definitely escalate it further. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Pods

XFi pods still are not connected to anything after 6 days and my wifi signal is actually worse now. I have devices that can't even find the network anymore.  PLUS the pods themselves are hot - they are a fire hazard! Our house isn't that big, the router is directly beneath the pod and nothing works. My Netgear extended did a better job than something that is supposed to be compatible with our Xfninity leased router and our Xfinity service. What a disappointment. 

Frequent Visitor

Re: Pods

I was planning on putchasing some pods, but thanks to all you guys for reporting problems you have with them.  I think I will wait.  Maybe even go back to my own router.  Appears to be to many issues.  Maybe some hardware released before it was ready?

Official Employee

Re: Pods

@Lisamm -  I can't check if there are any issues with the pods without your information. Could you please send your first and last name? Thank you in advance, 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Pods

Purchased a Netgear AC1900 Dual Band extender and within 15 minutes went from "poor" to "excellent"signal. Thanks to Best Buy for helping me find the right product.