Community Forum

Port forwarding not working

New Poster

Port forwarding not working

I see the forums have had this topic before and hope by now there was a solution but perhaps not. It will not work for me. I have a very specific device that requires port forwarding. I had it setup previously on a CenturyLink DSL system and worked flawlessly for three years. Now I switch to the Comcast system and it will not work. It appears Comcast does not want to solve this problem for I know more about such issues than the 6 or more techs I’ve talked to. Do I need to by my own modem? If yes, is there one that is highly recommended? Cost not the issue, or do I need to go back to CenturyLink?

Silver Problem Solver

Re: Port forwarding not working


@mjrelph wrote:

I see the forums have had this topic before and hope by now there was a solution but perhaps not. It will not work for me. I have a very specific device that requires port forwarding. I had it setup previously on a CenturyLink DSL system and worked flawlessly for three years. Now I switch to the Comcast system and it will not work. It appears Comcast does not want to solve this problem for I know more about such issues than the 6 or more techs I’ve talked to. Do I need to by my own modem? If yes, is there one that is highly recommended? Cost not the issue, or do I need to go back to CenturyLink?


You didn't say which Comcast Gateway you have, but since you posted in this forum, maybe this will help:

https://www.xfinity.com/support/articles/xfi-port-forwarding

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Official Employee

Re: Port forwarding not working

Hi, I'd be happy to help. Can you please provide some additional details on the issue you are experiencing? 

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Port forwarding not working

i am having a really rough time as my computer isnt showing up on the list of devices available for portforwarding. 

my computer for sure uses ipv4 not ipv6 

ive changed the lan setting to try to fix it.

my device is listed in connected devices

Official Employee

Re: Port forwarding not working

i am having a really rough time as my computer isnt showing up on the list of devices available for portforwarding. 

my computer for sure uses ipv4 not ipv6 

ive changed the lan setting to try to fix it.

my device is listed in connected devices

Mphillips604, thanks for posting and confirming the computer isn't using iPv6. I'd like to take a closer look at this for ya. Please send me a private message with your full name for help. Just click my name and then on the next page, you'll see an option to send me a private message on the top right hand side.  


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Port forwarding not working

I'm having exactly the same problem, with my device not appearing on the port forwarding popup list even though it appears as a connected device.  It has a perfectly good ipv4. 

 

Can you please post the solution you faound for the other user?   Or was it not possible to fix, and everyone should go buy their own modem?

Official Employee

Re: Port forwarding not working

dtclemens, is your computer dual stack for ipv4 and ipv6? If so, when you made the ipv4 address your active profile, did you reboot your modem and your computer? 

 

Ken


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!