Community Forum

Just upgraded to Xfi and my Xbox reports a double NAT

Highlighted
Regular Contributor

Just upgraded to Xfi and my Xbox reports a double NAT

So the Comcast guy just left after instaslling the new Xfi modem, everything works but My Xbox is now reporting a double NAT. Previously this did not happen.

 

I only use the Xfinity equipment as my modem I have a Wifif router connected that serves my internal Wifi.

 

I've read that I need to turn on brdige mode on the new Xfi modem but going through the Xfi app I'm not able to find a place to enable bridge mode.

 

Just to be further clear my home router is not the issue as before the older Xfinity Modem did not report a double NAT issue, the new Xfi modem is the cause of it.

Silver Problem Solver

Re: Just upgraded to Xfi and my Xbox reports a double NAT


@swanlee wrote:

So the Comcast guy just left after instaslling the new Xfi modem, everything works but My Xbox is now reporting a double NAT. Previously this did not happen.

 

I only use the Xfinity equipment as my modem I have a Wifif router connected that serves my internal Wifi.

 

I've read that I need to turn on brdige mode on the new Xfi modem but going through the Xfi app I'm not able to find a place to enable bridge mode.

 

Just to be further clear my home router is not the issue as before the older Xfinity Modem did not report a double NAT issue, the new Xfi modem is the cause of it.


Do you have any other network devices like the Apple Airport?

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Just upgraded to Xfi and my Xbox reports a double NAT

If you have not figured this issue out already, you likely just need to configure the new XFi modem to be in bridged mode.  See:  https://www.xfinity.com/support/articles/wireless-gateway-enable-disable-bridge-mode

 

This worked for me.

New Poster

Re: Just upgraded to Xfi and my Xbox reports a double NAT

Note: you can do this from a web browser for me it was simply http://10.0.0.1 which I believe is the default on the XFi modem.