Community Forum

Just set up my xFi, 7 devices already show up connected to it

Highlighted
New Poster

Just set up my xFi, 7 devices already show up connected to it

I recently moved and just picked up my xFi from the local store. I installed it using the xFi app, and as soon as I got it up and running I see 7 devices already connected to it, including an iPhone (not mine), an iPad, an amazon echo, what I assume to be a printer, and a few others. I don't own any of these products, and I don't know how they would be connected to my wifi already since I hadn't even connected my own devices yet, and my wifi is password protected. They all seem to be on the 5GHz band if that makes a difference.

 

Why is this happening, how do I prevent it from happening in the future, and is pausing the devices enough to protect my network? I can't figure out how to delete them permanently on the app. Thanks!

Official Employee

Re: Just set up my xFi, 7 devices already show up connected to it

Hi @jax6 

 

Thanks for reaching out.  I was able to pull up your account & take a look at the issue you described. I have sent you a private message with additional information. Private messages can be accessed by clicking on the envelope icon in the upper right hand corner of any forums page. Thanks!

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!