Community Forum

Having FaceTime problems with new Xfi pods...

New Poster

Having FaceTime problems with new Xfi pods...

So installed last night and that was a adventure. FaceTime for maybe a minute then it just drops the call...any reason why?
Silver Problem Solver

Re: Having FaceTime problems with new Xfi pods...


@Aphextwin002 wrote:
So installed last night and that was a adventure. FaceTime for maybe a minute then it just drops the call...any reason why?

It might be because of the distance from the nearest wifi signal.  Does it drop while standing next to a pod?

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Having FaceTime problems with new Xfi pods...

Yes it does! Right next to it.
Highlighted
Official Employee

Re: Having FaceTime problems with new Xfi pods...

Aphextwin002 -- I pulled up your account & it looks like you recently onboarded the Pods.  When you first onboard the Pods, your home WiFi network will optimize over the next few days. I'd like to check back with you tomorrow & see if anything improves.

That said, can you let me know if this is happening with all the Pods or one in particular?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!