Community Forum

Frustrated with wifi speed, xFi Pods and Xfinity customer service

Frequent Visitor

Frustrated with wifi speed, xFi Pods and Xfinity customer service

I live in a 2,000 square foot townhouse that is split up over 4 levels. My wifi coverage has always been just OK which was mitigated by the fact that I do have ethernet hardwired to each level of the house. Improving wifi has always been on the to do list. Xfinity recently contacted me to ask if I wanted faster speeds for the same price under my current Blast tier. They sent me a new router to self install. Several weeks later, lots of headaches, wasted calls with incompetent support staff and trips to Xfinity stores, I finally have the network functional. However I am not pleased with the performance and am a now obsessed with getting it up to par given the time invested in this.

 

The Good: speeds via hard wired connections are consistently 250 mbps+ via all hard wired connections throughout the house (upload speed averages 11-12 mbps but I'm not sure what expectations should be there. IF in the immediate vicinity of the router wifi speeds are comparable if a touch below this.

 

The Bad: wifi speeds away from the router are very inconsistent, topping out at 30 mbps and sometimes much slower. Xfinity told me that I needed to buy their xFi pods and my problems would be solved. I purchased and installed 3 pods, and performance is only slightly improved. The areas with the worst performance (sub 10 mbps) have been stabilized and slightly improved, but overall the performance is still inconsistent and slow (some areas may honestly be slower).

 

The rep at the Xfinity store told me that as I had wired ethernet, I could plug that into the pods and get fast performance throughout my house. However in reading through these forums it seems that ethernet backhaul is specifically NOT supported by xfinity for some reason. I have not yet tried to test this as I am giving the pods a few days to optimize and see what does for performance before monkeying around more. However I have a hard time imagining significant improvements.

 

My question is where to go from here? Is there a solution I am missing via Xfinity? My next move may be to return the pods, buy a 3rd party system that supports ethernet backhaul (such as Orbi) and just put the Xfinity router into bridge mode. I'd love to simplify and stay with the Xfinity only system, however my household is demanding more and better wifi performance. The pods just aren't preforming as advertised.

Silver Problem Solver

Re: Frustrated with wifi speed, xFi Pods and Xfinity customer service

You may have gotten some bad advice.

I have escalated your issue to the Comcast Team available to these forums. Check back often for a reply in this thread from a Comcast Official Employee.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: Frustrated with wifi speed, xFi Pods and Xfinity customer service

It would be great to hear from someone competent at Xfinity, as all I have received is conflicting or straight up ignorant advice.

 

After 72 hours for the pods to "optimize" preformance has not improved at all. Actually the wifi speeds I am getting in some areas are slower with the pods.

Frequent Visitor

Re: Frustrated with wifi speed, xFi Pods and Xfinity customer service

Welp, the worthless xpods went back. Xfinity was not willing or able to help. I've never seen worse coordination among channels (phone, stores, forum). It's as if none of the people work for the same company.

 

I got the Orbi system setup and installed in a snap. Only 2 units (router & satillite) blanked my 4 story home with a warm blanket of consistently 250+mbps wifi (I was getting as low as 20 with the xpods).

New Poster

Re: Frustrated with wifi speed, xFi Pods and Xfinity customer service

Very similar issue. Pods do not function as I had hoped and I only am in a 1700 sq ft ranch. Cannot get consistent service in office or bedroom even with pods. Smiley Sad
New Poster

Re: Frustrated with wifi speed, xFi Pods and Xfinity customer service

Having similar issues... 5 bedroom house, wifi is pretty good, but not always available, and speeds are 30-50 mbps, instead of the 250 we consistently get if we're on the gateway's network.

 

My main question is, wih the Orbi, will it assume and extend your gateway's network name, or do you wind up with the Comcast network and then Orbi's network SSIDs?

 

That is one thing I like with the xFi pods – one network everywhere.

 

Thanks!

Highlighted
Frequent Visitor

Re: Frustrated with wifi speed, xFi Pods and Xfinity customer service

My plan is just to put the Xfinity modem in bridge mode once I'm sure everything is stable. This will essentially turn off the wifi router in the Xfinity router. I have port 1 on the Xfinity gateway going directly into my Orbi router, when then connects to an ethernet switch going to other locations and devices in my house. I don't even have the ethernet backhaul set up on the Orbi yet, as there is really no additional wifi speed to be gained at this point. The Orbi has been rock solid with no dropped connections and solid speed. I'm giving it a few more days until I put the gateway into bridge mode as I try to have as few moving pieces at a time when testing my network.

 

I'm no expert, however I don't see any reason why you couldn't set up an Orbi (or other system) with the same SSID as your Xfinity gateway. However they wouldn't optimize and you may have an issue with a device defaulting to a weaker AP (for instance if you are far away from the Xfinity gateway. With the thorough coverage I am getting from the Orib I will simply kill the Xfinity wigi, or ignore that network.