Xfinity plant
Xfinity globe
Community Forum

Firmware upgraded needed for Pods?

Regular Visitor

Firmware upgraded needed for Pods?

I'm going to order some xFi Pods today (or see if they have them in our Service Center). I've read about a lot of people needing firmware upgrades before they work. Is this supposed to happen automatically? I checked and my firmware is at DPC3941_2.7p8s1_PROD_sey. I tried rebooting a couple times and it's still at that version.

 

Thanks,
Ed

Official Employee

Re: Firmware upgraded needed for Pods?


@EdBR wrote:

I'm going to order some xFi Pods today (or see if they have them in our Service Center). I've read about a lot of people needing firmware upgrades before they work. Is this supposed to happen automatically? I checked and my firmware is at DPC3941_2.7p8s1_PROD_sey. I tried rebooting a couple times and it's still at that version.

 

Thanks,
Ed


At this time, xFi Pods are only available for customers in Boston, Chicago, and Colorado through purchase online by visiting www.xfinity.com/xFipods. If you do order or have already ordered Pods, you will need a firmware upgrade. If you still see your firmware version as 2.7, please send me a private message and I will have you added to the firmware upgrade list for Pods.