Community Forum

Connected devices show as not connected.

Frequent Visitor

Connected devices show as not connected.

Occasionally I try to use my Xfi app to check my network to see if my devices are connected to 5ghz or 2.4ghz. Generally the app shows about half of my 6 devices as DISconnected, even though each device shows that it is connected to WiFi and functioning normally. How do I get all my connected devices to show up as connected.
Official Employee

Re: Connected devices show as not connected.

Hi WillisC, are you using any sort of an extender?


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Connected devices show as not connected.

No extenders.  And it doesn't make any difference if I disconnect the device from WiFi and then reconnect.  It shows on the list, but as "unconnected".

Official Employee

Re: Connected devices show as not connected.

Thank you for that answer. I can assist you.

So that I can take a look at your account, please send me a private message and include your full name and account primary email address. Please click on my name to see my profile, and then hit the blue "Send Message" button.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Connected devices show as not connected.

What was the resolution? I am seeing the same thing.

Frequent Visitor

Re: Connected devices show as not connected.

There was no resolution initially, but in the past week or so all my devices have begun showing up as connected.  Don't know what changed; nothing at my end.

New Poster

Re: Connected devices show as not connected.

We are having the same problem. How do we go about correcting it?

Frequent Visitor

Re: Connected devices show as not connected.

Don't know.  For me it corrected itself without any tweaks on my part.

Contributor

Re: Connected devices show as not connected.

It shows my iPhone is not connected... but I'm using that device to ACCESS the gateway!!

 

My guess is that there will be an update to this buggy app real soon now.

 

Contributor

Re: Connected devices show as not connected.

There has been an update to the app but it still shows my iPhone 7 as "not connected"  which makes no sense since I'm using THAT PHONE  to monitor the network! How can the iPhone not be connected and still show all the other devices, etc.?

 

We had an outage last week and the gateway resynced (maybe it re-booted?) when the line came back (after about an hour... outages have been rare here... we love Comcast... get service!) So I thought that might 'fix' the iPhone Xfin app.... but it didn't. 

 

I have no faith in the integrity of the app and as such I won't use it for anything. It is just as easy to login to the gateway via the browser  via http://10.0.0.1 and administrate from there.  

 

Al

 

New Poster

Re: Connected devices show as not connected.

Hi, I have the exact same problem. What is an extender?
Valued Contributor

Re: Connected devices show as not connected.

Was there ever a solution to this?  I am having the same problem, no Pods, no extenders, just the gateway.

 

Thanks.

Contributor

Re: Connected devices show as not connected.

I've not heard of a solution. I'm a iPhone software developer and I have some ideas as to what the probem is.... it could be a whole host of things... and without seeing the code I would not venture my guess in public. I'm sure they will find it and fix it. It is not like it is a high priority app for any of us.

Valued Contributor

Re: Connected devices show as not connected.

Well for Comcast, it's a high priority app.. and since this problem deals with iPhones, which is sorta a popular phone, I would suggest they fix it.

 

The xFi app is NO good if we can't do what it says we can with it.  How can we control a childs WiFi usage on an iPhone if it says never connected, but it is!?

Contributor

Re: Connected devices show as not connected.


@joey12volt wrote:

Well for Comcast, it's a high priority app.. and since this problem deals with iPhones, which is sorta a popular phone, I would suggest they fix it.

 

The xFi app is NO good if we can't do what it says we can with it.  How can we control a childs WiFi usage on an iPhone if it says never connected, but it is!?


Can you do any of this from the gateway itself via http://10.0.0.1 ?  Or maybe from the Xfinity account on the web? I thought this app was just a substitute for direct administration of the gateway box via the 10.0.0.1 interface.

 

 

Official Employee

Re: Connected devices show as not connected.

Hi all, 

We're sorry to hear you are experiencing this issue with xFi. We would like to dig into these; next time you observe this happening can you please capture the below items and send to me in a Private Message? I can then forward to the team for investigation into this issue.

 

- A screenshot of xFi showing with the incorrect Offline status

- A screenshot of the device's WiFi connection showing the device is connected to your home network

- Date and Time of occurrence

 

OR 

 

- A screenshot of xFi showing with the incorrect Online status

- A screenshot of the device's WiFi connection showing the device is not connected to your home network

- Date and Time of occurrence

 

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Connected devices show as not connected.

I have been having the same problem. I would love to send you the requested information except I don’t know how to send you a private message
Silver Problem Solver

Re: Connected devices show as not connected.


@Lisabev wrote:
I have been having the same problem. I would love to send you the requested information except I don’t know how to send you a private message

Click on the name and the popup has a Send Message on the right side.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: Connected devices show as not connected.


@Al8041 wrote:
<<snip>>
It is just as easy to login to the gateway via the browser  via http://10.0.0.1 and administrate from there.  

 

 


Except when you Admin console screens LITERALLY takes 7-10 muntes per screen to load.  On the brand new super fancy gateway they are using.  Sigh.  I like a lot about the xFi interface (except that it was released woefully lacking in feature parity which seems silly) but would kill for decent Admin Console access.

Contributor

Re: Connected devices show as not connected.

My Arris gateway screen comes up using 10.0.0.1 in a few seconds so I don't know what the issue is with yours. I run an iMac on macOS High Sierra. 

 

Now my Accounts app says the gateway is not connected!!!  So according to these apps my iPhone is not connected to the gateway and the gateway is not connected to the internet... both are totally false. 

 

I've given up on both apps. I don't trust either of them. 

 

 

Frequent Visitor

Re: Connected devices show as not connected.

My screens are excritiatingly slow.  This is across multiple computers, multiple browsers, multiple OSes, via mobile browsers, firewalls and AV turned off.  This happens on my gateway and my 2 neighbors gateways (I help them with their stuff).   This has happened across multiples of the same gateway model (exchanged hardware) and across various models of gateways over the years.  Sometimes it will get better for a short period of time immediately after a gateway reboot, but that's about it.   The delays are also not consistent in length.  Sometimes a screen will come up in 30 seconds, sometimes in 4 or 5 minutes (most common) sometimes 7 or 8 minutes.  Some screens do seem sort of more consistently faster, but the ones that I want to use are not any of them. 

 

I'm not the only one with this issue.  I have researched this numerous times over the years to no avail.

 

I wrote this entire response waiting for the "connected devices" config screen to load.

 

Also, I too have been having the same issue with devices not showing connection status properly on occasion.  This seems to be a relatively new thing, in the past few months for me, but I admit that I don't usualy look at connection status too often as it isn't a super vital thing for me (I don't use bedtime nor parental controls, etc).

Contributor

Re: Connected devices show as not connected.

This is very strange.... especially over many different pieces of equipment, browsers, and equipment.

 

Are you connecting over ethernet or wi-fi? If ethernet maybe try a different Cat 6 cable?

 

What model of Gateway do you have, or are these separate modems and routers?

 

What does Comcast support say? 

 

Have them come out and bring a new box and see if it is slow for them? 

 

Keep us apraised.

 

 

 

Valued Contributor

Re: Connected devices show as not connected.

How to send screen shots. Its happening now.
New Poster

Re: Connected devices show as not connected.

Thank you. I have sent them everything and they replied saying they would forward it to their engineers.
Contributor

Re: Connected devices show as not connected.


@Lisabev wrote:
Thank you. I have sent them everything and they replied saying they would forward it to their engineers.

I did that eariler... and so far no results. I doubt it is a high priority item for their software developers.

 

New Poster

Re: Connected devices show as not connected.

I've had the same problem since I first started using the xfi app. My kids iPhone always shows not connected. It seems to connet briefly then switches to not connected. But I can see her using it the whole time! It's an iPhone 7. I can see that many others have had this issue. Just wondering if anyone ever got an answer.
New Poster

Re: Connected devices show as not connected.

Btw, I also tried looking at the admin panel at 10.0.0.1. It aslo shows the iPhone as offline, and yes it is online right now.
Silver Problem Solver

Re: Connected devices show as not connected.


@Pengi18 wrote:
Btw, I also tried looking at the admin panel at 10.0.0.1. It aslo shows the iPhone as offline, and yes it is online right now.

I've had the xFi feature since it first became available in my market.

I've never found any use for knowing whether a device is connected or not.  What can I use it for?

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Connected devices show as not connected.

I can only speak for myself, but my husband and I attempt to use it to monitor my kids data usage and time spent on the internet/their devices, of course that’s if the app actually worked.
Official Employee

Re: Connected devices show as not connected.

Hi everyone, we understand the frustration with devices not showing properly in xFi. We have shared these reports with the team and they are looking into them. 

I ask for the following next time you experience this issue:

1. Confirm that the device is still connected to your secured home network

2. Log out of and log back into the xFi app and check the device status

 

If the device is confirmed connected and refreshing the app did not resolve the status discrepancy in xFi, please send the following to me:

- Timestamp of the issue (date & time) & MAC address of the device (Device Details in xFi)

- a screenshot of xFi showing the device as "Offline"

- a screenshot from the device itself showing that it is connected to your secured home network

 

You can send me a private message by clicking on my name and then the blue "Send a Message" button. Use the "Photos" button to attach the screenshots.

 

I know some of you have already sent the above information to us and we thank you for that. 

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Connected devices show as not connected.

Same. Many connected devices don’t show up as connected (eg the phone I use to access the app). Also, many connected devices don’t show up at all.
Contributor

Re: Connected devices show as not connected.

This has been going on since the end of June... it is seven months later,  and Comcast programmers still can't figure it out? It is either that or this issue is not anywhere near a priority to them.  

New Poster

Re: Connected devices show as not connected.

I have been having this same issue for a long time.  I don't even use the app because it sounds like app has the same issues.  When I go to the Gateway (http://10.0.0.1/), many of the devices that are currently connected to (and being used on) our XFinity home wifi show as being "unconnected."

There is a real need to be able to see which devices are truly connected, especially when you have parental controls set and they apparently don't work because the child's device is not even showing as being connected, when it truly is.  My child uses a Macbook. Her iPhone also shows as being not connected.  It is very frustrating, especially when trying to prevent your child from being a computer gaming addict.

 

Please get this fixed. Make it the priority that it should be.

 

 

New Poster

Re: Connected devices show as not connected.

Oh, also, I have tried contacting Comcast by phone a few times about this. They have no idea what the Gateway even is ....

New Poster

Re: Connected devices show as not connected.

I'vev been having the same problem with connected devices showing up not connected when they are.  I've been "forgetting" them to remove them then allow the system to find them again.  It's a pain because I frequently have to do it.  Also, sometimes the IP and MAC addresses change for those devices.

New Poster

Re: Connected devices show as not connected.

I wish they would just tell us how to fix it, or implement a fix to the program.  Surely, Comcast has had enough time to examine this issue that so many people are having.

 

If the IP or MAC address changed, wouldn't it show up as something else? It's not.   My husband's Samsung Galaxy 8 phone was connected today, and it's not showing up either. However, mine is showing (same type of phone). Doesn't make sense.

 

New Poster

Re: Connected devices show as not connected.

For me, when the devices' IP and MAC addresses change they show up with some meaningless name or the name Windows gives the computer.  Or the name "Local" with another meaningless number after it.

 

I have all the information for my devices, but I'm always having to update them because of the frequent changes.  I believe my issue is related to intruders hacking into my Wi-Fi because I have issues with that too.

 

And yes it would be nice if they would let us fix it ourselves instead of treating us like idiots who don't know anything.  Verizon FiOS has a better system than Comcast where you can tweak just about anything.  Comcast system stinks.  It's designed for them to do it for you and from my experience they never fixed things.  I just complained about it in chat and threatened to cancel my service.  My mobile hotspot is faster and safer than Comcast service, and has more options.  It just runs out of data too quickly.

Official Employee

Re: Connected devices show as not connected.

Hi, to provide an update for everyone, we are continuing to investigate this issue.  Please continue to send these report to me via Private Message - include your account number, device MAC, a screenshot of xFI showing the incorrect status and a screenshot of the device settings showing it's connected to your network.

 

We are sorry for the inconvience. 

 

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Connected devices show as not connected.

I really just have the same issue. Says a device not connected but it is (I think). It can be personalized & stuff but I wonder if it could be since it a Guest device w/ full access. No clue really.
New Poster

Re: Connected devices show as not connected.

Hi All

This is SO frustrating
Like the rest of Comcast
But I guess this is what you get when there is literally no competition and cable companies carve out monopolies for themselves in large pieces of geography.

COMCAST - please fix this.

The whole point of this app is to control what our kids are doing. I can’t see my daughter online with her Mac and IPhone on the xFi app even though I am
Watching her stream you tube as I write this.

9 months and no solution.

PLEASE FIX THIS

otherwise we can only assume that you really don’t care as your are a monopoly and we can’t get another service provider.

So much for free enterprise
New Poster

Re: Connected devices show as not connected.

Same problem. It doesn’t recognize my AV home theater even while it’s on. When I try to get it to recognize the Sony device. It doesn’t even list AV box or home theater as one of the options for activation. I end up having to restart the entire system from the surge suppressor and restart everything.

Fix this problem. Comcast isn’t worth $320/month if I have to get up and reset my system every time I want to watch TV!
New Poster

Re: Connected devices show as not connected.

Seriously, Comcast. I was talking to my manager about this "nonconnected" issue, and he said the app is broken and they don't know how to fix it.  The parental controls are useless if chidren's devices are not showing as connected.  And they are so important these days.