Community Forum

Can't remove port from MyXFi port forwarding

Regular Visitor

Can't remove port from MyXFi port forwarding

I have seen numerous posts about this online, but none of the solutions worked. I was trying to forward a port for Plex. beofre, when the router handled this, I could add and remove ports with ease. Now with Xfinity handling this, I appear to be having serious issues. So, the port I am trying to remove is stuck with a non-associated device. The IP address it's attached to, used to be the IP of my PC, but when I reinstalled my PC with a fresh copy of Windows, I gained a new IP address. Now when I go to the port forwarding section of MyXFi, and try to remove the port, again which is attached to a non associated devide, I get the "We're Having Some Trouble" error. It doesn't matter which device I try to do this form, whether it's from my phone or my pc, and it doesn't matter if I'm actually on my network or not. I have RESET my router to factory, and I have changed the DHCP range. Nothing works, and I cannot remove the port. This is absurd, I do not want to reset my router again, and XFinity is ridiculous to have made this change in the first place. Thoughts or suggestions?

Official Employee

Re: Can't remove port from MyXFi port forwarding

Hi, I would be happy to help look into this. Can you please send me a private message with the specific information for the port forward that you are unable to delete (name and IP address that shows in xFi)? I can work on getting this deleted for you. 

 

To Private Message me, please click on my name and then "Send a Message". 

 

 

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Can't remove port from MyXFi port forwarding

 Hi 

I am having the same issue. Could you please help me ?

Thanks!

Regular Visitor

Re: Can't remove port from MyXFi port forwarding

I am having this problem as well. Port forwarding has worked for over a year, not it has stopped (perhaps there was a firmware update recently?). I cannot add/delete/change a port forward. I always get a message stating that something went wrong and to try back later. I have tried restarting the modem with no change.

Official Employee

Re: Can't remove port from MyXFi port forwarding

The team has identified this to be an issue with the Gateway's firmware. They are working on a fix. 

In the meantime they can manually remove ports that need to be deleted. 

 

@ZMerrell, there were multiple escalations regarding this that they are working on fixing. I will keep my eye on your ticket and let you know when the port has been removed. 

 

@abd84@pjlaskey, if there are specific ports you need deleted, please send me the port number and I can pass it along. 

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Can't remove port from MyXFi port forwarding

PM sent. Thank you!

Official Employee

Re: Can't remove port from MyXFi port forwarding

@ZMerrell, your port has been deleted. Please check in xFi at your convenience and let me know if you experience any more issues. 

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Can't remove port from MyXFi port forwarding

Yup! It is fixed now! thank you so much for your help!!!

Regular Visitor

Re: Can't remove port from MyXFi port forwarding

I sent you a messsage with the ports i need deleted, thanks


New Poster

Re: Can't remove port from MyXFi port forwarding

Hello,

 

Can you please help me remove a portforward?  

 

Thank you,

-J.R.  

Regular Visitor

Re: Can't remove port from MyXFi port forwarding

I need help from ComcastDaniella to delete port forwarding

New Poster

Re: Can't remove port from MyXFi port forwarding

Can you please delete all of the port forwarding on my XFi, I've really messed it up.

Regular Visitor

Re: Can't remove port from MyXFi port forwarding

I sent you a private message with the ports I need deleted.

 

Thanks in your advance for your help.

Regular Visitor

Re: Can't remove port from MyXFi port forwarding

I have been having this same issue since they forced all changes through the XFi app or using the web browser.   When I was able to login directly to the router, everything worked just fine.  I've had at least 3 different calls over the last 8 months with Xfinity support, since they have a terrible CRM system, I've had to repeat myself each and everytime to the 2nd level tech support. (last night was real funny the first support reps immediate response was to start troubleshooting call forwarding) Each time the support folks have the same issue, they can't login to the router and delete the port, nor can they do it from the XFi interface.  The ultimate resolution is to restore the router to factory defaults and reconfigure all the settings.  This is a bug in the XFi setup that Xfinity dosen't seem to have an answer for, nor are they interested in escalating the problem.   After posting this note I will be factory resetting my router AGAIN.  

Tags (1)
Official Employee

Re: Can't remove port from MyXFi port forwarding


@kaadeg01 wrote:

I have been having this same issue since they forced all changes through the XFi app or using the web browser.   When I was able to login directly to the router, everything worked just fine.  I've had at least 3 different calls over the last 8 months with Xfinity support, since they have a terrible CRM system, I've had to repeat myself each and everytime to the 2nd level tech support. (last night was real funny the first support reps immediate response was to start troubleshooting call forwarding) Each time the support folks have the same issue, they can't login to the router and delete the port, nor can they do it from the XFi interface.  The ultimate resolution is to restore the router to factory defaults and reconfigure all the settings.  This is a bug in the XFi setup that Xfinity dosen't seem to have an answer for, nor are they interested in escalating the problem.   After posting this note I will be factory resetting my router AGAIN.  


Can you please tell me what specific issues you would like to report around Port Forwarding? I would be happy to help, I will just need to get some information on what specifically you are experiencing trouble with. 

Please be advised, if you have an Arris 1682g Gateway and are experiencing problems with deleting port forwards, a factory reset is not going to resolve the issue. There is an open bug that the team is working on implementing a fix for. In the meantime, I would need to escalate a ticket to get this resolved. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Can't remove port from MyXFi port forwarding

The port forward I would like removed is:

 

10.0.0.193, Port 3389

 

Thanks,

-J.R.  

New Poster

Re: Can't remove port from MyXFi port forwarding

@ComcastDaniella

I'd like to remove all my port forwards. Can you help me?

Official Employee

Re: Can't remove port from MyXFi port forwarding

@collins_j22,I just sent you a PM, your ports have been removed. 

 

@LM16, your ticket is still sitting with the team. I anticipate it will get worked today and I will provide you an update in our Private Message conversation. 

 

@dmurtagh, I received your PM and opened a ticket this morning. I will provide you with an update when finished.

 

I am going to close this thread. If you need to report any issues related to being unable to delete port forwards, please reach out on the xFi Port Forward Failures thread.

 

We will also be keeping that thread up to date regarding the status of the fix. 

 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!