Xfinity plant
Community Forum
Xfinity globe

account number

New Poster

account number

Botched install 10 days ago with one account #.    On first account no services were activated because nothing was installed.   correct equipment install 10 days later with a different account number.   problem when using online or app services it only shows the first account # with no services.  i have called customer service but they keep trying to fix my log in which works fine its the dead account number they need to merge or delete.   

any suggestions

 

Expert

Re: account number


rknelson2074 wrote:

Botched install 10 days ago with one account #.    On first account no services were activated because nothing was installed.   correct equipment install 10 days later with a different account number.   problem when using online or app services it only shows the first account # with no services.  i have called customer service but they keep trying to fix my log in which works fine its the dead account number they need to merge or delete.   

any suggestions


I have escalated your issue to the Comcast Team available to these forums. Check back often for a reply in this thread or via Private Message from a Comcast Official Employee.

Official Employee

Re: account number

Hi, rknelson2074. I can help look into the issue with your login reflecting the inactive account number. Please click my name, ComcastMax, and then click Private Message Me to send me a message verifying your full name, address, the phone number associated with your account, and the XFINITY username you're using to log into your account so I can assist.