Community Forum

Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Frequent Visitor

Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Ever since I installed the new XFi Gateway, the Xfinity WiFi on-off control in the MyAccount app is grayed out. Also when you go the app control page, the app pops up a message "Something Went Wrong - we were unable to load your Wi-Fi hotspot settings. Would you like to try again?" Each retry fails. A call to technical support provided no solution. They turned it off remotely but it still shows here as on. It cannot be controlled with the gateway controls at 10.0.0.1. I do want to be able to turn it on when needed and otherwise turn it off to avoid devices connecting to the non-secure signal. Please provide a fix to the app. BTW, there is no new control for this in the new XFi app.
Silver Problem Solver

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed


@joneisenberg wrote:
Ever since I installed the new XFi Gateway, the Xfinity WiFi on-off control in the MyAccount app is grayed out. Also when you go the app control page, the app pops up a message "Something Went Wrong - we were unable to load your Wi-Fi hotspot settings. Would you like to try again?" Each retry fails. A call to technical support provided no solution. They turned it off remotely but it still shows here as on. It cannot be controlled with the gateway controls at 10.0.0.1. I do want to be able to turn it on when needed and otherwise turn it off to avoid devices connecting to the non-secure signal. Please provide a fix to the app. BTW, there is no new control for this in the new XFi app.

Can you give us the make and model of your gateway?

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

XB6A. No make given. "Made with ❤️ in Philadelphia." Thanks.
Silver Problem Solver

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed


@joneisenberg wrote:
Ever since I installed the new XFi Gateway, the Xfinity WiFi on-off control in the MyAccount app is grayed out. Also when you go the app control page, the app pops up a message "Something Went Wrong - we were unable to load your Wi-Fi hotspot settings. Would you like to try again?" Each retry fails. A call to technical support provided no solution. They turned it off remotely but it still shows here as on. It cannot be controlled with the gateway controls at 10.0.0.1. I do want to be able to turn it on when needed and otherwise turn it off to avoid devices connecting to the non-secure signal. Please provide a fix to the app. BTW, there is no new control for this in the new XFi app.

Did you try the website?

https://www.xfinity.com/support/articles/disable-xfinity-wifi-home-hotspot

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Thanks but I went through this with a Comcast. That page says "We're having trouble accessing this data. Please try again later." Comcast could not explain this and had no solution. Thank you.
IMG_9167.PNG
Regular Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

I've had the same exact issue with both models of the XB6.  I currently have a CGM4140COM, and previously had a TG3482G (that I replaced trying to fix this).

 

I've called at least 6 times to support to have the xfinitywifi hotspot turned off because it keeps turning itself back on.  Each time Comcast assures me it wont turn back on.  Comcast please address this bug with the XB6s!

 

Screen Shot 2019-02-17 at 1.02.01 PM.pngIMG_586837D36ED9-1.jpeg

Silver Problem Solver

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

I have successfully turned off my xfinitywifi SSID with this:

 

https://www.xfinity.com/support/articles/disable-xfinity-wifi-home-hotspot

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Frequent Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Thanks but unfortunately all the controls are grayed out or disabled. The article you cited gives a link to a control page which responds “We’re having trouble accessing this data. Please try again later.” It has said that for months now. Xfinity can’t fix it.
Frequent Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

See the 12-16-18 message in this thread. Thanks.
Regular Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

@joneisenberg wrote:
Thanks but unfortunately all the controls are grayed out or disabled. The article you cited gives a link to a control page which responds “We’re having trouble accessing this data. Please try again later.” It has said that for months now. Xfinity can’t fix it.

Same here.   I've tried factory reseting both modems hoping it would fix this issue.  This issue occurs even if the modem is in bridge mode.  To my understanding after talking to several support agents, by default bridge mode should disable the xfinitywifi hotspot.

 

Also note, after I call in and a Comcast agent turns off the xfinitywifi hotsopt, it will always turn back on by itself the next day.

 

 

Official Employee

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Eighty80,

 

Let's take a look into this further folks. Please send me a private message with your full name so I can take a closer look into the re-enabled hotspot on your Xb6s. 

 

Ken


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Having this same issue both via laptop and mobile app. Reset the gateway and it hasn't made any difference.

Official Employee

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Having this same issue both via laptop and mobile app. Reset the gateway and it hasn't made any difference.

bhawks197, hit me up in private message for help. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Why can’t you help on the public forum for all affected by this issue to see?
Frequent Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

As comcast says, “We ask that you post publicly so people with similar questions may benefit from the conversation..”
Regular Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed


@joneisenberg wrote:
Why can’t you help on the public forum for all affected by this issue to see?

@joneisenberg , @ComcastKenF was able to fix it for me.  So far it's been off for 5 days, and the settings are no longer greyed out or unavailable in the app/web.  Ken needed to do some troubleshooting/make some changes on the modem, so I doubt it's a fix customers can do on their own.  Thus the need to confirm the account via PM.

 

Hopefuly whatever the issue is, can be fixed for all customers with a future update.

Official Employee

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Great questions joneisenberg. Nothing shady going on here! We ask to go private so that I can authenticate the account and confirm a few account specific things. It's better to get that out of the way first so we aren't jumping back and forth. The idea is meant to be more cohesive. If the forums user decides to keep the convo there, we will. If a solution is discovered, it'll definitely be posted publicly for people to check out. 

 

Eighty80's issue had to do with some back end provisioning and then we had to manually push the opt out for the hotspot. Once that was done, it seemed to do the trick! 

Cheers, 

 

Ken


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Ken,

Any chance you can help me out as well. I’m getting the same “something went wrong” message and customer services only solution is to offer to swap out my modem for a new one.

I want the ability to turn the home hotspot on and off at will.

Thanks.
Regular Visitor

Re: Xfinity Hotspot Control Grayed Out Since XFi Gateway Installed

Ken,

Any chance you can help me out as well. I’m getting the same “something went wrong” message and customer services only solution is to offer to swap out my modem for a new one.

I want the ability to turn the home hotspot on and off at will.

Thanks.