Community Forum

My Account app

New Poster

My Account app

The My Account app won't connect. It appears others are having this problem as well. It worked fine until recently, what has happened? I tried uninstalling and reinstalling to no avail.
Silver Problem Solver

Re: My Account app


@cschultz999 wrote:
The My Account app won't connect. It appears others are having this problem as well. It worked fine until recently, what has happened? I tried uninstalling and reinstalling to no avail.

Are you able to connect to it with a computer?

https://my.xfinity.com/?cid=cust


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: My Account app

I don't have a computer
Silver Problem Solver

Re: My Account app


@cschultz999 wrote:
I don't have a computer

Are you on your local wifi with the app?  Are you using the correct username/password for your account?

https://customer.xfinity.com/#/settings/security#username-password


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: My Account app

Yes. I have been using this app for several years and never had a problem. Then it just stopped working. I haven't changed anything.
It appears this is happening to many people, so I have to presume it is in Comcast's end.
Silver Problem Solver

Re: My Account app


@cschultz999 wrote:
Yes. I have been using this app for several years and never had a problem. Then it just stopped working. I haven't changed anything.
It appears this is happening to many people, so I have to presume it is in Comcast's end.

If it is on Comcast's end, maybe a call to 1800comcast and ask for account will help.

My My Account app works on my iPad and my iPhone11; I check it every day.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!