Community Forum

Bill pay on Android app still doesn't work

Frequent Visitor

Bill pay on Android app still doesn't work

I have just uninstalled and reinstalled the Android app. Cleared the app cache. Still getting a blank white screen when I attempt to make a payment. I only have one account/user name so there should be no issue there.
Expert

Re: Bill pay on Android app still doesn't work


@mclaura wrote:
I have just uninstalled and reinstalled the Android app. Cleared the app cache. Still getting a blank white screen when I attempt to make a payment. I only have one account/user name so there should be no issue there.

go to your device's settings for network. what is the DNS server address?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Bill pay on Android app still doesn't work

I don't have a DNS server configured as far as I can tell. I use DHCP, not static IP. I also never mess with those settings, and used to be able to pay via the app.
Expert

Re: Bill pay on Android app still doesn't work


@mclaura wrote:
I don't have a DNS server configured as far as I can tell. I use DHCP, not static IP. I also never mess with those settings, and used to be able to pay via the app.

go to your wifi settings 'i' for information. will give you IP and DNS server among others like gateway address.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Gold Problem Solver

Re: Bill pay on Android app still doesn't work


@Rustyben wrote: ... go to your wifi settings 'i' for information. will give you IP and DNS server among others like gateway address.

I have v5.1 and a v8.1 Android phones, and neither one has an " 'i' for information " in Wifi settings. And AFAICT neither OS version has a way of displaying DNS server or gateway addresses. Device MAC and IP, yes. Those other items, no. Perhaps the OP is facing a similar roadblock.

Highlighted
Frequent Visitor

Re: Bill pay on Android app still doesn't work

In my advanced settings, I can see my IP and mac addy, but that's it. I am using a Samsung Galaxy Note 9, android version 9 (pie). 

 

I guess it's nice that the last update fixed it for some users, but it did not fix it for me.  

Expert

Re: Bill pay on Android app still doesn't work


@BruceW wrote:

@Rustyben wrote: ... go to your wifi settings 'i' for information. will give you IP and DNS server among others like gateway address.

I have v5.1 and a v8.1 Android phones, and neither one has an " 'i' for information " in Wifi settings. And AFAICT neither OS version has a way of displaying DNS server or gateway addresses. Device MAC and IP, yes. Those other items, no. Perhaps the OP is facing a similar roadblock.


this will show you how to see (just cancel at end no changes will be made). pull down and long press your wifi connection icon. long press the in-use wifi SSID (will say connected) and select modify network. check show advanced options then select ip settings, then select static. scroll down and you can see dns 1 and dns 2 server addresses. 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Gold Problem Solver

Re: Bill pay on Android app still doesn't work


@Rustyben wrote: ... select modify network. check show advanced options then select ip settings, then select static. scroll down and you can see dns 1 and dns 2 server addresses. 

What you see there is deceptive. Under

 

    Modify network /  Show advanced options / IP settings / Static

 

both of my phones show (in pale grey characters to indicate what kind of entry to make, NOT reading out actual data) an IP address of 192.168.1.128. But the phones' actual IPs, from

 

    Settings / System / "About phone" / Network / IP address

 

and confirmed by my router's "Show Attached Devices" screen, are 192.168.1.11 and 192.168.1.12.

 

What's shown under Static IP is meaningless unless you are actually using a static IP, which I'm not (the IP setting is DHCP on both phones).

New Poster

Re: Bill pay on Android app still doesn't work

Just get a white screen when trying to pay my bill.
Frequent Visitor

Re: Bill pay on Android app still doesn't work

Using the steps above, I was able to see dns 1 and 2 IPs. However, I guess I don't understand why those settings even make a difference?

Expert

Re: Bill pay on Android app still doesn't work


@mclaura wrote:

Using the steps above, I was able to see dns 1 and 2 IPs. However, I guess I don't understand why those settings even make a difference?


hi, there seems to be a common issue where 'we' customers use cloudflare or other 3rd party DNS resolvers (like 1.1.1.1) don't always work well. it isn't a bad dns resolver but seems to be a 'not' public server that is not available outside of using comcast's dns servers. comcast's DNS is 75.75.75.75 (there is a secondary but not really important for this question).



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Bill pay on Android app still doesn't work

So, I got an email asking if my issue was resolved and to mark a "best answer". But, while I do appreciate the assistance that was provided, the issue is *not* resolved. I firmly believe the app is the problem, rather than any phone or vpn settings.

I do see that the app has updated again, but it just clocks when I click on "Pay Bill".
Expert

Re: Bill pay on Android app still doesn't work


@mclaura wrote:
So, I got an email asking if my issue was resolved and to mark a "best answer". But, while I do appreciate the assistance that was provided, the issue is *not* resolved. I firmly believe the app is the problem, rather than any phone or vpn settings.

I do see that the app has updated again, but it just clocks when I click on "Pay Bill".

you said you could see the dns servers but didn't reply with what you saw. also are you using a VPN? 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Bill pay on Android app still doesn't work

I never posted the dns info because I honestly don't think that's the issue.  And right now I'm at work where seeing that info isn't possible, either. No VPN being used at either place,  and it doesn't work either place.  

Official Employee

Re: Bill pay on Android app still doesn't work

Greetings, mclaura! I appreciate you taking the time to reach out to us here on the forums. I hope you are having an amazing day. I apologize to hear that you are having issues trying to may a payment o your MyAccount app. That's certainly frustrating. I would like to look into this and see what's going on. Can you please send me a PM with your first and last name so I may further assist you?

 

To send a private message, please click my name "ComcastMichael" then select "Send a Message" on the right side.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Bill pay on Android app still doesn't work

Hi Michael,

 

I started to send you a PM as requested, but decided to try clearing the app cache and data again. That had had no effect last time but...what do you know? It worked this time and I am again able to get the bill pay to work. Smiley Happy

 

So, for anyone else with this problem, try clearing your app cache and data and see if that helps. On my phone, that means going to Settings > Applications > find the My Account app. Click Storage, then use the buttons for clear cache and clear data. Your process may be different, of course. 

Official Employee

Re: Bill pay on Android app still doesn't work

Awesome to hear that you were finally able to get back into the billing portion of the MyAccount app, mclaura. I know the MyAccount app is a great tool to have at your disposal as it allows you to access and manage your account no matter where you are at. I use it all the time myself and love. I also wanted to thank you for posting the steps you took to clear the app's data and cache. If you need assistance in the future, don't hesitate to reach out to us.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!