Community Forum

Keep having "No Services" for new BYOD activations

Regular Visitor

Keep having "No Services" for new BYOD activations

I am an existing Internet customer. Yesterday I joined the BYOD mobile plan with my unlock iPhone6S (which I bought overseas) porting from T-mobile. It did also work on Verizon before. However, the sim card never gets activated. I have gone to the shop a couple times to check and the staff were very helpful by keep calling support to help. I have also called support myself at home but it still did not work (I have tried to restore network setting and also the whole phone). I have "XFINITY MOBILE" section at the Settings > Cellular on my phone. But it is just not working.

 

I have a ticket number from the support I called, but I am really not sure if this can be solved. Really frustrated now.

Official Employee

Re: Keep having "No Services" for new BYOD activations

 

fungsteven, we're only compatible with iPhone 6's from the big 4. However, since you have a ticket open, I can check on it's status. Please send me a private message with your full name and address for help. 

Regular Visitor

Re: Keep having "No Services" for new BYOD activations

Hi Ken. I received a carrier update message on the phone when I was just at the shop and prepared to ask the staff to restore the phone for me an hour ago. After the carrier update, the XM service works on my phone now!

So I believe there is something need to be done for certain non-xfinity phones to use XM (my phone was bought overseas but should work on all US carriers)

I hope you guys are getting into pace since the BYOD just started a while ago, but get prepared when you allow Android phones as well later. I hope it is smooth, the signal strength really exactly the same as Verizon, and everyone is happy.

Thank you for your assistant here.

Official Employee

Re: Keep having "No Services" for new BYOD activations

That's great, fungsteven! Post again if you need anything else. 

 

KenF