Community Forum

Home Wifi not allowing MMS

New Poster

Home Wifi not allowing MMS

We have an Xfinity mobile plan and got Samsung S10e's about 2 months ago.  Unfortunately we've been having issues with sending MMS while on Wifi and I know I've seen a bunch of comments and discussions from other S10e owners about this.  For us its a little different.

 

With mobile data off, we can send and receive MMS through most Wifi networks (where I work, a random museum, hotel, etc.), but when we're home it won't go through.  We've spoken with Samsung when we initially thought it didn't work through Wifi at all and they constantly told us it was Xfinity.  Then we would talk to Xfinity and they would tell us it was Samsung.  Once we narrowed down though that it could be done and it just depended on the Wifi network, we really started to focus on Xfinity, who is also our internet provider.

 

Each time we contact them, we tell them the issue and they ignore us and send us through the standard troubleshooting process.  We finally got through to the next level and they were supposed to call us back, but that hasn't happeded yet.

 

In any event, I'm assuming this should be at least mostly related to Wifi settings?  Does anyone have any thoughts or opinions on what Wifi network settings could be causing this?  Its curious because I setup the Wifi network at the house and just used standard settings on the ASUS router, so I can't think of anything special I would have done that would exclude MMS when other networks don't.  Any thoughts are appreciated.  Thanks!

Contributor

Re: Home Wifi not allowing MMS

My guess is that your problem is with WiFi Calling, not WiFi. Many cutomers both on Android and on iOS are having issues with WiFi Calling. 

 

 None of my account’s three phones (iPhone 6s, 7, and XR) work properly when WiFi Calling is activated unless we turn on airplane mode (turn off cellular)  This is a known problem that Xfinity Mobile is supposedly working on.  

 

The answer is that until Xfinity gets their act together you should only use WiFi Calling when you really need to use it and when you do use it, turn on airplane mode. 

 

For most people this fixes MMS issues, Dropped Call issues, as well as Visual Voicemail issues. Yes, it is a pain, but it’s the best choice for now. 

New Poster

Re: Home Wifi not allowing MMS

Thanks for the info.  I've seen Wifi calling come up in previous discussions, but wasn't sure whether it might apply to my situation as well, since it sometimes works from other Wifi networks.  And I pretty much always have my data turned off, so I wasn't sure what more switching it to Airplane Mode would accomplish.  As I'm pretty much total confused on this topic, I'll give Airplane Mode a shot tonight when I get home.  Its the being able to send and receive MMS with data off on some Wifi networks but not others that has me completely confused.  Thanks!

Regular Contributor

Re: Home Wifi not allowing MMS

Using Verizon Messages (Message+) solves the problem on 2 s10e's. It seems to work for everything.

- Bill
Contributor

Re: Home Wifi not allowing MMS

The problem is that MMS needs your data turned on if your phone is trying to send MMS over the cellular network. With WiFi Calling turned on the various networks such as Verizon, AT&T, Xfinity Mobile, and so on attempt to use the cellular network first and only switch to WiFi Calling when the cellular network is weak or congested. 

 

With Xfinity Mobile it is supposed to show Xfinity Mobile on your screen if and when the cellular connection is strong and being used, otherwise it will show XM WiFi when it has switched to using your WiFi. However this is often not working properly for Xfintiy Mobile, so you have no idea what is really happening, and Xfinity Mobile doesn’t seem to have any idea either!

 

So when you are at home and you think that you are sending an MMS using WiFi Calling, Xfinity may actually be trying to send the MMS over cellular which it can’t do if you have data turned off. It can send simple 140 character texts. 

 

Here is is another option. Turn on your cellular data, but in your settings individually turn off cellular data for all of your apps and services except for Phone, MMS, Visual Voicemail, and system services if possible. 

 

Good Luck!

New Poster

Re: Home Wifi not allowing MMS

All, thanks for the input.  I feel like we tried the Verizon Messaging app, but its all blurry at this point.  We'll give that another shot to see whether it makes a difference for us. 

 

And the Wifi calling thing is weird because when I'm on some Wifi networks, it can send MMS without data turned on.  I've done it from work many times.  It just won't go through on our home network for some reason.  So even if we were to assume that Xfinity is trying to send it over cellular, why can I send it from other Wifi networks without data turned on?  I've sent/received pictures, group texts, etc. with data turned off - just not at the one place I really want it to go through (at my home).  Is Wifi calling a specific setting?  I'm not aware of having anything specifically setup for that.  Is that just the terminology for when Wifi is used for something like a phone call or a text message?  Maybe airplane mode or the different messaging app will help, I'll check it out tonight.

 

The wife is about ready to throw the phone through the wall!

Regular Contributor

Re: Home Wifi not allowing MMS

FWIW, I use the s10e with VZ Messages+ and mobile data on.
- Bill
Contributor

Re: Home Wifi not allowing MMS

Your phones are working properly.

XFINITY Mobile is working properly. 

 

Good News: You have very good cellular network connectivity at your house. 

 

Bad News: You have very good cellular network connectivity at your house, which means that your device will prioritize to a cellular network connection for phone functions such as calling, text, MMS, and voicemail even when you are connected to WiFi no matter how strong the WiFi is. MMS and Voicemail require data. 

 

What at are your options while at home:

 

1.) Somehow block the XM/Verizon signal at your house. Go into your basement?, Or

 

2.) Turn on Cellular Data but only for your phone App., Or

 

3.) Turn on Airplane Mode when you want to receive or send MMS or get voicemail. 

 

Unfortunately none one of the networks prioritize WiFi while in the U.S., though I see an option to prioritize WiFi (thus WiFi Calling) while roaming internationally. So take your wife on a vacation. 

New Poster

Re: Home Wifi not allowing MMS

LOL, I guess that is good news, who would have thought.  Tried the Airplane Mode option last night and it didn't work unfortunately.  What was odd though, is that once I turned Airplane Mode off, I was able to send and receive MMS for a short period of time.  It then reverted back to its normal cr@ppy state.  Worked for my wife too.  So there must be a delay or something before it reverts back to prioritizing cellular data.  It seems like its either cycle the Airplane Mode or cycle the data to get the texts to come through at the house.  Oh well, we're going to keep on Xfinity to see if they can find some sort of way to resolve this.  Thanks for the all of the input folks!

 

 

Contributor

Re: Home Wifi not allowing MMS

i've been tracking similar issues with samsung s8, and also comparing with iphone SE iMessage on xfinity mobile.    the behavior in this area is specific to every phone/OS-rev and seems to have been changed multiple times in recent xfinity-samsung-s8 OS revs.     additionally the messaging app is a factor.    changing the messaging app from one app to another can further confuse the OS.   So in the case of a samsung phone getting confused about whether it can send an MMS after you've been toggling airplane-mode/cellular-data/wifi-only, or changing the messaging app do this:  set the settings as you want then reboot the phone and do not change the settings, then do your 'tests'.

 

the root cause for why a phone won't encapsulate/send MMS over your home wifi that your home wifi has bad problems, which has nothing to do with comcast unless you opt to spend extra money and optionally rent their wifi/router/hub equipment.   possibly consider to return all their wifi/router equipment except the cable modem and get a nice 802.11 AC or AX wifi-hub-router, this may fix your problem.     then a month later buy a cable modem and walmart and swap it in, and return the rented modem.    its a good idea to keep the cable modem and the router/wifi/hub as separate pieces so you can swap them separately when need be.

 

the case of iPhone/iMessage has another bunch of complications and is beyond the scope of this posting.   anyone feel free ask interesting specific questions about whatever and i sure will answer if i see them - i don't get on this forum too often but try to occasionally help folks here.

 

best regards...

 

/e