Community Forum

Enable LTE for Voice and Hotspot issues

Regular Visitor

Enable LTE for Voice and Hotspot issues

Just brought over 2 phones from Verizon.  I get error message that says to enable LTE calling to contact Xfinity Mobile.  Phone and chat support are clueless.  I see there has been success on this forum getting it solved.  Can someone assist in activating LTE Voice calling from my iPhone X mobile device?  Also activating option for Mobile Hotspot?  I need these features!!

Regular Visitor

Re: Enable LTE for Voice and Hotspot issues

I’m in the same boat. Have been since November. I still have issues with Voicemail and enabling LTE for voice calls but Tier 2 tech support should get your hotspot working just ask them to escalate it.
Official Employee

Re: Enable LTE for Voice and Hotspot issues

 

dwork2000, sounds like you need your features to be realigned. I've seen your private message and will follow up with you there. 

 

KenF


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Official Employee

Re: Enable LTE for Voice and Hotspot issues

 

dwork2000, glad we were able to get this resolved for you. Post again if you need further assistance. 


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!