Xfinity plant
Community Forum
Xfinity globe

Unable to add devices through Home App

New Poster

Unable to add devices through Home App

I have some home automation devices that I have been trying to add unsuccessfully. For instance the nest thermostat and Phillips lights. I follow all of the instructions to add a device but I hit a wall where a screen pops up with the words "we were unable to connect to your account. Please exit the thread and try again later." I have tried again later, its been 3 weeks. No service agent or comcast IT person has been able to help me. Any suggestions would be helpful. Thanks.
Official Employee

Re: Unable to add devices through Home App

Jhieme20 -- 

 

Thanks for reaching out.  I've been able to pull up your account & share with engineering to troubleshoot. 

 

Rachel

New Poster

Re: Unable to add devices through Home App

Thank you I appreciate any help I can get.
New Poster

Re: Unable to add devices through Home App

Any luck???

New Poster

Re: Unable to add devices through Home App

I have the same problem with the same two apps.  It seems to work on the side of the apps. When I log into the nest app, it shows multiple permissions granted to the Xfinity Home App but the execution never completes (I have also tried several times) 

New Poster

Re: Unable to add devices through Home App

Anything to fix this issue? I got a message asking if my problem was fixed, it is not. Please help.

Official Employee

Re: Unable to add devices through Home App

GAKnutse & Jhieme20 -- 

 

Can you please confirm you are using the most up to date version of the Xfinity Home app (9.10)?

 

Thanks!

Rachel