Xfinity plant
Community Forum
Xfinity globe

Thermostat problem

Frequent Visitor

Thermostat problem

The actual temperature on my thermostat does not update on the touch screen, web or the home app. Sometime the rules on the web control the thermostat and sometimes the program on the thermostat controls the temperature.
Also the Evo save program is a pain, how can you disable it?
Problem Solver

Re: Thermostat problem

There have been many posts on this topic...check out the other similar topics in the history....
New Poster

Re: Thermostat problem

My thermostat is always reading 71 on the app and touch screen. But the thermostat itself works just fine. This all happened after the update. Any ideas?
Official Employee

Re: Thermostat problem

Hi creighton630 & imadhourani -- 

 

I opened tickets for you both & a tech should reach out to you directly.

 

Thanks!

 

Rachel

Problem Solver

Re: Thermostat problem

Rachel, why do you have to 'open tickets'? Why can't these issues be resolved by tech support first on the phone, and then by appointment if necessary? What do you do differently?
Official Employee

Re: Thermostat problem

Hi Rjmmoon -

 

Correct, many issues can be resolved by tech support over the phone.  The ticketing process I use is a way for us to schedule a tech to call the customer.  Depending on the issue, an appointment will be be made if necessary.  The ticketing process is also another way for us to track issues so we can make improvements to our mobile applications.

 

Thanks.

 

Rachel

Regular Visitor

Re: Thermostat problem

I have trouble with my thermostat. I use the TouchScreen to set the temp to 75 degrees but it doesn't hold. I'll notice it's warm and I have to press the down arrow again to reset the temp. The A/C does turn on but why do I have to keep telling it the temp I want? I have pets and if I leave the house, I don't want them to get overheated. Please help! Thanks!

Official Employee

Re: Thermostat problem

Hi mgkamish - 

 

I've private messaged you.

 

Thanks!

 

Rachel

Regular Visitor

Re: Thermostat problem

My Thermo does same thing after 6/29 APP fix. Actual Temp on APP stays the same(Not the current) temp. Correct temp on Thermo and WEB Portal are correct. Phone support has not been able to fix. Ticket put in with promise of a call back. Comcast support has not done anything!!!!
Official Employee

Re: Thermostat problem

Hi Condo02 - 

 

I'd like to help troubleshoot.  I've private messaged you.

 

Thanks,

 

Rachel