Community Forum

Home app doesn't work on wifi

New Poster

Home app doesn't work on wifi

Ever since a recent update, the home app doesn't work while I'm using my xfinity wifi. If I try to open the app using wifi, it takes me to the sign in page every time, and then opens a browser page that never loads. When I turn my wifi off and use my phone data, the app works fine. And my wifi works perfectly well with every other app, including watching 1080p/4k content on YouTube and netflix. It just seems to be this app. Any ideas?
Silver Problem Solver

Re: Home app doesn't work on wifi


@zalford75 wrote:
Ever since a recent update, the home app doesn't work while I'm using my xfinity wifi. If I try to open the app using wifi, it takes me to the sign in page every time, and then opens a browser page that never loads. When I turn my wifi off and use my phone data, the app works fine. And my wifi works perfectly well with every other app, including watching 1080p/4k content on YouTube and netflix. It just seems to be this app. Any ideas?

What wifi device are you using?


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Home app doesn't work on wifi

Has anyone fixed this somehow yet?  I am ready to switch home security because I can't use the app now on my smart phone.  The app does not work unless the phone is connected to my computer, useless.

Silver Problem Solver

Re: Home app doesn't work on wifi


@Aheadache wrote:

Has anyone fixed this somehow yet?  I am ready to switch home security because I can't use the app now on my smart phone.  The app does not work unless the phone is connected to my computer, useless.


What phone do you have?  XHome works with my iPhones and iPads and Galaxy Tab.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!