Community Forum

Camera Previews won't load/are unavailable

New Poster

Camera Previews won't load/are unavailable

For the past few months, the camera preview on both of my cameras try to load when I open the Home app, only to eventually fail to, and I get the "preview unavailable" message. I have had an Xfinity tech (contractor) out to the house, tried deleting and reinstalling the app, unplugging/rebooting the cameras and the touchscreen...nothing works. The live video feed does work fine, but the preview is nice to have, especially when you don't want to use data on your cellphone.

Silver Problem Solver

Re: Camera Previews won't load/are unavailable


@stevic15 wrote:

For the past few months, the camera preview on both of my cameras try to load when I open the Home app, only to eventually fail to, and I get the "preview unavailable" message. I have had an Xfinity tech (contractor) out to the house, tried deleting and reinstalling the app, unplugging/rebooting the cameras and the touchscreen...nothing works. The live video feed does work fine, but the preview is nice to have, especially when you don't want to use data on your cellphone.


I recently had a camera that was offline; I called support and they fixed my issue.

Try calling XHome Services 1-877-298-0874

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
New Poster

Re: Camera Previews won't load/are unavailable

I, of course called support, and even had a technician out to the house. He told us that it was a problem in the Home app after replacing our cameras with new ones. I am getting ready to change to Simplisafe.