Community Forum

Sent date/time is blank for messages from phone to Comcast e-mail account

Highlighted
Frequent Visitor

Sent date/time is blank for messages from phone to Comcast e-mail account

Hi - I have a Samsung (Emerge J3) phone with the Xfinity Connect app.  When I send e-mails on the phone to my Comcast and also Yahoo e-mail accounts, then the e-mail on Yahoo will include a Sent: date and time, but for the Comcast e-mail account, Outlook (Outlook 2010 with Windows 10) shows Sent : None if I look at or try to forward the message, so there isn't any sent date/time if I look at the e-mail to my Comacast account with within Outlook and also online.    I uninstalled and reinstalled the Xfinity Connect app on my phone, but that didn't fix the issue.  Why isn't there a Sent date and time?  Thanks!!  - Jim

Frequent Visitor

Re: Sent date/time is blank for messages from phone to Comcast e-mail account

I'm getting the idea that current Comcast employees don't really monitor this forum.  Given that, sould someone who reads this and has the XFINITY Connect APP on their phone and Windows 10 with Outlook 2010 please send an e-mail from their phone to themselves, and then check their Outlook to see if it says  Sent : None?   If the problem is what the XFINITY Connect APP itself, then everyone should see the same issue.  Yesterday, I spent hours on the line with Comcast Support, and didn't get to a solution, although they felt it was a 'synch' issue, but I'm not convinced...  I'm using POP on the Outlook account settings, so am starting to look into IMAP vs POP.  Also, if I log into the Comcast website on my home computer, and go to the mail page, then I can send an e-mail and it shows the correct Sent date and time, but any e-mail that I generate or forward from my phone using the XFINITY Connect APP doesn't.  Help!!!  - Jim   

Frequent Visitor

Re: Sent date/time is blank for messages from phone to Comcast e-mail account

If someone has the XFINITY Connect APP on their phone and any Windows and Outlook version on their home computer, then I’d really appreciate it if you would send yourself an e-mail from your phone to your own e-mail, and then check Outlook on your home computer to see if it says  Sent : None for the date/time stamp.   If the problem is what the XFINITY Connect APP itself, then everyone should see the same issue, and any info will be helpful. Many thanks!!! - Jim

Gold Problem Solver

Re: Sent date/time is blank for messages from phone to Comcast e-mail account


@calif_kid wrote: ... Why isn't there a Sent date and time? ...

Because, strangely, the app doesn't send one. All emails should have a Date: header that includes the date, time, and time zone, like this:

 

        Date: Mon, 23 Dec 2019 17:32:03 -0500 (EST)

 

but app v 7.5.3 on my LG phone does not send one. When this header is missing, mail clients sometimes use a date from a different header, such as Received:, ex:

 

        Received: from dovdir2-asc-04o.email.comcast.net ([96.114.154.199])
                by dovback2-asc-20o.email.comcast.net with LMTP
                id cJiYLGRAAV5TJAAA96/dQA
                (envelope-from <???????????@comcast.net>)
                for <???????????@comcast.net>; Mon, 23 Dec 2019 22:32:04 +0000

 

Apparently Outlook doesn't do this.

 

It appears to be a bug in the app, or perhaps a very odd design decision.

 

ETA: You can view email headers in Comcast's webmail ( https://connect.xfinity.com/ ) by selecting the message, then clicking "View source" on the three-line "hamburger" menu. You can also view headers in Outlook: see https://www.google.com/search?q=outlook+2010+view+source.

Frequent Visitor

Re: Sent date/time is blank for messages from phone to Comcast e-mail account

 

 

BruceW - thanks for the info.   I called Comcast, and then went into one of their stores today, and they didn't have info about the issue, but they did put me in contact with the 'We're on it' department, and opened a trouble ticket, so hopefully, there will be a solution or more info soon. 

 

Comcast - I sent myself three messages this morning - one from my phone using the XFinity Connect app, one from Outlook on my home computer (using Outlook 2010 with  Windows 10 with Office 2010), anf the last  from the Comcast webpage (which I logged into on my home computer).   I included a snapshot of my Outlook that shows the Sent 'None' for just the e-mail sent from my phone using the Xfinity Connect app.  Originally, I just had the Sent column in my Outlook Inbox message listing, but after I realized that my Inbox didn't list the messages from my phone, I added a Received column and sorted by it.  Thanks!!  - Jim 

Xfinity Connect Appp - issue with Sent date and time.jpg

Comcast - my

Frequent Visitor

Re: Sent date/time is blank for messages from phone to Comcast e-mail account

As it looks like the picture I uploaded of my Outlook Inbox didn't upload correctly, here is the info just pasted in as text.  The message from my phone has Sent None, while the messages from within Outlook or from the Comast website e0mail page did have a Sent date and time.  - Jim 

 

From Subject                                                                                                  Sent                                 Received               

J…     Message sent from Comcast e-mail page using home computer   Wed 1/8/2020 8:12 AM     Wed 1/8/2020 8:12 AM               

J…     Message sent from Outlook on home computer                           Wed 1/8/2020 8:10 AM     Wed 1/8/2020 8:11 AM

J…     Message sent from phone                                                                      None                                        Wed 1/8/2020 8:09 AM