Community Forum

Can't disable call forwarding to cell phone from home phone

Frequent Visitor

Can't disable call forwarding to cell phone from home phone

After installing Xfinity Connect app on my android phone I can't disable the call forwarding from my Comcast home phone to my cell phone. When I go to settings there isn't a Xfinity Connect under advanced call forwarding for me to toggle to the off position.

New Poster

Re: Can't disable call forwarding to cell phone from home phone

I'm not able to disable the Call Forwarding either on my new Android.  Comcast's FAQ says there is a toggle to turn it on and off but that is not present.  All I can do is control how many rings before voicemail picks up.  I cannot just edit my Comcast home number or delete it either--no option to do that.  I really, really, really don't want my smartphone going off during the day at work because of random calls going to the house phone.  I'm at the latest versions for Andriod and Xfinity Connect.  Hoping this gets fixed soon.

New Poster

Re: Can't disable call forwarding to cell phone from home phone

I have the same problem!

Problem Solver

Re: Can't disable call forwarding to cell phone from home phone

Hopefully the information below will help you all out.  I am using the connect app on my original pixel xl phone running the latest version of Android.

 

On your cell phone, open up the Connect App and touch the three horizontal lines in the upper left corner of the screen to open up the menu. Select the Settings option and then select Call Preferences then select Call Forwarding.  At this point I have a screen that lists my primary Xfinity Voice number and one of the virtual numbers I have setup, so I select the primary Xfinity Voice number.  At this point it will take a moment as it reads the settings for the number.  On the screen that shows up, depending upon how you are forward your home phone calls to your cell phone, the Xfinity Connect Mobile App may be reading On, select this to get to the screen where you can toggle it to Off.  If you are forwarding to your actual cell phone number, you will see it listed and it may be reading On, select this to get to the screen where you can toggle it to Off.  

 

Hope this helps you out.

Regular Visitor

Re: Can't disable call forwarding to cell phone from home phone

On my Connect app on my Android, when I try to turn Off Call Forwarding from my landline to my phone, it won't let me.  It just says  Call Forwarding "On".  Try as I may, I can't toggle the On to Off.  When i push "On", I just get a screen that lets me adjust the number of rings before voicemail.  There is no toggle to Off.  Something's wrong with the app.

New Poster

Re: Can't disable call forwarding to cell phone from home phone

I have the same issue. Clearly they did not test this. I was just on with Comcast today for 5+ hours, and nobody can figure out how to disable call forwarding from my home phone to the app on my cellphone. Most don't even know what I'm talking about! First they tell me to punch in *73 on my home phone to disable call forwarding. So I do that and I get a message that call forwarding is off, but a call to my home phone still rings to my cellphone. Then they tell me to disable it on the website in my account, but you can't. The "Remove" button under Advanced Call Forwarding says "you can't delete this number". And unchecking the box next to the number does nothing. And with the app itself, I agree with the previsous poster that there is no way to turn the "On" to "Off".  I can't believe Comcast pushed out a new version of xfinity connect and made the default setting to automatically forward home phone calls to my cellphone with no way to change it!! It should have been the other way around.  This is clearly a problem that Comcast needs to fix, but calls to their support line are worthless.

New Poster

Re: Can't disable call forwarding to cell phone from home phone - WORKAROUND FIX

So last night I got a call from a Level 2 Tech at Comcast who said my issue had been escalated. After about 30 mins of trying different things I now have what appears to be a workaround until Comcast fixes the app and allows you to turn off a phone number that is set for call forwarding. I have an Android phone, so the user interface might be different on an iPhone, I don't know. Here are the steps to follow: Go to Settings in the xfintity Connect app. Then select Notification Preferences. Scroll down to the Caller ID section and turn of both Caller ID Alert and Caller ID Pop-Up. Apparently having these on will still trigger your cellphone to ring through the app even if the phone that is forwarding has Call Forwarding turned off. I tested this multiple times and it looks like calls are no longer forwarding to my cellphone. At least it doesn't ring anymore. The Tech agreed that this is not the ideal solution nor is it an intuitive solution, but he was going to post it on as many Comcast blogs and sites that he could, and notify the Connect team that they should allow a user to turn off Advanced Call Forwarding under that section of the app. I also told him about the limitations on the website under one's account, where you cannot delete the Home phone from the list of Advanced Call Forwarding numbers listed. Hope this helps!

Regular Visitor

Re: Can't disable call forwarding to cell phone from home phone - WORKAROUND FIX

Yes, that stops the ringing.  You're right, it's not ideal because I think it doesn't keep a record of the incoming calls (which I liked).  Hopefully, they'll roll out a new update for the app soon that fixes everything.  (I was on the phone for a long time with Comcast yesterday, too!)

Contributor

Re: Can't disable call forwarding to cell phone from home phone - WORKAROUND FIX

I cannot get this to work. When I go to "Notification Preferences", I no longer have any option for Caller ID notification or popups. (I used to have it until Voice2Go was installed.) Is there anyone using Voice2Go that can still get Caller ID notifications? I am going crazy with this!

New Poster

Re: Can't disable call forwarding to cell phone from home phone - WORKAROUND FIX

I don't use Voice2Go, but I found this on the xfinity support pages which may help:

 

Disable Incoming Calls

You cannot deactivate Voice2Go for the primary user; however, you can disable incoming calls to the Xfinity Connect app:

  1. Press the Menu icon  at top left and select Settings.
  2. Select Call Preferences and then Call Forwarding.
  3. Select your phone line if prompted.
  4. Select XFINITY Connect Mobile App and toggle the on/off switch next to your phone line to enable/disable incoming calls.


Note: Turning off inbound calls will disable all notifications for any incoming calls to the app, including the Caller ID feature. After the inbound calls are set to off, all calls to the app will automatically go to voicemail and your app will not ring.

Regular Visitor

Re: Can't disable call forwarding to cell phone from home phone - WORKAROUND FIX

As stated above by more than one person, the ability to toggle "on"/"off" with any landline number in the Call Forwarding screen does not exist.  It just stays On, no matter what you do.

New Poster

Re: Can't disable call forwarding to cell phone from home phone - WORKAROUND FIX

I just figured this out...on my Android phone running Xfinity app v 7.1.2

 

1. Open Xfinity app

2. Settings

3. Call Preferences

4. Voice2Go Call Settings -> toggle to Off

Now at least my phone doesn't ring...

But I still see Missed Call notifications at the top of the screen.  To turn this off...

1. Open Xfinity app

2. Settings

3. Notification Preferences

4. Call Notifications -> toggle all to Off...Incoming Call, Missed Call, Outgoing Call

 

This seems to work!

I NEVER use the phone line supplied with my Triple Play.  I don't even have a phone connected to it in my house. The only calls that come into this line are telemarketing calls.

I hope this works for others!