Community Forum

Xfinity Stream loading dots stuck on screen

Frequent Visitor

Xfinity Stream loading dots stuck on screen

When I try to open a show to watch on the Xfinity Stream site I get the 3 loading dots on it. When they are there, I can't click on anything on the page to go back, so the only option is to refresh the page and try again. Sometimes I can get it to work after a refresh or 2 but rarely. There have been many times that I had to refresh the page a dozen times. I did a chat with Comcast today but didn't get anywhere as it seemed the tech wasn't a native English speaker and seemed to focus on the other issues I have with the site and not the reason I reached out. Then she just stopped responding altogether. I'm hoping someone here knows what it is and how it can be fixed. Thanks for any help!

Attached is a photo of what I see on the screen:

Comcast Loading dots.jpgloading dots

Bronze Problem Solver

Re: Xfinity Stream loading dots stuck on screen


@xolindsayoxwrote:

When I try to open a show to watch on the Xfinity Stream site I get the 3 loading dots on it. When they are there, I can't click on anything on the page to go back, so the only option is to refresh the page and try again. Sometimes I can get it to work after a refresh or 2 but rarely. There have been many times that I had to refresh the page a dozen times. I did a chat with Comcast today but didn't get anywhere as it seemed the tech wasn't a native English speaker and seemed to focus on the other issues I have with the site and not the reason I reached out. Then she just stopped responding altogether. I'm hoping someone here knows what it is and how it can be fixed. Thanks for any help!

Attached is a photo of what I see on the screen:

 


Try deleting browser cache and cookies

Frequent Visitor

Re: Xfinity Stream loading dots stuck on screen

I tried that many times. I cleared my cache/history as well as logging out/in on the Stream site and also had signals sent. Nothing fixed it...

New Poster

Re: Xfinity Stream loading dots stuck on screen

Same thing here.  Started two days ago.  Jumped through all the usual hoops, to no avail.

Tags (1)