Community Forum

XFINITY TV and Windows 10

Frequent Visitor

XFINITY TV and Windows 10

ON my laptop with Windows 10 and on my Surface with Windows 8.1, both show XFINITY TV as away from home. The result is, I cannot watch live TV, only recordings. Is there a fix for this??

 

Windows 7 on the same laptop worked perfectly with XFINITY TV.

Problem Solver

Re: XFINITY TV and Windows 10

Are you still having the problem?  There was a national issue with the "Out of Home" error for the past few days, but that was fixed yesterday (see this link).

 

As for Windows 10, I installed it on my laptop and no problems streaming live TV from the Xfinity TV website.  Works in both Chrome and the new Edge browser.

 


@CroakerLuver wrote:

ON my laptop with Windows 10 and on my Surface with Windows 8.1, both show XFINITY TV as away from home. The result is, I cannot watch live TV, only recordings. Is there a fix for this??

 

Windows 7 on the same laptop worked perfectly with XFINITY TV.


 

Frequent Visitor

Re: XFINITY TV and Windows 10

Thanks for the reply, sadly I am stll having the problem. I just checked my Surface with Windows 8.1.

 

I have already removed Windows 10 from the laptop. I have to say, I hope they have solved the problem, I really liked the features of 10. However, this problem is a deal breaker for me.

Problem Solver

Re: XFINITY TV and Windows 10

That's weird, so you were able to stream live TV on the Surface with 8.1 but not on the laptop with Windows 10?  Was that simultaneously? Which browser(s) were you trying to use?

 


@CroakerLuver wrote:

Thanks for the reply, sadly I am stll having the problem. I just checked my Surface with Windows 8.1.

 

I have already removed Windows 10 from the laptop. I have to say, I hope they have solved the problem, I really liked the features of 10. However, this problem is a deal breaker for me.


 

Frequent Visitor

Re: XFINITY TV and Windows 10

No, sorry if my info was confusing. I can't get XTV on either the laptop with Windows 10 or the Surface with Windows 8.1. I removed 10 from the laptop and went back to 7. It works perfect with XTV. After I read your post I tried the Surface with 8.1. Still shows "Not at Home".

 

Hope this cleears things up.

Frequent Visitor

Re: XFINITY TV and Windows 10

No, sorry if my info was confusing. I can't get XTV on either the laptop with Windows 10 or the Surface with Windows 8.1. I removed 10 from the laptop and went back to 7. It works perfect with XTV. After I read your post I tried the Surface with 8.1. Still shows "Not at Home".

 

Hope this cleears things up.

New Poster

Re: XFINITY TV and Windows 10

let me see, it will not let me downloud the app this kinda sniks I think Bill Gates is awesome, I really cannot stand how user friendly it is not


@HowAboutThisOne wrote:

Are you still having the problem?  There was a national issue with the "Out of Home" error for the past few days, but that was fixed yesterday (see this link).

 

As for Windows 10, I installed it on my laptop and no problems streaming live TV from the Xfinity TV website.  Works in both Chrome and the new Edge browser.

 


@CroakerLuver wrote:

ON my laptop with Windows 10 and on my Surface with Windows 8.1, both show XFINITY TV as away from home. The result is, I cannot watch live TV, only recordings. Is there a fix for this??

 

Windows 7 on the same laptop worked perfectly with XFINITY TV.


 


 

New Poster

Re: XFINITY TV and Windows 10

It's still going on. Does not make any difference which browser is used. If the laptop is plugged into the charger the image will be zoomed in immensely. 

On the rare occasion that it does work, it will only play in Chrome for a few hours - 4 days and then it will play on the Edge for about another 3 days and go out for a few months. Occasionally refocusing for moments at a time at the start of a show or when switching quality modes. 

 

New Poster

Re: XFINITY TV and Windows 10

The link in the "answer" is to another question with no resolution.

 

Silver Problem Solver

Re: XFINITY TV and Windows 10


@Victorianwilson wrote:

The link in the "answer" is to another question with no resolution.

 


And the answer was posted in 2015.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!