Community Forum

XFINITY Stream

New Poster

XFINITY Stream

Your system isn't compatible with XFINITY Stream
For optimal performance, the following is required:
Supported Operating System Windows 7+, Mac OS X 10.7+
Supported Browsers Internet Explorer 11+, Edge, Chrome, Firefox, Safari 8+

Windows has turned into a big piece of junk.
For that reason I now run Linux Mint 18.3 Cinnamon 64-bit with Mozilla Firefox

WHEN WILL YOU SUPPORT LINUX?