Xfinity plant
Xfinity globe
Community Forum

Voice over narration

New Poster

Voice over narration

I have the X1 and for only three of my DVR recordings there is a voice over narration that describes all scenes during the three recordings, it doesn't happen with any of the other recordings in my DVR, but the three recordings are from the same show and the same channel and are the only recordings I have from that channel.  I've looked at my settings and can't find anything remotely close to describing what i'm getting, plus the anyroom DVR is doing this voice over from all my TV's not just one, so i don't think it's a TV setting.  Any ideas why this would happen, where the setting is so I can disable it?  I originally watched the recordings and this wasn't happening, but now it's doing it and won't stop.....

New Poster

Re: Voice over narration

I am having the same issue and am on with Comcast and they don't have a clue.
Regular Visitor

Re: Voice over narration

Same here. It has happened on  Masterpiece downton abbey tonight, and sherlock last week. 

 

 

New Poster

Re: Voice over narration

Ditto that......comcast try's there best to keep me mad at them.....
Frequent Visitor

Re: Voice over narration

I am having the same issue get it together Comcast aren't you reading these post? We need a fix I'm having the same problem
Frequent Visitor

Re: Voice over narration

Did they get a fix?
New Poster

Re: Voice over narration

We just had X1 installed and are having the same problem. So far it is with PBS recording. But it looks like I should be prepared to have the same thing happen on other programs. Doesn't sound like the great upgrade that Comcast told us it would be.

Frequent Visitor

Re: Voice over narration

See update below.

Ok, we had a comcast technician out to our today. He was great, by the way. If you can get past the 800 comcast support people and get to a real technician in the field these guys are hard working and will do what they can to solve problems.

READ ALL THE WAY THROUGH FOR A TEMPORARY FIX TO THIS ISSUE

Here is what we learned about this issue. It seems to be unique to the new X1 and the latest X1 guide update. It now has a "National Ticket" meaning they know it is a problem nationally and are working to solve it. The voice over is PBS's (and others) Descriptive Video Service (DVS) for the blind or visually impaired. It is normally only available as an alternate audio selection (SAP or MTS). We did a bunch of tests trying to determine if it was the main DVR box, the small remote access boxes or the actual TV's themselves as most modern LCD/LED TV's can select alternate audio sources. Turns out after we did a reboot of the main DVR it only happens on the small remote boxes. It doesn't happen on the main DVR (in our case.) We also set up one TV with both the main DVR and the small remote access box. We got the DVS audio only when playing the TV from the small remote box not the main DVR. So the problem is a software issue with the small remote access boxes that are picking up the wrong audio signal (DVS) rather than the main English audio. I also spoke to a service manager in Denver who said they were now aware of this and were working on a fix/patch.
 
HERE IS THE TEMPORARY FIX - Using your X1 remote press the Xfinity button and go in to settings, then device settings then audio settings from the main settings guide and change the broadcast language to Spanish. As long as the channel or program you are watching does not have an alternate Spanish broadcast it will broadcast the main English audio without the DVS voice over narration. If your channel also has a spanish broadcast this won't work and you will have to switch back to "english" for that channel but hopefully it won't be PBS or BBC where most of the problems seem to be occuring. Good Luck. Comcast promised an update ASAP and a notification that is was addressed if you called to complain about it.

UPDATE - we found that some stations do not broadcast audio at all on the alternate language or SAP for some programs. If that is the case for the program you are watching you will get no audio on the Spanish audio option. You will need to switch back to English for that program or channel. Kind of a pain but at least there is a way to turn off the voice over narration on PBS, etc. if you want to. Hopefully Comcast fixes it correctly soon.
Official Employee

Re: Voice over narration

There's no fix or eta yet, try putting it in French
New Poster

Re: Voice over narration

We have the same VoiceOver issue with Modern Family.
New Poster

Re: Voice over narration

Any update on this?  I am having the same issue.

Official Employee

Re: Voice over narration

There's still no fix as of yet. If you hit xfinity go to gear symbol to device settings to audio and change the second language to French, it will go away
Frequent Visitor

Re: Voice over narration

I've tried changing it to every one of the language options, but I can't get it to stop.

Frequent Visitor

Re: Voice over narration

ComcastAndrew - Any fix on this yet?
Official Employee

Re: Voice over narration

wmrpdx, as of today I haven't heard of one. I still saw it in the field today.
New Poster

Re: Voice over narration

The issue I'm having is that I actually want to leave the language selection to Spanish so that it's automatically available but when I go to a channel that doesn't have a Spanish track it's giving me this DVS, when it's set to English it's working fine but to have to go in and change it for when a non Spanish show is on is very frustrating!!!  DVS should be a seperate option and not tied to a language setting IMHO!!!

New Poster

Re: Voice over narration

Double click the "A" button and you should be able to turn on and off the Voice over Narration

New Poster

Re: Voice over narration

I went into the setup through the xfinity button on the x1 remote. Audio setup - changed the video audio configuration and the problem went away
New Poster

Re: Voice over narration

Mine automatically started doing the voice over as well. I went to Audio settings and it somehow had switched to Spanish. once I changed it back voice over turned off.

Official Employee
New Poster

Re: Voice over narration

I love you. This actually worked!!!!!👏🏼👏🏼👏🏼👏🏼