Community Forum

TV/on demand not working

New Poster

TV/on demand not working

None of Xfinity content is working. When I click on something I get a black screen with the full screen/minimize bottons on the top right. Everything works on another computer so the problem is on my end. I updated my GPU driver yesterday, but the problem started a little later. 

 

Edit: When I watch through another site (i.e Fox Sports) everything works fine.

Expert

Re: TV/on demand not working


@andagain1 wrote:

None of Xfinity content is working. When I click on something I get a black screen with the full screen/minimize bottons on the top right. Everything works on another computer so the problem is on my end. I updated my GPU driver yesterday, but the problem started a little later. 

 

Edit: When I watch through another site (i.e Fox Sports) everything works fine.


try using the Chrome browser as it has an integrated flash player.


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
New Poster

Re: TV/on demand not working

I am using Chrome. 

 

Another thing -- when I click on a channel and get a black screen there's the info button on the top right. When I click on that I get a black box with a small dash on it. 

black.PNG
Expert

Re: TV/on demand not working


@andagain1 wrote:

I am using Chrome. 

 

Another thing -- when I click on a channel and get a black screen there's the info button on the top right. When I click on that I get a black box with a small dash on it. 


in the Chrome menu, did you try deleting your cache and cookies?


I am not a Comcast employee; I am just a customer, volunteering my time to help other customers here in the Forums.

If you'd like information about the Expert program, you can find it here.
New Poster

Re: TV/on demand not working

Just tried it and it did the trick. Thank you very much!