Community Forum

Not able to login to xfinity stream while on home network

New Poster

Not able to login to xfinity stream while on home network

Hello, for the past few days, whenever I try to connect to xfinity stream from our home network (from any laptop in our house), the connection to oauth.xfinity.com times out.  I get:

 

This site can’t be reached
oauth.xfinity.com took too long to respond.

 

When connecting from outside my home network, I am able to logon and view the listings/recordings just fine.  I had to connect to xfinitywifi to be able to log on and type this question.  Nothing has changed in terms of our home router settings, so I'm wondering what could be the problem.  

 

Thanks

Expert

Re: Not able to login to xfinity stream while on home network


@stsuchihashi wrote:

Hello, for the past few days, whenever I try to connect to xfinity stream from our home network (from any laptop in our house), the connection to oauth.xfinity.com times out.  I get:

 

This site can’t be reached
oauth.xfinity.com took too long to respond.

 

When connecting from outside my home network, I am able to logon and view the listings/recordings just fine.  I had to connect to xfinitywifi to be able to log on and type this question.  Nothing has changed in terms of our home router settings, so I'm wondering what could be the problem.  

 

Thanks


using windows 10 up-to-date? have you tried another browser? are you using a vpn? have you checked your DNS server settings? does it work on other desk/laptops? does it work on smart phone/tablets?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Not able to login to xfinity stream while on home network

All macs, and different browsers same thing happens (safari, chrome, opera).  Not using VPN.  With the app on smart phone, the Get Started butting is greyed out when connected to home wifi network.  If I connect via cellular, I am able to log on.  So something with connecting from the home network.

Expert

Re: Not able to login to xfinity stream while on home network


@stsuchihashi wrote:

All macs, and different browsers same thing happens (safari, chrome, opera).  Not using VPN.  With the app on smart phone, the Get Started butting is greyed out when connected to home wifi network.  If I connect via cellular, I am able to log on.  So something with connecting from the home network.


pending questions: using windows 10 up-to-date?  have you checked your DNS server settings? (what are the DNS servers being used?) 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: Not able to login to xfinity stream while on home network

Again, i don't have anything running windows (all macs which are up to date) and they are using the router as the DNS.  The router is using the xfinity DNS (75.75.76.76 I believe).  I don't believe it has anything to do with DNS as the lookup is providing the correct IP address.  Something with the routing...

 

$ traceroute oauth.xfinity.com

traceroute to oauth.g.xfinity.com (68.87.29.197), 64 hops max, 52 byte packets

1  router.asus.com (192.168.1.1)  1.193 ms  0.831 ms  0.805 ms

2  96.120.89.189 (96.120.89.189)  32.394 ms  12.041 ms  10.686 ms

3  be-10008-rur01.sanjose.ca.sfba.comcast.net (162.151.30.65)  9.730 ms  10.442 ms  10.237 ms

4  be-231-rar01.santaclara.ca.sfba.comcast.net (162.151.78.249)  15.114 ms  10.818 ms  11.148 ms

5  be-3651-cr02.sunnyvale.ca.ibone.comcast.net (68.86.91.73)  10.824 ms  19.316 ms  13.503 ms

6  be-11020-cr01.champa.co.ibone.comcast.net (68.86.84.10)  38.471 ms  54.767 ms  54.383 ms

7  be-12021-cr02.1601milehigh.co.ibone.comcast.net (68.86.84.226)  34.629 ms  35.507 ms  38.342 ms

8  be-10521-cr02.350ecermak.il.ibone.comcast.net (68.86.85.169)  69.201 ms  64.123 ms  101.153 ms

9  be-1302-cs03.350ecermak.il.ibone.comcast.net (96.110.36.105)  60.949 ms  61.999 ms  57.830 ms

10  be-1314-cr14.350ecermak.il.ibone.comcast.net (96.110.35.58)  58.145 ms  57.560 ms  58.445 ms

11  be-302-cr12.ashburn.va.ibone.comcast.net (96.110.32.101)  75.253 ms  74.010 ms  74.479 ms

12  be-1412-cs04.ashburn.va.ibone.comcast.net (96.110.32.213)  90.824 ms  75.090 ms  74.544 ms

13  be-1202-cr02.ashburn.va.ibone.comcast.net (96.110.32.174)  75.089 ms

    be-1302-cr02.ashburn.va.ibone.comcast.net (96.110.32.178)  74.934 ms

    be-1202-cr02.ashburn.va.ibone.comcast.net (96.110.32.174)  74.285 ms

14  be-7922-ar01-d.westchester.pa.bo.comcast.net (68.86.94.226)  78.972 ms  78.568 ms  90.968 ms

15  be-100-ur21-d.westchester.pa.bo.comcast.net (68.85.137.213)  83.015 ms  89.450 ms  93.799 ms

16  * * *

17  * * *

18  * * *

19  * * *

20  * * *

21  *^C

New Poster

Re: Not able to login to xfinity stream while on home network

Seems others have hit this as well with someone saying that restarting the modem worked (I restarted my router, but didn't try restarting the modem).  Will try that later to see if it works.

 

https://www.reddit.com/r/Comcast/comments/boytmi/unable_to_log_in_oauthxfinitycom_took_too_long_to/

New Poster

Re: Not able to login to xfinity stream while on home network

Restarting the modem did the trick.

Gold Problem Solver

Re: Not able to login to xfinity stream while on home network


@stsuchihashi wrote: ... the connection to oauth.xfinity.com times out. ...

I see this from time to time. At the moment in South-Central PA, "oauth.xfinity.com" redirects to "oauth.g.xfinity.com", which in turn resolves to one of three IP addresses: 68.87.29.197, 96.114.156.145, and 162.150.57.167.

 


C>nslookup oauth.g.xfinity.com 75.75.75.75
Name: oauth.g.xfinity.com
Addresses: 2001:558:fe14:3:68:87:29:197
68.87.29.197

 

C>nslookup oauth.g.xfinity.com 75.75.75.75
Name: oauth.g.xfinity.com
Addresses: 2001:558:fe16:109:96:114:156:145
96.114.156.145

 

C>nslookup oauth.g.xfinity.com 75.75.75.75
Name: oauth.g.xfinity.com
Addresses: 2001:558:fe21:38:162:150:57:167
162.150.57.167


Currently 96.114.156.145 and 68.87.29.197 are responding, but 162.150.57.167 is not:

 


C>ping -n 1 68.87.29.197

Pinging 68.87.29.197 with 32 bytes of data:
Reply from 68.87.29.197: bytes=32 time=36ms TTL=247

 

C>ping -n 1 96.114.156.145

Pinging 96.114.156.145 with 32 bytes of data:
Reply from 96.114.156.145: bytes=32 time=73ms TTL=240

 

C>ping -n 1 162.150.57.167

Pinging 162.150.57.167 with 32 bytes of data:
Request timed out.

Packets: Sent = 1, Received = 0, Lost = 1 (100% loss),


Traces to these IPs look like:

 


C>tracert -4 68.87.29.197

Tracing route to 68.87.29.197 over a maximum of 30 hops

1 15 ms 11 ms 3 ms router1 [192.168.1.1]
2 10 ms 10 ms 12 ms 96.120.9.181
3 13 ms 12 ms 12 ms te-0-6-0-0-sur02.york.pa.pitt.comcast.net [162.151.68.57]
4 12 ms 13 ms 12 ms 96.110.24.214
5     *      19 ms 28 ms 96.110.25.65
6 19 ms 20 ms 19 ms be-34-ar01.mckeesport.pa.pitt.comcast.net [69.139.168.141]
7 26 ms 25 ms 28 ms be-7016-cr02.ashburn.va.ibone.comcast.net [68.86.91.25]
8 29 ms 31 ms 32 ms be-7922-ar01-d.westchester.pa.bo.comcast.net [68.86.94.226]
9 31 ms 31 ms 31 ms be-100-ur21-d.westchester.pa.bo.comcast.net [68.85.137.213]
10 31 ms 34 ms 31 ms 68.87.29.197

Trace complete.

 

C>tracert -4 96.114.156.145

Tracing route to 96.114.156.145 over a maximum of 30 hops

1 16 ms 3 ms 3 ms router1 [192.168.1.1]
2 16 ms 17 ms 13 ms 96.120.9.181
3 11 ms     *        11 ms te-0-6-0-0-sur02.york.pa.pitt.comcast.net [162.151.68.57]
4 10 ms 11 ms 12 ms 96.110.24.214
5 15 ms 13 ms 13 ms 96.110.25.65
6 21 ms 21 ms 20 ms be-34-ar01.mckeesport.pa.pitt.comcast.net [69.139.168.141]
7 27 ms 27 ms 24 ms be-7016-cr02.ashburn.va.ibone.comcast.net [68.86.91.25]
8 27 ms 27 ms 25 ms be-1202-cs02.ashburn.va.ibone.comcast.net [96.110.32.173]
9 27 ms 28 ms 28 ms be-1212-cr12.ashburn.va.ibone.comcast.net [96.110.32.206]
10 43 ms 43 ms 42 ms be-302-cr14.350ecermak.il.ibone.comcast.net [96.110.32.102]
11 42 ms 44 ms 44 ms be-1114-cs01.350ecermak.il.ibone.comcast.net [96.110.35.49]
12 46 ms 45 ms 45 ms be-1102-cr02.350ecermak.il.ibone.comcast.net [96.110.36.98]
13 68 ms     *       67 ms be-10521-cr02.1601milehigh.co.ibone.comcast.net [68.86.85.170]
14 66 ms 67 ms 66 ms ae0-0-ar03-d.cmc.co.ndcwest.comcast.net [68.86.90.74]
15 67 ms 67 ms 69 ms ae-2-0-ar03-d.potomac.co.ndcwest.comcast.net [162.151.85.70]
16    *       68 ms 66 ms be-100-ur05-d.potomac.co.ndcwest.comcast.net [162.151.57.122]
17 65 ms 67 ms 67 ms 96.114.156.145

Trace complete.


C>tracert -4 162.150.57.167

Tracing route to 162-150-57-167-static.hfc.comcastbusiness.net [162.150.57.167]
over a maximum of 30 hops:

1 10 ms 2 ms 2 ms router1 [192.168.1.1]
2 22 ms 13 ms 12 ms 96.120.9.181
3 14 ms 12 ms 10 ms te-0-6-0-0-sur02.york.pa.pitt.comcast.net [162.151.68.57]
4 10 ms 10 ms 10 ms 96.110.24.214
5 13 ms 13 ms 13 ms 96.110.25.65
6 21 ms 23 ms 21 ms be-34-ar01.mckeesport.pa.pitt.comcast.net [69.139.168.141]
7 27 ms     *      29 ms be-7016-cr02.ashburn.va.ibone.comcast.net [68.86.91.25]
8 28 ms 25 ms 25 ms be-1402-cs04.ashburn.va.ibone.comcast.net [96.110.32.181]
9 27 ms 28 ms 30 ms be-1412-cr12.ashburn.va.ibone.comcast.net [96.110.32.214]
10 43 ms 44 ms 45 ms be-302-cr14.350ecermak.il.ibone.comcast.net [96.110.32.102]
11 44 ms 45 ms      *       be-1414-cs04.350ecermak.il.ibone.comcast.net [96.110.35.61]
12 43 ms 44 ms 45 ms be-1402-cr02.350ecermak.il.ibone.comcast.net [96.110.36.110]
13 44 ms 42 ms 44 ms ae-0-0-ar02-d.northlake.il.ndcchgo.comcast.net [68.86.87.70]
14 96 ms 45 ms     *       xe-4-0-0-0-ur10-d.northlake.il.ndcchgo.comcast.net [162.151.24.10]
15-30 *        *            *       Request timed out.

Trace complete.


So customers who are directed to that non-working IP are out of luck.