Community Forum

Xi6 Live TV connectivity issues

Regular Visitor

Xi6 Live TV connectivity issues

I have upgraded 3 of of my cable boxes in my household to the xi6 4k units. Because of the size of the house, I have Ubiquiti AP's which have no WPS feature, so I have all 3 hardwired into the network. A photo is attached.

Each time I restart the unit,  the Xi6 boxes load up and then a black screeen appears with no live tv, I am able to access the menu and go on apps like youtube and watch videos with no problem. I have found a work around where after going on Demand, and watching the start of a free movie, I hit the channel button to return to LIVE TV and the picture is up. However this seems to only last a day and I have to do the same going on Demand process again.

 

The main DVR is the 4k XGIV4.  I went to a comcast store and the rep gave me the XI6 boxes and said the setup would be rather simple. Thankfully I have ethernet at each of the tv locations. 

 

If the picture doesn't load, here is a google drive link to it showing my wired setup.

https://drive.google.com/file/d/1Bh8qoTZf4Cx6QYlz_NMmA8noHoYjmEXF/view?usp=sharing

 

setup.png

Diamond Problem Solver

Re: Xi6 Live TV connectivity issues

You don’t have modem compatibility. Check out this link
https://www.xfinity.com/support/articles/wireless-tv-box-faqs

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Regular Visitor

Re: Xi6 Live TV connectivity issues

I wish someone would have told me about this. It was a hassle calling support several times with no solution.  Will the gateway work fine with the gigbit switches I have? Also I really don't want to have to spend more money on a rental fee, can I purchase a used one online and register that with my account?

Diamond Problem Solver

Re: Xi6 Live TV connectivity issues

Sorry, the compatible gateways are not available for retail sale.

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
New Poster

Re: Xi6 Live TV connectivity issues

CCAndrew....Thanks for the information. Now I know why my Xi6 boxes needs to be restarted every time I turn on my TV. I got mine five days ago and was having problem ever since.  I own my Modem (Arris TG862G) and found out on the 'link' that it is not compatible with the Xi6 boxes. The only ones compatible with the Xi6 box is Arris3482G or Arris1682G and some other brands which is only available for rentals. I only have one UHD/HDR TV hooked up to XG1v4 main cable box and it's working fine. Since the other TVs are not UHD/HDR , I have no need for the Xi6 boxes and would switch back to the coax model XiD. Besides I do not want to rent the compatible modem. I spent so much time with two technicians trying to resolve this issue but they do not know that the Modem should be compatible with wireless Xi6 box. Thanks CCAndrew !

Regular Visitor

Re: Xi6 Live TV connectivity issues

I have the same issue, everyday when I turn a TV on for the 1st time, I just get a black screen. I’ve had my units, 2, for a few months, and I’ve always had the issue.
My workaround has been to hit the guide button, @ the black screen, then turn the TV to a channel other than the 1 the TV is currently on. It will ask to “Try Again”. Programming is displayed after hitting enter.
I have my own Arris cable modem. Both of my boxes are the Xi6 model.