Community Forum

Xi5 doesn’t work

Regular Visitor

Xi5 doesn’t work

I have a new xi5 wireless box that a tech set up before all of my household goods, including my kitchen tv, were delivered.  My hardwired TVs all work but no matter what I do I can’t get the xi5 on the kitchen tv to work. When I plug it in I get a flashing green light for about a minute, than nothing. If I push what I think is the on/off button top nothing happens. Any thoughts? Thanks 

Tags (1)
Official Employee

Re: Xi5 doesn’t work

Are you sure it’s an Xi5? There’s no button on top and the light is white. Maybe XiD? It may just need to get swapped out
https://www.xfinity.com/support/articles/x1-hub-vs-companion-box


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Xi5 doesn’t work

You are correct I gave the description of the wrong box. The box that isn’t working has XI5-P on the bottom, and what looks like a button with 2 pointers facing each other. I’ve plugged in this box and attached the hdmi from the box to the tv. No luck. Tv says weak or no signal. Wi-Fi signal here is good as I can stream Xfinity to my phone and tablet from this location. Thanks for any help you can provide.
Official Employee

Re: Xi5 doesn’t work

When you first plug it in does it go to a welcome screen and then the weak Wi-Fi signal message?

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Xi5 doesn’t work

No.  It goes right to the weak signal message. 

Official Employee

Re: Xi5 doesn’t work

That means it’s justbtoo far away from the gateway, doesn’t really matter if your personal devices work fine. Try to restart the gateway and the Xi5. If that doesn’t work, Either the gateway needs to move closer, use a wired cable box or possibly use a Roku and use the Xfinity stream app and save the cost of a cable box

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Xi5 doesn’t work

As a test I moved the wireless box and tv to within 6 feet of the master box/gateway. I also swapped out the hdmi cable in case that was the problem. Still doesn’t work. Not sure I want to do the Roku Route at this point, so what is my next option. Could the box be bad? Is there a way to test it?