Community Forum

Xfinity X1 Audio Sync Issues

Frequent Visitor

Xfinity X1 Audio Sync Issues

Over the last few weeks, I notice that program audio seems to getting out of sync with the video.  The audio advances faster and gains about a second every hour.  Changing the channel and returning seems to force a re-sync.  Hope we'll see a fix for this soon.

Expert

Re: Xfinity X1 Audio Sync Issues


@gk1227 wrote:

Over the last few weeks, I notice that program audio seems to getting out of sync with the video.  The audio advances faster and gains about a second every hour.  Changing the channel and returning seems to force a re-sync.  Hope we'll see a fix for this soon.


I would unplug the cable-box at least a minute. Plug it back in and allow it to reset. 


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Xfinity X1 Audio Sync Issues

Any channel change seems to reset it, but within 1/2 hour it's out of sync again.

Expert

Re: Xfinity X1 Audio Sync Issues


@gk1227 wrote:

Any channel change seems to reset it, but within 1/2 hour it's out of sync again.


have another set top box in the home? if so, temporarily swap them and see if problem stays with the TV or moves with the box.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Xfinity X1 Audio Sync Issues

Same issue continues.  I have only one X1 box.  Every 1/2 hour or so, you have to change the channel and change it back to re-sync the audio.  In each case, the audio advances ahead of the video.  It is not a function of the cabling as the same problem occurs even if the monitor is attached to the coaxial output, the component output or the HDMI output.

Expert

Re: Xfinity X1 Audio Sync Issues


@gk1227 wrote:

Same issue continues.  I have only one X1 box.  Every 1/2 hour or so, you have to change the channel and change it back to re-sync the audio.  In each case, the audio advances ahead of the video.  It is not a function of the cabling as the same problem occurs even if the monitor is attached to the coaxial output, the component output or the HDMI output.


please use the voice command 'about' and reply with your set top box version line. Does the problem happen on live TV? on-demand? playback of recorded shows? Is the set top box connected to the TV directly or through another device? Is the audio path all HDMI?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: Xfinity X1 Audio Sync Issues

Box version PX001AN_30p26s1_PROD_sey

 

Live TV;  DVR and on-demand playback is often choppy, but I assume that's not box related.  Signal strength on the box is "good" and no alerts on signal strength have ever been generated.  Cable modem on the same line shows good signal, good SNR and negligible errors.

 

Periodically, the box experiences delays of 3-4 seconds in responding to a command from the remote.  This is always resolved by a box reboot.

 

Occurs regardless of the connection.  HDMI, componenent or coaxial. 

Expert

Re: Xfinity X1 Audio Sync Issues


@gk1227 wrote:

Box version PX001AN_30p26s1_PROD_sey

 

Live TV;  DVR and on-demand playback is often choppy, but I assume that's not box related.  Signal strength on the box is "good" and no alerts on signal strength have ever been generated.  Cable modem on the same line shows good signal, good SNR and negligible errors.

 

Periodically, the box experiences delays of 3-4 seconds in responding to a command from the remote.  This is always resolved by a box reboot.

 

Occurs regardless of the connection.  HDMI, componenent or coaxial. 


next time you watch the DVR 'to' clean status, swap it for a newer DVR (latest is xg1v4 yours is xg1v1).



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Contributor

Re: Xfinity X1 Audio Sync Issues

My x1 box was failing and it was replaced. Now I have the audio delay. How do I fix this?
Regular Contributor

Re: Xfinity X1 Audio Sync Issues

Your TV or receiver may have setting adjustments for audio sync if you always have the same delay.  Mine only gets out of sync once in a while, usually after using TV apps, then switching back to the X1 HDMI input.  Switching the TV input to a different HDMI port and back seems to clear it up but your equipment may have different quirks.