Community Forum

XRE-10007 Error - need help

caseyj374
New Poster

XRE-10007 Error - need help

I am getting the dreaded XRE-10007 error.  However, here is my setup:

XG1v4-A - hard wired to my home network

XI6-T - hard wired to my home network

XI6-T - hard wired to my home network (Brand new box from xfinity store).

 

All are on same network, there is a MoCA filter on the input of the splitter.  This just started happening, the MoCA filter has been in place for a couple years.  I also own my own modem, but have been told by tech support that you can own your own modem and they sent a tech out, tech wouldn't look at it said it was a moca communication error with my modem and wouldnt do anything about it - yet I dont understand that - It doesn't touch the modem for communication between boxes.  It's all hard wired LAN.  Literally plugged into the exact same switch. Basic setup.  

 

Comcast please help!  This is frustrating - brand new tv and setup in my basement and I have to keep hitting try again to watch TV.

CCAndrew
Diamond Problem Solver

Re: XRE-10007 Error - need help

You need a Comcast gateway, not your own modem for Xi6 boxes to work properly. In a normal setup the dvr talks to the gateway, gateway talks to the Xi6. Your personal modem doesn’t do that, thus the error. The moca filter’s sole purpose is to keep your service in, neighbor’s service out, there’s no other purpose

https://www.xfinity.com/support/articles/wireless-tv-box-faqs

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
caseyj374
New Poster

Re: XRE-10007 Error - need help

So why has this worked up until recently? Even before the new xi6 i was having this problem with the first xi6 in the other bedroom.  This is totally unfair to have to pay for a modem rental just to fix this issue. That's why I bought my own modem.  To not have to pay the $16/month.

CCAndrew
Diamond Problem Solver

Re: XRE-10007 Error - need help

It’s not unfair, it’s how the boxes are meant to work. Swap to a box where you need a live cable signal or use a Roku with Xfinity Stream app

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
caseyj374
New Poster

Re: XRE-10007 Error - need help

Here's the question though: Why did this all of a sudden stop working? This was working before. I've always had an owned modem.

CCAndrew
Diamond Problem Solver

Re: XRE-10007 Error - need help

Here's the question though: Why did this all of a sudden stop working? This was working before. I've always had an owned modem.
____________
And it only occurred after adding a second wireless box or 2 wireless boxes? You say “always working” but equipment was added

I am a Retired Official Comcast Employee
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
caseyj374
New Poster

Re: XRE-10007 Error - need help

I have had the DVR and 1 of the wireless boxes.  Up until about 3 weeks ago I started getting this XRE-10007 error.  I added a second one for my tv downstairs about 3 days ago and they both get this error.  I'm trying to tell you that this problem has not always existed. Something has changed.  It is not the firmware on my modem.  I verified and its the same firmware that has been on there since I bought the modem in early 2020.