Community Forum

XG1V4 box HDMI handshake problem

Contributor

Re: XG1V4 box HDMI handshake problem


@Rozr1 wrote:
any resolution or info regarding this issue from comcast? this is just getting worse and worse for me.

Ridiculous


 Nothing.  Not too optimistic. I’ve been dealing with since November.  Great lip service from Comcast but no resolution.  Been waiting for a return call from a Senior Advanced repair person, Mark, who assured me he would call after he discussed with engineers  that was one month ago

Contributor

Re: XG1V4 box HDMI handshake problem

IMO, it will not be solved until Comcast has acutaul 4K programing. I just use the smart TV netfilx. Hands down better than comcast in terms of picture quality.

Expert

Re: XG1V4 box HDMI handshake problem


@Rozr1 wrote:
any resolution or info regarding this issue from comcast? this is just getting worse and worse for me. I'm on fw 100 which shows dl on 7/1, if anything it made the issue worse.

Ridiculous

there are two versions that 'change', one is the one you referenced the XRE (menu system). the other is the firmware and appears on the about screen after "STB Version". The problem may be a firmware but can't be a menu issue. the problem may also be a hardware (the box design components) issue. it is unknown at this time. I change input on the TV to chromecast/DVD/roku then back to the DVR and the connection wakes up.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Frequent Visitor

Re: XG1V4 box HDMI handshake problem

I think I may be a new victim with this issue.  Started losing video and sound for a 5-10 seconds a week ago, replaced all the HDMI cables with new high speed.  Not fixed.  Setup is XG1V4 to an old Marantz receiver and then to Panny F8500 (not 4K).   Thought OK, guess the Marantz HDMI ports are going, wanted to upgrade anyway and picked up a new Denon 2500 A/V. 

Now I am losing video every 15mins or so for a few seconds.  Always re-connects but makes tv unwatchable.  Strangely seems much worse when using Netflix or Amazon from the XG box.

Do these sound like the same handshake issues everyone is reporting?  Seems the one difference is it always reconnect by itself.

 

Contributor

Re: XG1V4 box HDMI handshake problem


@chrisinfla wrote:

I think I may be a new victim with this issue.  Started losing video and sound for a 5-10 seconds a week ago, replaced all the HDMI cables with new high speed.  Not fixed.  Setup is XG1V4 to an old Marantz receiver and then to Panny F8500 (not 4K).   Thought OK, guess the Marantz HDMI ports are going, wanted to upgrade anyway and picked up a new Denon 2500 A/V. 

Now I am losing video every 15mins or so for a few seconds.  Always re-connects but makes tv unwatchable.  Strangely seems much worse when using Netflix or Amazon from the XG box.

Do these sound like the same handshake issues everyone is reporting?  Seems the one difference is it always reconnect by itself.

 


Sounds much different than the HANDSHAKE issue I have been dealing with since November 2018   Also sounds much different than the Handshake issues I have been reading about in this forum 

Regular Visitor

Re: XG1V4 box HDMI handshake problem

I thought I conquered the handshake issue Changed hdmi port tv reconnected and Xfinty icon appeared.  Had Comcast icon worked for four days!  Some up and turned on tv and guess what black screen.  Unplugged cable box and picture/sound back.  I said f--k it reconnected thru Yamaha A\V.  I AM IN PROCESS OF CANNECTING HARMONY HUB/COMPANION RUNNING IT CABLE TO MEDIA CENTER.  I will report back to let everyone know if it was successful.  Timbo

Frequent Visitor

Re: XG1V4 box HDMI handshake problem

Well I asked for a new box and it's on the way. Will post results here.
Over the last hours or 2 I've noticed that the issue stabilizes after an HDMI reconnect but always starts to come back after about 20 mins and get progressively worse.
New Poster

Re: XG1V4 box HDMI handshake problem

yea I'm mad I replaced my hdmi cables to due to this issue. My new ones exceed current specs and still same handshake issue. When it happens I can switch to hdmi 2 for firetv or hdmi 3 for chromecast and screens are working perfectly fine, but black screen for comcast so it's an comcast issue.
Regular Visitor

Re: XG1V4 box HDMI handshake problem

Hello everyone,

I am happy to report that I was successful in bypassing the Comcast handshake issue.  I went out and bought a Harmony Hub.  I took the Comcast box out of the loop!  From what I have read from all the articles most people are using an a/v unit, replugged all devices back through my Yamaha A/V and that will do all the switching.  Amazon has a great deal on hug and remote.  Huh works well, only thing is you lose voice function.  

Logitech does have a voice remote but pricey.  I am happy with my set up.  I had a old Touch remote from Logitech  everything turns on and switches to the right inputs.  Good luck everyone!!

Regular Visitor

Re: XG1V4 box HDMI handshake problem

Yeah let us know if that fixes the issue. I’ve had the 4K box for a few months now (with TCL 6 series) and just in the last few weeks, the hdmi handshake issue appeared. And I have the problem at least once a day and I either have to unplug the dvr or the hdmi to the tv. It’s very frustrating to deal with. But I don’t want to go back to an old box version. Hopefully they will push a software update to correct the issue. I have no idea why I had no issue for the first few months owning the box and now every day I have to deal with it.
New Poster

Re: XG1V4 box HDMI handshake problem

I also have a Denon receiver and the same issue. Ever find a solution?
Contributor

Re: XG1V4 box HDMI handshake problem


@Cbutterw430 wrote:
I also have a Denon receiver and the same issue. Ever find a solution?

Only turning offf  the UHD to the HDMI port the x1 box is connected too. When this is done handshake issue goes away   Then turning it back on after tv and system starts.  Had issues since Nov 2018.  Comcast totally useless in fixing issue even the Comcast people on this forum like Comcast Ken and Rafael. Who contacted me several times then disappeared   aA Comcast Advanced support person (Mark) call me. He was going to contact the Comcast engineers  then call me back.  This was over 5 weeks ago. No Call yet.  Says a lot about Comcast support. POOR CUSTOMER SERVICE NO  interest in fixing a long going nation wide issue  

Frequent Visitor

Re: XG1V4 box HDMI handshake problem

I ended up changing HDMI to ver 1.6 in the Denon to fix this.  I'm only 1080P tho, doesnt help you 4K people.

Regular Visitor

Re: XG1V4 box HDMI handshake problem

I have been having a similar issue for many months. After looking at this thread and one titled “XG1V4 requires reboot everyday”, I decided to change my XG1V4 update setting time because there might be a problem with the XG1V4 box when it tries to update itself and reconnect at night when my TV is asleep.

I changed my XG1V4 “xfinity/Settings/Preferences/General/Daily Update Time” to “12:00-2:00a” so all updates would occur after I went to bed and before my TV went into sleep mode. It has been over two weeks now and I have not had any more problems. You might want to try this work around and see if it helps your situation.

Contributor

Re: XG1V4 box HDMI handshake problem


@jjgcsb wrote:

I have been having a similar issue for many months. After looking at this thread and one titled “XG1V4 requires reboot everyday”, I decided to change my XG1V4 update setting time because there might be a problem with the XG1V4 box when it tries to update itself and reconnect at night when my TV is asleep.

I changed my XG1V4 “xfinity/Settings/Preferences/General/Daily Update Time” to “12:00-2:00a” so all updates would occur after I went to bed and before my TV went into sleep mode. It has been over two weeks now and I have not had any more problems. You might want to try this work around and see if it helps your situation.


Hi

Thanks for the  tip.  I have since November changed the the update time to a variety of different times as was suggested by someone several months ago.   However, I am not clear about one part of your suggestion.  That is change the update time so it up dates before the TV goes to sleep mode.   My system is set up so when I turn the system off at night when going to bed the TV, sound, and X1 box (after awhile) all turn off.  My TV Sansumg 2017 Q7 does not have a setting that I have found that does anything other than turn the TV off (in a mode that it goes on instantly when turned on)  I have tried changing the update time to like 8am-12pm and just leaving the TV on during those hours and it did not make any difference.   Still need to rebood every 3/4 days when the UHD is left on.    

Valued Contributor

Re: XG1V4 box HDMI handshake problem

When all this started we all were looking for a potential solution. One that was offered , especially for Samsung TV owners, was to shut the UHD option. That seemed to work for me at the time. But I'm about to take the Netflix upgrade to 4K so I turned the UHD back on and for 2 days at least I have not had a handshake issue. Is there any chance that Comcast has fixed this problem?

New Poster

Re: XG1V4 box HDMI handshake problem

Its still not fixed. I've been on UHD setting on my TV (via Reciever) the whole time and it happened again yesterday. 

 

I've actually just bitten the bullet and yesterday moved to FIOS fiber and cutting the cord. I'm sick of waiting for Comcast on this and having no 4K content of their own. Couple this with the quality of video streams being constantly reduced due to compression as they add more channels and I am finally done with Xfinity.

Regular Visitor

Re: XG1V4 box HDMI handshake problem

Hi Everyone,  the only thing that.worked for me was to take it out of the  loop.  I use a Harmony Hub to take care of all my switching.  Can be used with or without A/V Componet.   Harmony Hub and basic remote can be found at several retail for under 100.00 dollars.  You can also use tablet/ smartphone to contro.  It is difinity xfinity box have not had any issues since I set up over a month ago!  Good luck everyone l

Contributor

Re: XG1V4 box HDMI handshake problem

According to Samsung, the UDH setting for an a HDMI port is meant for gaming: https://www.samsung.com/us/support/answer/ANS00079575/

 

We have had  no problem for months now with this setting off and the cabl box power saver on. 

Norpt sure why you all keep screwing around with that setting if the problem comes back.  You don't need it to be on. 

Contributor

Re: XG1V4 box HDMI handshake problem


@radnortx1 wrote:

According to Samsung, the UDH setting for an a HDMI port is meant for gaming: https://www.samsung.com/us/support/answer/ANS00079575/

 

We have had  no problem for months now with this setting off and the cabl box power saver on. 

Norpt sure why you all keep screwing around with that setting if the problem comes back.  You don't need it to be on. 


You are RIGHT  after months of dealing with this have done what you suggested.  The only reason my family has been turning it on and off is because we THOUGHT we were seeing a better picture qulity with it turned on.  HOWEVER,  after thourghly looking at the 4k picture quality with the UHD turned OFF  we came to the realization that there is NO actural difference.   Our 4K picture quality through, Comcast, YouTube, and Netflix are excellent.   No difference with UHD to that port on or Off.  Thanks for your post 

Valued Contributor

Re: XG1V4 box HDMI handshake problem

My new Comcast tier (signature) comes with Netflix included. But it is the lower level Netflix and so I plan to upgrade to the UHD Netflix and see if the picture quality is worth the extra $3 a month. So I wanted to see if turning on the HDR option in my Samsung would cause the handshake issue to return. The handshake issue is so frustrating that I would forgo the Netflix 4K. So far there has not been a handshake issue. But once I get the upgraded Netflix I will try different options to see if it is really worth the 3 monthly surcharge.

 

Interesting side note RCN cable has just wired my street and offered me the same level of service as Comcast for about $100 less a month than I am currently paying. That is a big savings, but RCN is a small company that is only in a few cities and I am not sure of the quality of their service.  I certainly don't want a service that  has constant problems expecially with my internet connection. Plus they don't offer mobile phone service so I would have to start paying for mobile phone servioce instead of using my XfinityMobile phone. So I am going to wait a few months and see what feedback I get from any neighbors who sign up. 

Contributor

Re: XG1V4 box HDMI handshake problem


@WindsurfMaui wrote:

My new Comcast tier (signature) comes with Netflix included. But it is the lower level Netflix and so I plan to upgrade to the UHD Netflix and see if the picture quality is worth the extra $3 a month. So I wanted to see if turning on the HDR option in my Samsung would cause the handshake issue to return. The handshake issue is so frustrating that I would forgo the Netflix 4K. So far there has not been a handshake issue. But once I get the upgraded Netflix I will try different options to see if it is really worth the 3 monthly surcharge.

 

Interesting side note RCN cable has just wired my street and offered me the same level of service as Comcast for about $100 less a month than I am currently paying. That is a big savings, but RCN is a small company that is only in a few cities and I am not sure of the quality of their service.  I certainly don't want a service that  has constant problems expecially with my internet connection. Plus they don't offer mobile phone service so I would have to start paying for mobile phone servioce instead of using my XfinityMobile phone. So I am going to wait a few months and see what feedback I get from any neighbors who sign up. 


I did upgrade my Netflix to get the 4k movies.  With my Samsung TV UHD turned off on the Port going to the X1Box When I Watch the Netflix 4k movie it is great.  It makes no difference if the UHD on the TV to that port is on or off  Picture is 4k great either way, so this has proven to me that like some have said that the UHD does NOT have to be on to the port.  The few comcast 4k movies that are out there are also great with the UHD off.  As is the 4K content on you tube.  I access Netflix by telling the X1 to go to Netflix   Also when I look in the settings on the X1 box I have it set to best picture quality and it always shows 4K UHD at both the X1 box and at the TV whether the TV UHD port is on or off.   Anyway, I am done dealing with the "handshake" issue, becasue I discoverd based on my viewing and what another said on this forum the UHD can be off and the  picture will always deliver 4k UHD from the box as long as the TV and box are set up correctly.  Good luck

Regular Visitor

Re: XG1V4 box HDMI handshake problem

This is a year later from when these posts occured and the problem still exists.  I have a 4k Vizio 75" TV connected with the highest grade HDMI cables to the XG1V4 box.  I also have an apartment connected to my home in which they use my comcast signal and were getting errors watching DVR movies they recorded.  It turned out the X1 box was too old to manage the decompression of the recorded shows so the Comcast engineer replaced the box which resolved the problem.  But he also replaced my older DVR box with the XG1V4 and this problem began the first day of replacement and has continued since then requiring a hard reboot of the box daily in order for me to get a signal again.

 

Once I do this then the apartment loses their signal until my unit boots up which can take awhile.  I can leave my box on for several hours and even over night without any viewing problems, but once I turn the TV off  and leave off for the night I cannot get a Comcast signal the next morning withou unplugging the power supply and replugging it back in.

 

I've gone through several XG1V4 boxes replaced by Comcast engineers, who have also reconnected my endpoints from outside of my home to the box to make sure I have a strong signal which I knew couldn't be the problem nor can the cable be the problem because once I'm viewing the signal and quality is perfect.

 

I don't have a Comcast signal each morning until after I reset the power supply.  I suspect this problem only occurs on TV's that are 4k and there is a handshaking problem between the XG1V4 and 4k TVs.

 

Comcast needs to resolve this bug or lose customers.

Highlighted
Contributor

Re: XG1V4 box HDMI handshake problem

Yep, you have to unplug & plug in the hdmi cable in to wake it up. Or just make sure the UHD setting is off. Then you wont have a problem.

Official Employee

Re: XG1V4 box HDMI handshake problem

Hi All, 

 

Thanks for posting. The handshake issue has been reported to our engineering teams. I've spoked with a few of you in the forums and have able to figure out some workarounds like disabling UHD and disabling eco saving modes on both the cable box and the TV. This issue seems to be affecting select TVs. 

 

Please send me a private message if you would like me to take a look into this for you. We'll do some troubleshooting and take a look at our options. 

 

Ken


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: XG1V4 box HDMI handshake problem

Just being reported??? Are u serious. This forum goes back almost a year. Sad.
New Poster

Re: XG1V4 box HDMI handshake problem

I'll be sending a PM.
Contributor

Re: XG1V4 box HDMI handshake problem

IMO, it will not be resolved until Comcast actually offers 4K programing. As long as its only Netflix or Amazon Prime, they'll never fix it.

Silver Problem Solver

Re: XG1V4 box HDMI handshake problem


@BrianHCM1 wrote:

IMO, it will not be resolved until Comcast actually offers 4K programing. As long as its only Netflix or Amazon Prime, they'll never fix it.


Comcast will offer 4k when the Networks (CBS, NBC, ABC, etc. start providing 4k content.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Regular Visitor

Re: XG1V4 box HDMI handshake problem

The problem has been resolved, I had to go back to the older box version.  Engineer #5 came and admitted this issue and Comcast has no 4k capability in any of its broadcasts and this issue would not be resolved until it did.  Trouble now is they charged me a $39.99 installation fee for the new "Old" box and promised to reimburse on my bill but they did not.  I'm estimating   7 hours of my time used to research this problem, 3 times I've had to explain to my teams at work why I'm leaving early to go home and meet an xfinity engineer who did not know what the problem was and simply replace the box.

 

Working in the IT industry it would have been far better QOS had xfinity made a incident post to all of their engineers there is a known issue with the XG1V4 box it would have saved a lot of my time and theirs as well.  And now I have to argue with them about the install charge which will take more of my time.  I've been a Comcast customer since 1995, the product has been good over the years but the QOS and customer service has been going down hill.

New Poster

Re: XG1V4 box HDMI handshake problem

I have the EXACT same issue with the same Samsung S-UHD TV - a top of the line tv that's only 2 years old and which had ZERO problems with Xfinity until their new Xfinity1 box came out. Every single morning it requires a reboot of the TV.

Regular Visitor

Re: XG1V4 box HDMI handshake problem

How much more QOS would have been accomplished had your install engineer say “I know what this is!” And then give you options. Sad the customer has to do the leg work.
Contributor

Re: XG1V4 box HDMI handshake problem

To reiterate :

1. Make sure UHD setting is off to the HDMI port you are using

2. Turn on cable box Power Saver

 

These two changed should resolve the problem. I've been trouble free for months. 

New Poster

Re: XG1V4 box HDMI handshake problem

how do I send a PM in this forum?

 

I have the same handshake issue, Samsung UHD TV.  

 

Yes, if I turn off UHD I don't have to reboot the box everyday, but then I have to go in and change it every time I want to watch something in 4 K.  


The box needs a firmware fix.

Contributor

Re: XG1V4 box HDMI handshake problem


@tjf120 wrote:

how do I send a PM in this forum?

 

I have the same handshake issue, Samsung UHD TV.  

 

Yes, if I turn off UHD I don't have to reboot the box everyday, but then I have to go in and change it every time I want to watch something in 4 K.  


The box needs a firmware fix.


Hi

Click on the persons forum name Upper left  corner and send the message from there.  

Also, I to have a 2017 Q7 75" Samsung and been dealing with the issue since November 2018.  Several on the forum indicated that it really does not make any difference if the  port has the UHD turned off or not because  that the picture quality will always be 4k if all the settings are correct on the X1 and the TV    After months of experimenting with watching 4K on YouTube, Amazon and Netflix with UHD off and On, I came to the conclusion that I could not see any difference in picture quality with it on or off so I have been leaving it off. 4K quality was always great

Try it out and see what "your eyes" tell you.   However, Comcast SHOULD fix the issue. Period.

Anyway Good Luck

Contributor

Re: XG1V4 box HDMI handshake problem

👍👍👍👍
Regular Visitor

Re: XG1V4 box HDMI handshake problem

I've been a Comcast customer since 1995, I'm always told how much they appreciate me being a long time customer but the volume of repeat visits by engineers and phone calls to their support reps to troubleshoot issues has been on a significant increase.

 

I've elected to remain a long time customer even though the costs have increased because of the hassle of switching to Direct TV or Dish especially with mixed packages.  I'm not as concerned about the handshaking issue with the XG1V4 as I am with this "should" have been a known issue engineers and reps and 21 hours of my time needing to take off from work to resolve and discover on my own what the issue was is a game changer.  Technical issues arise with any carrier, how they manage issues, compensate and serve their customer base is the game changer.

 

I don't know if I'm going to switch carriers or not, but I'm now going to investigate the cost difference and research QOS on the other carriers.

New Poster

Re: TV and new DVR losing hardwired connection

Just checking in. I have the problem as described in this lengthy topic - and I’m running LG OLED with a Yamaha A/V receiver. Comcast rates right up there with the IRS in my opinion.
Valued Contributor

Re: TV and new DVR losing hardwired connection

My reconnection problem disappeared 6 months ago when I disabled the UHD connection. 2 weeks ago as a test I turned the  UHD back on in my Samsung TV and today for the first time I had the reconnect problem again and had to disconnect the HDMI cable to reconnect.

Expert

Re: TV and new DVR losing hardwired connection


@ridge_farmer wrote:
Just checking in. I have the problem as described in this lengthy topic - and I’m running LG OLED with a Yamaha A/V receiver. Comcast rates right up there with the IRS in my opinion.

is your DVR connected to the receiver or the TV. many have reported that connecting the HDMI to the receiver solves the issue. 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XG1V4 box HDMI handshake problem

This problem started on my setup a few months ago, a setup that hasn't changed for many months. I have Samsung UHD. I can't say what the Xfinity box is without checking. I have tested and tested and have come to the conclusion that if I turn the power off via the Xfinity remote too soon after doing anything else with the remote, such as change a channel or return from On Demand after watching a show, or return from smart mode on the TV, back to the Xfinity box and immediately turn off via the remote, the next time I want to turn on to watch, the Xfinity box is MIA. This started about the same time as it started not returning to where I left off watching an on demand show if I returned to it later to resume. Sometimes it returns to as much as a couple minutes back from where I left off. I have proven to myself that if I change channel on Xfinity, return from On Demand, or return to Xfinity from my smart TV, as long as I give it a few minutes on one channel before hitting power off with the Xfinity remote, it will work fine in the morning.

 

Do not tell me this is my TV's fault, or an HDMI cable. This exact issue started on the very same day with a neighbor who has a Sony smart TV. As a computer guy, I'm pretty sure this is some sort of memory issue with the Xfinity box where it can't remember where it was or what it was doing or know that it should be looking for a "handshake",  if it was very recently asked to do something before the power off was requested by the remote.

 

When the Xfinity box is MIA, I just turn it off and on with the front power button. In a couple minutes, it shows that it's alive, and then starts working.

New Poster

Re: XG1V4 box HDMI handshake problem

Thank you!

 

This worked for me!

New Poster

Re: XG1V4 box HDMI handshake problem


@radnortx1 wrote:

To reiterate :

1. Make sure UHD setting is off to the HDMI port you are using

2. Turn on cable box Power Saver

 

These two changed should resolve the problem. I've been trouble free for months. 


Thank you!

 

This worked for me!

Regular Visitor

Frequent no signal xfinity box hdmi

We are frequently receiving a no signal message when we turn on the tv. This issue started about three and a half weeks ago. A tech replaced the box and the hdmi cables, I plugged the hdmi cable into a different input port and yet the issue still exists. The only fix is to power down the box through the power preferences every time or toggle back and forth between hdmi input one and two. It is very frustrating to have to reboot or power down the box through power preferences every day. The small box in our bedroom works just fine. From browsing the forum it appears that this issue has been affecting many other users since January. It is unacceptable to me that this issue or software bug has not been fixed. Especially considering the amount of money we pay each month.
Expert

Re: Frequent no signal xfinity box hdmi


@Dmf2278 wrote:
We are frequently receiving a no signal message when we turn on the tv. This issue started about three and a half weeks ago. A tech replaced the box and the hdmi cables, I plugged the hdmi cable into a different input port and yet the issue still exists. The only fix is to power down the box through the power preferences every time or toggle back and forth between hdmi input one and two. It is very frustrating to have to reboot or power down the box through power preferences every day. The small box in our bedroom works just fine. From browsing the forum it appears that this issue has been affecting many other users since January. It is unacceptable to me that this issue or software bug has not been fixed. Especially considering the amount of money we pay each month.

using the voice remote on the TV set top box having the problem, use voice command about. what is the rest of the line to right of "STB Version..."?



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: Frequent no signal xfinity box hdmi

SX022AN_3.10p1s1_PROD_sey
Contributor

Re: XG1V4 box HDMI handshake problem

I had the same problem on my Samsung for the last year and exactly why you did until the last two box updates came through which now allows me to turn the hdmi color back on and the tv comes on every time. The only two things I notice is that there is about a 5 second delay before the picture comes on when you do your initial start up of the day which is no big deal. The second problem is what I’ve been complaining about for the last year is that the HD picture looks better than the 4k picture which Comcast never addressed. I found a great improvement by replacing the hdmi cable between the box and the tv with a fiber optic hdmi cable which is very expensive (75 to 100 dollars) but made a big difference compared to the 30.00 wire cable I was using. Now the 4 k looks better than the HD but not necessary perfect. This is something I can live with till Comcast comes up with a real fix.
Frequent Visitor

Re: Frequent no signal xfinity box hdmi

My XG1v4 box starting doing this exact same thing within the last few weeks.  I've had this box for a couple of years now and never had this problem.  I believe the hardware is starting to fail.  I am planning on returning the XG1v4 to the local xfinity outlet and getting a new one.

 

My symptoms are not just the HDMI disconnect that the television reports.  Often, the XG1v4 quits responding to the remote control.  This will last 30-60 seconds before it starts responding again.  The XG1v4 user interface is also noticeably sluggish.  I've tried restarting and even disconnecting and reconnecting power, but that doesn't permanently cure the misbehavior.

 

(Note:  Dmf2278, the original poster, mentioned that their issue started about three and a half weeks ago.  This may be about the same time my issues started.  Was there a recent firmware update to the XG1v4?).

Frequent Visitor

Re: Frequent no signal xfinity box hdmi

I also have this problem as described in this post: 

https://forums.xfinity.com/t5/X1/XG1v4-doesn-t-work-with-deep-color-UHD-10-amp-12-bit/m-p/3252555/hi...

 

Only a full disconnect of power on the comcast box restores the picture and this is painful.

 

The old XG1 1080p box worked just fine.   I don't use CEC so it is not that causing the problem. New issue is that the LG auto selects Deep Color On for this port when you power it up so where before I could leave it off and it worked, now I am stuck.

 

Still waiting on a response on that thread for a fix.

Regular Contributor

Re: Frequent no signal xfinity box hdmi

Does hitting exit exit exit 1080 on the remote make it see the resolution change and match up?