Community Forum

XG1V4 box HDMI handshake problem

Frequent Visitor

Re: XG1V4 box HDMI handshake problem

Just so all of you know, I have had this problem with our XG1V4 and LG OLED65G6p since December of 2017.  It's periodic, random, and I resolve it by simply unplugging the HDMI cable from the back of the tv and immediately plugging it back in.  This connection is readily accessible and seems to be the only method to quickly resolve it.    It's annoying!  (along with the non-existance of any Comcast 4K material)

Silver Problem Solver

Re: XG1V4 box HDMI handshake problem


@pcsilvia wrote:

Just so all of you know, I have had this problem with our XG1V4 and LG OLED65G6p since December of 2017.  It's periodic, random, and I resolve it by simply unplugging the HDMI cable from the back of the tv and immediately plugging it back in.  This connection is readily accessible and seems to be the only method to quickly resolve it.    It's annoying!  (along with the non-existance of any Comcast 4K material)


I will wait until the Networks (ABC, NBC, CBS, et al) switch to 4k.  That's when Comcast will be able to offer 4k content.


I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Expert

Re: XG1V4 box HDMI handshake problem

Comcast has not yet announced when the fix is ready for the 'wake up' issue with some TVs and the XG1v4 4k/UHD set top box. The simplist workaround is to change the TV HDMI input to any other port and then back to the HDMI port the set top box is connected. That way no reboot is necessary and you don't lose the current channel's buffer. 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XG1V4 box HDMI handshake problem

Yes I too have had this problem since getting the 4k box. I have a 78'' RCA however it's rumored to be a rebranded Samsung so this isn't surprising. Tried two different boxes and had Comcast try persistently to send a tech out to look at the issue which I refused as we all know it's nothing to do with anything but the box. There's been maybe five forums here about this since the issue started but comcast closes them all with someone claiming a resolution at the end which does not work. I too have been unable to have anyone at Comcast admit the problem. It's ridiculous with the prices they charge they can't or won't resolve this but don't expect anything anytime soon as this has been going on over a year now. Looking at options from RCN and AT&T now as this is unbearable.  

Contributor

Re: XG1V4 box HDMI handshake problem


@EricinChicago wrote:

Yes I too have had this problem since getting the 4k box. I have a 78'' RCA however it's rumored to be a rebranded Samsung so this isn't surprising. Tried two different boxes and had Comcast try persistently to send a tech out to look at the issue which I refused as we all know it's nothing to do with anything but the box. There's been maybe five forums here about this since the issue started but comcast closes them all with someone claiming a resolution at the end which does not work. I too have been unable to have anyone at Comcast admit the problem. It's ridiculous with the prices they charge they can't or won't resolve this but don't expect anything anytime soon as this has been going on over a year now. Looking at options from RCN and AT&T now as this is unbearable.  


Thanks for your post.  Not sure if I am going to change or just keep dealing with.   As seen through this forum it is Nation wide issue with the X1 box.   Just an update with my particular issue.  Previously I had to restart the box when turning on in the morning every 2/3 days.  For  the last 10 days it has been every other day.   

Expert

Re: XG1V4 box HDMI handshake problem


@EricinChicago wrote:

Yes I too have had this problem since getting the 4k box. I have a 78'' RCA however it's rumored to be a rebranded Samsung so this isn't surprising. Tried two different boxes and had Comcast try persistently to send a tech out to look at the issue which I refused as we all know it's nothing to do with anything but the box. There's been maybe five forums here about this since the issue started but comcast closes them all with someone claiming a resolution at the end which does not work. I too have been unable to have anyone at Comcast admit the problem. It's ridiculous with the prices they charge they can't or won't resolve this but don't expect anything anytime soon as this has been going on over a year now. Looking at options from RCN and AT&T now as this is unbearable.  


Samsung does not make a 78 inch UHD television.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: XG1V4 box HDMI handshake problem

I found 2 solutions to this problem.
1)On your Xfinity remote go to settings, device settings,power preference, and turn your power saver ON. Box will go to sleep at night but when you turn your tv on in the am it will turn the box on also. When both the box and tv turn on together the video will connect with no problem.
2) If you have a Samsung tv or a tv with the HDMI UHD COLOR setting turn it off for the HDMI cable box input. Per Samsung this setting must be on for any type of gaming because it increases the refresh rate but for a cable box with 4K it has no effect. I have mine turned off and it’s been working every morning for the last week and the 4K does come thru on Netflix.
Contributor

Re: XG1V4 box HDMI handshake problem


@jmg1951 wrote:
I found 2 solutions to this problem.
1)On your Xfinity remote go to settings, device settings,power preference, and turn your power saver ON. Box will go to sleep at night but when you turn your tv on in the am it will turn the box on also. When both the box and tv turn on together the video will connect with no problem.
2) If you have a Samsung tv or a tv with the HDMI UHD COLOR setting turn it off for the HDMI cable box input. Per Samsung this setting must be on for any type of gaming because it increases the refresh rate but for a cable box with 4K it has no effect. I have mine turned off and it’s been working every morning for the last week and the 4K does come thru on Netflix.

Thanks for your suggestions.  #1 That’s how mine is currently set.  

#2 I’ve never tried that.  I just changed and will see what happens.  I’ll let you know. I sure hope that works. 

Expert

Re: XG1V4 box HDMI handshake problem

simplest work-around is to change the TV to a different live HDMI port then back to the DVR port.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: XG1V4 box HDMI handshake problem


@Rustyben wrote:

simplest work-around is to change the TV to a different live HDMI port then back to the DVR port.


Tried that previously. Does not work for me 

Contributor

Re: XG1V4 box HDMI handshake problem

Tried that and also disconnecting the HDMI cable and plugging it back in which didn’t work for me. The fix might be different for everyone, ultimately Comcast should be fixing this , not us trying work arounds.
Regular Visitor

Re: XG1V4 box HDMI handshake problem

Here's my latest: Called tech support. Rep said this should not be happening but did not seem to be aware of the problem or this forum. A tech came out and decided to replace the 4K box, which worked, but after the tech left the same problem occurred. Called it in again, the same tech came out and said the local engineer suggested using HDMI port #1 instead of port #2 on my Sony TV. I tried this before, but this time it worked, although there's about a 0.5 s delay to connect vs instantaneous before the problem arose. So everything's been working fine for about 2 weeks - hope it won't recur after I send this message!  I did have to spend over an hour explaining the same situation to 2 different tech support staffers and the onsite tech. The tech reps seem to think that Comcast's working on this problem, but who knows.

Contributor

Re: XG1V4 box HDMI handshake problem

Great to hear that.  In our case, for awhile, the DVR box was actually ok (i.e., TV worked fine) but the issue shifted to our two other boxes with two different issues every morning.  Xfninity was out a few times . . . today they changed the DVR box to a different one.  We'll see what happends after the next update tonight.  

I know the box changes have not worked before (this is our 3rd or 4th) but maybe they have done something since we were OK at the main box for the past couple of weeks.

I'll write back in a few days to update everyone.

New Poster

Re: XG1V4 box HDMI handshake problem

Same problem here - black screen with no audio or video every few days. Very annoying and I've found only power cycle fixes. I will try the TV HDMI input change next time it happens . My equipment: XG1-v4-A, Denon AVR-X4400W Receiver, Sony XBR940D 75", Comcast 4K high speed HDMI cable from X1 to AVR; 4k high speed cable using ARC from TV to AVR. 

 

Hoping a fix comes soon otherwise I am swapping this out to older box as there really is no benefit to the 4k box vs 1080p. Netflix is way better on the Android  Sony TV app with Atmos support and a cleaner picture.

Contributor

Re: XG1V4 box HDMI handshake problem

Back yesterday to black screen on DVR but other TVs ok. Today, all ok. Tech coming again tomorrow. If no solution, going to switch back to. FIOS who now has 4K box and voice remote. They pay switching costs. But I need Comcast to take back X1 Pods.
Contributor

Re: XG1V4 box HDMI handshake problem

Good News.  SO FAR  I have not had the problem since I tried your suggestio to turn off the UHD setting to the HDMI port that the  X1 box is connected to.    It has been 10 days since I changed the setting and have not experienced the black screen issue. 

Prior to that I had to restart the X1 every 2/3 days to get a picture on the TV.  

Thank you for your suggestion.   I have been having this problem for months and tried everything people on this forum suggested.   Nothing worked till you mentioned this.

Hopefully it stays like this.

 


@rlee131 wrote:

@jmg1951 wrote:
I found 2 solutions to this problem.
1)On your Xfinity remote go to settings, device settings,power preference, and turn your power saver ON. Box will go to sleep at night but when you turn your tv on in the am it will turn the box on also. When both the box and tv turn on together the video will connect with no problem.
2) If you have a Samsung tv or a tv with the HDMI UHD COLOR setting turn it off for the HDMI cable box input. Per Samsung this setting must be on for any type of gaming because it increases the refresh rate but for a cable box with 4K it has no effect. I have mine turned off and it’s been working every morning for the last week and the 4K does come thru on Netflix.

Thanks for your suggestions.  #1 That’s how mine is currently set.  

#2 I’ve never tried that.  I just changed and will see what happens.  I’ll let you know. I sure hope that works. 


 

Contributor

Re: XG1V4 box HDMI handshake problem

That’s what I did on my LG once the UHD setting was turned off it works with the 4K setting for regular TV. If I switch to Netflix via X1 box for an UHD movie, the tv will automatically switch to UHD on. However when I switch back to regular tv, it will lose signal and go black. I then have to manually turn off UHD on the tv for it to work. It looks like a compatibility issue since Comcast doesn’t offer any 4K programs for regular tv. My guess is the tv is looking for the signal that doesn’t exist yet and just gives up.
Contributor

Re: XG1V4 box HDMI handshake problem

Techs came out today. They set box to power down when TV is off. They were convinced this will work with my Samsung TV. BTW, the UHD setting to the HDMI has been off. I’ll write again once I see if this works.
Expert

Re: XG1V4 box HDMI handshake problem


@BrianHCM1 wrote:
That’s what I did on my LG once the UHD setting was turned off it works with the 4K setting for regular TV. If I switch to Netflix via X1 box for an UHD movie, the tv will automatically switch to UHD on. However when I switch back to regular tv, it will lose signal and go black. I then have to manually turn off UHD on the tv for it to work. It looks like a compatibility issue since Comcast doesn’t offer any 4K programs for regular tv. My guess is the tv is looking for the signal that doesn’t exist yet and just gives up.

On my 2015 3D UHD Samsung TV the UHD color setting can be set "on" or "off" for each individual HDMI port. For IPV (Internet broadband) UHD color setting is always "on" as it should be.   Check your LG manual to set if your's works that way. My tv never switches them from where I set them.

 

A possible exception might be if your television just received a "Update", or if you selected a "Reset to factory default settings.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: XG1V4 box HDMI handshake problem

Glad to hear it works for you too! Mine has been working 3 weeks without a problem.

Contributor

Re: XG1V4 box HDMI handshake problem

Don't give up on Comcast yet, they have been working on the problem. Last week Comcast called me on a update they wanted to send to my box to see if there were any changes. Sorry to say the updated did not correct the condition but at least their working on solutions. 

Contributor

Re: XG1V4 box HDMI handshake problem

If I switch the UHD Color onnor off I also get a black screen , Comcast is working on the problem because I heard from them last week.

Contributor

Re: XG1V4 box HDMI handshake problem

Letting the DVR box go into sleep mode worked for me even though I'm using the UHD Color off on my TV. When youn turn the tv on in the morning the box should wake up also as long as your remote is programed correctly to tun the tv and box at the same time. When the box and tv turn on together they both are looking for a video signal at the same time and connect with no problem.

Contributor

Re: XG1V4 box HDMI handshake problem

Amazing that you have been able to get Comcast to say they are working on it. In my area I gave had three technicians out to my house, 4 telephone conversations with support (two times with supervisors I requested to speak to) replaced the X1 box twice, and one visit to the Xfinity store  EVERYONE says they have no knowledge of the problem and it must be my TV. 

Anyway your suggestion to turn off UHD to the HDMI port WORKED so all is good now

one issue that has shown up is that even though the X1 is set to power saver every couple of days in the morning before turning the system on the light on the X1 is already on so it did not turn off since I last shut down the TV ( 14 hours 

not worried about because your fix took care of the HANDSHAKE issue Would love to connect your Comcast people with those supporting this area 

Contributor

Re: XG1V4 box HDMI handshake problem

My tech said light won’t go off but box goes to sleep. Today I was good but we’ll see tomorrow.
Contributor

Re: XG1V4 box HDMI handshake problem

Right the light on the box doesn’t go off . Glad it’s working for you so far.
Contributor

Re: XG1V4 box HDMI handshake problem

Acturally the light on my box in power saving mode does go off after a couple of hours after the tv is turned off.   Then in the morning it does not go on till I hit the remote turning on the box, Sound and TV.   This happend all the time until I change the HDMI setting that fixed the handshake.   Now when I get up in the morning about 50% of the time the X1 box light is on unlike previously when the the was not on till I hit the remote.  

Not a big deal, dont really care about the power saving mode its just that  for some reason it does not function as it did befor

Regular Visitor

X1 box on but no picture or sound

My X1 box has been acting up. When I turn my TV on, there is no picture or sound. I’m on the correct input and all cords are connected properly. I have found two ways to temporarily get the picture back - 1) If I power off the box and then turn it back on, I get a picture or 2) sometimes (rarely) if I unplug just the HDMI cable and plug it back in the picture and sound come back. 

 

Here is what I have done so far:

  1. I have switched HDMI cords which has not fixed the problem.
  2. I have switched out my X1 box which has not fixed the problem
  3. I even had a service technician come to the house and suprisingly it failed while he was here.  Unfortunately, the only suggestion he had was to change out the cord, which I did and it worked temporarily, but a week later it started happening again.

This seems to be an intermittent problem that I can’t recreate. It just seems to happen. 

Bronze Problem Solver

Re: X1 box on but no picture or sound

I can certainly check this for you from here if you would like. To protect the privacy of your account, can you provide your full name exactly as it's listed on the billing statement? To send a private message click on my name, then click "Send a message".


I am a Retired Official Comcast Employee and no longer actively support the Xfinity Forum.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark a post as the Best Answer!
Contributor

Re: XG1V4 box HDMI handshake problem


@radnortx1 wrote:
My tech said light won’t go off but box goes to sleep. Today I was good but we’ll see tomorrow.

Contrary to that tech  My X1 box light DOES go off when in power saving mode.  THEN when you turn the TV and Box back on you get a message on the TV saying That you have saved power  by your box being off for for so many hours. (para phrase)  

You will not get this message when you turn your TV on if the light on the X1 box is already on when you turn the tv on..   Try it   Manually turn off the box when done with the TV  Then turn off the TV.   When you turn the TV and box on after several hours or overnight you will see that message.

 

Contributor

Re: XG1V4 box HDMI handshake problem

Yes I got that message also when the TV and box came on together. I was also told that even if the box goes to sleep at night the recorder still works. So if you have anything programmed to record in the middle of the night it should work sionce its all cloud based, I never did try it.

Contributor

Re: XG1V4 box HDMI handshake problem


@jmg1951 wrote:

Yes I got that message also when the TV and box came on together. I was also told that even if the box goes to sleep at night the recorder still works. So if you have anything programmed to record in the middle of the night it should work sionce its all cloud based, I never did try it.


Strange now.  After I changed the HDMI Port setting on the TV, like I said previously that fixed the handshake issue, the X1 now never goes to sleep the first few times after changing it would go to sleep “sometimes” now it.  never goes to sleep 

Contributor

Re: XG1V4 box HDMI handshake problem

Comcast send updates to the box at night when not being used, maybe it’s something they are doing.
New Poster

Re: XG1V4 box HDMI handshake problem

fixed problem on vizo tv by changing update time to when i will be watching tv and turned of cec i tv systems setting works fine now

Contributor

Re: XG1V4 box HDMI handshake problem

Didn't realize VIZO was effected with this problem also. Great that you found a work around for the problem. Maybe one of these days Comcast will come up with a pernament fix!

Contributor

Re: XG1V4 box HDMI handshake problem

Set cable box to power down when TV is off. Fixed the problem on our Samsung. The issue is NOT brand of TV related I don’t think. Fixed issued with a Sony TV also.
Contributor

Re: XG1V4 box HDMI handshake problem

I agree that using the Power Saving setting to "on" is a work around for the box problem that works with all brand TV's. The only problem I see with that is Comcast updates their cable box when the tv is off and the box is on, with the box off you will never get updates in their attemp to fix the problem. I would leavev it on at night  a couple times a week so you get the updates. Comcast called me yesterday and they are sending update # 13 for this problem to my box today to see if it corrects the problem, so far all previous updates have not worked. I've been helping them test the new updates to see if there are any changes.

Highlighted
Contributor

Re: XG1V4 box HDMI handshake problem

My tech - senior guy - disagrees. Box will still get updates. It’s just put into a standby condition.
He’s been really knowledgeable about these issues.
Contributor

Re: XG1V4 box HDMI handshake problem

I’m just relaying what Comcast told me about updates. They said to make sure the box is not in sleep mode so that they can send updates to me. You do what you think is best.
Contributor

Re: XG1V4 box HDMI handshake problem

Spoke too soon. Today after a week or two since tech was here back to black screen. I think the real solution is going to Fios in my area. Frustrated.
Contributor

Re: XG1V4 box HDMI handshake problem

Did you try what jmg1951 suggested.  That is turning offf the UHD on HDMI connected to the X1 Box.  On my tv I found that in the TV settings   I tried that about a month ago and have not had the problem of Black screen since.  However,  for some reason it created another issue which is that the X1 box never will go into the sleep mode even though I have that setting turned on.   I had comcast out the other day and the Tech said its is not suppose to go to sleep.  Well that is contray what the information says right under where you turn power savings on/off as well as contrary to what I have experienced  Anyway he changed the X1 box.   That night when I turned off the TV, the box light stayed on But later went into power savings mode because when I got up in the morning the X1 box light was off.  And when the TV came on it did say I had saved 6 hours in power savings.   

That was three days ago and since that one time of the new box  going into power savings mode, it no longer is going into power savings, event though power savings is turned on.  

At least I am no longer having the black screen Handshake problem.   

So if you have not tried turning off the UHD to the port give it a try, it solved my issue and there is no difference in the picture quality its sill great 4K.   jmg1951 had said that the UHD setting is not needed for the X1 box which proved to be correct in my case.

 

 

 

Contributor

Re: XG1V4 box HDMI handshake problem

UHD is off to all HDMIs . . . so that's not it . . . off that it was ok for a while with power saving on on X1 box

Expert

Re: XG1V4 box HDMI handshake problem


@radnortx1 wrote:

UHD is off to all HDMIs . . . so that's not it . . . off that it was ok for a while with power saving on on X1 box


at least two comcast Official Employees have gathered information on the 'no signal' issue. to date nothing has been said on cause nor fix.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: XG1V4 box HDMI handshake problem


@rlee131 wrote:

Acturally the light on my box in power saving mode does go off after a couple of hours after the tv is turned off.   Then in the morning it does not go on till I hit the remote turning on the box, Sound and TV.   This happend all the time until I change the HDMI setting that fixed the handshake.   Now when I get up in the morning about 50% of the time the X1 box light is on unlike previously when the the was not on till I hit the remote.  

Not a big deal, dont really care about the power saving mode its just that  for some reason it does not function as it did befor


Just an update  The handshake issue has not been a problem now for over a month since as suggested I turned off the UHD to that HDMI Port.   

But now the box light NEVER goes off (sleep mode) eventhough its set for power savings.  Had a tech out and he changed the X1 Box.  The first night it went to sleep after that it now never goes to sleep mode.     At least the handshake issue is resolved  NO THANKS TO COMCAST.  

Anyone know how to solve the issue of the box never going to power savings eventhough the power savings is turned on?

Contributor

Re: XG1V4 box HDMI handshake problem

Our light never goes off. In the last 7 days, only one black screen. 5 days so far in a row. Not sure we are really fixed. Did shut off instant on feature on our Samsung before the 5 day run. I’ll update again in a few days.
Regular Visitor

Re: XG1V4 box HDMI handshake problem

My 2014 Vizio P is affected with the same problems as above. I am now trying the sleep setting to on and turning off cec. We’ll see if that helps. But I agree with the above re: randomness of problem. Sometimes I go a week without issue and now it’s every day.
Regular Visitor

Re: XG1V4 box HDMI handshake problem

Turning off cec and turning on power save mode didn’t work for my vizio tv. In fact my tv showed no signal issue 2 times tonight. I’m over it. It’s a waste of time and I’m not paying a cable company my money and my time. How archaic are cable boxes anyway in this day and age. Promising interface but the technology stinks. Oh well. Heading back to Fios. Hopefully Fios One is reliable.
Contributor

Re: XG1V4 box HDMI handshake problem

Did the tv and the cable box both come on at the same time first thing in the morning? This is the only time the power saver comes into play after sleeping at night. It has been working on other brand TVs. Why don’t you just downgrade your box to the older one you had before till they fix the problem with the 4K box. They have to come up with a solution sooner or later with so many people having the same issue.
Contributor

Re: XG1V4 box HDMI handshake problem

Had 7 good days then it happened again. And there was a actual software update. 2 days now ok. But, it’s starting not to be worth it. Never had issues with FIOS. And also we are getting what I call jerky pictures. Motion slows for a split second just enough to be annoying. And it’s happening a lot.
Contributor

Re: XG1V4 box HDMI handshake problem

Btw - box never goes into power save. Never. They really have issues that they are not addressing. Probably will switch back to Fios next week.