Community Forum

XG1V4 box HDMI handshake problem

Contributor

Re: XG1V4 box HDMI handshake problem

I agree. Same with mine usually works fine for no more that three days.
Contributor

Re: XG1V4 box HDMI handshake problem

It’s ok for a few days for me too. It happens after one of “daily” updates which doesn’t always happen. If tv is on during the update, no issue!
Contributor

Re: XG1V4 box HDMI handshake problem

Another issue is the poor quality of 4K anyway. Eyes sparkle like zombies. Native 4K though smart tv apps don’t have that issue. It’s the box. They need to fix all of this.
Contributor

Re: XG1V4 box HDMI handshake problem

I’ve never experienced that problem. My 4K is always perfect

Contributor

Re: XG1V4 box HDMI handshake problem

Others though have complained.
Contributor

Re: XG1V4 box HDMI handshake problem

Yep, it’s awful. Just do a Netflix comparison between direct streaming and the X1 box and the difference is night and day. I’m paying top dollar for a subpar product. Kinda sad
Expert

Re: XG1V4 box HDMI handshake problem


@BrianHCM1 wrote:
Yep, it’s awful. Just do a Netflix comparison between direct streaming and the X1 box and the difference is night and day. I’m paying top dollar for a subpar product. Kinda sad

have you tried setting up your TV while watching netflix in 4k (brightness, contrast, gamma, sharpness, etc)? Netflix offers test patterns to assist in the calibration. The direct streaming does not require that calibration but probably should be checked using the Netflix test patterns.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: XG1V4 box HDMI handshake problem

Stop using your ARC HDMI ports  go to the general HDMI ports and go to 2 clickers...use one to start the functions and the other to correct the TV and for the remainder of when the TV is on you are back to the Comcast clicker...rinse and repeat every time you turn on the TV.

Contributor

Re: XG1V4 box HDMI handshake problem

If I’m watching 4K streaming and Comcast 4K I would hope it would be the same quality. My tv is calibrated. What’s also interesting Comcast 4K Netflix just offers HDR where the streaming offers Dolby Atmos. Seems weak on Comcast’s part.

Silver Problem Solver

Re: XG1V4 box HDMI handshake problem


@BrianHCM1 wrote:

If I’m watching 4K streaming and Comcast 4K I would hope it would be the same quality. My tv is calibrated. What’s also interesting Comcast 4K Netflix just offers HDR where the streaming offers Dolby Atmos. Seems weak on Comcast’s part.


The only "Comcast 4k" content available now is with the Netflix app and you have to pay extra to 

Netflix for the access.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Contributor

Re: XG1V4 box HDMI handshake problem

No clue what you are explaining. Would you be clearer.
Contributor

Re: XG1V4 box HDMI handshake problem

I am paying for 4K Netflix, I upgraded my account when it popped up on the screen
Contributor

Re: XG1V4 box HDMI handshake problem

sorry, I was reponding to a different post

 

Contributor

Re: XG1V4 box HDMI handshake problem

for chicken321 - your post about 2 remotes

 

what are you talking about?   would you explain in more detail?  just dont understand at all what you are suggesting/doing.

Regular Visitor

Re: XG1V4 box HDMI handshake problem

I do not use my ARC HDMI.

 

 I plug my cable box into my Yamaha then plug my Yamaha into another HDMI port in my Samsung Q9.  My Comcast remote lights up the TV and turns on the receiver.  I then take the TV remote go to settings and switch the sound input from TV speakers to my Yamaha.  From there all control can be done with my cable remote. (Volume channel launch Netflix)

When I shut off the tv with the cable remote I need to do the whole process again next time I turn it on.

New Poster

Tv screen is back but has sound

Hello, former employee here. I have the newest 4K box and 65" Samsung QLED tv. This happens almost every day when I come home from work. I turn the tv on, I can hear the sound, but no picture. It works when I unplug it and plug it again or system refresh
by usung the my account app. The thing is I don't want to refresh the system everyday or unplug and plug it back. Before I do anything I also tried unplugging the HDMI cable and plug it back in see if it's the cable issue but no luck. Cable box power setting is set to not to go to sleep.
Silver Problem Solver

Re: Tv screen is back but has sound


@Nateuzunkaya wrote:
Hello, former employee here. I have the newest 4K box and 65" Samsung QLED tv. This happens almost every day when I come home from work. I turn the tv on, I can hear the sound, but no picture. It works when I unplug it and plug it again or system refresh
by usung the my account app. The thing is I don't want to refresh the system everyday or unplug and plug it back. Before I do anything I also tried unplugging the HDMI cable and plug it back in see if it's the cable issue but no luck. Cable box power setting is set to not to go to sleep.

I imagine you new TV has several HDMI ports.  Have you tried each one?

The TV ARC or CEC might be an issue.

I am not a Comcast Employee.
I am just a customer, volunteering my time to help other customers here in the Forums.
Was your question answered? Mark the post as best answer!
Contributor

Re: XG1V4 box HDMI handshake problem

Just an update to my long on going issue.  Today I saw there was a new update available for my TV (2017 75” Samsung. Q7F). I contacted Samsung to see if they knew if this would fix the problem.  Big mistake person was clueless and wanted me to try different things I have already did over several months.   Finally told him he is not familiar with the issue previous support people told me that they were aware of the issue and if I installed firmware update 1260 it would fix the problem.    It did not so now there is a new firmware available 1262  

and I wanted to know if this would fix the issue.   A TOTAL WASTE OF 30 minutes.  This person as usual was clueless

Anyway I installed the new firmware.  I will post when I see if it works.   Being the problem is intermittent only happening every 2-3 days I’ll have to wait and see.  I’m not to optimistic.   Anyone out there solved the problem?

Contributor

Re: XG1V4 box HDMI handshake problem

Installed the firmware update  Version 1262 for the TV    Did not help.  Today when turned on TV X1 box once again would not connect.   As usual I had to restart the X1 via the App  

I suspect this will never be solved. 

Contributor

Re: XG1V4 box HDMI handshake problem

Never was s TV problem.
What App restarts the box?
Contributor

Re: XG1V4 box HDMI handshake problem

I think I solved it on my LG tv. I turned off the HDMI HD deep color setting on the tv. It no longer drops completely. I changed the setting last week and it’s been good so far. Kinda bunk I can’t use all the fancy settings on the TV, but until xfinity gets it together it will have to do.
Expert

Re: XG1V4 box HDMI handshake problem


@BrianHCM1 wrote:
I think I solved it on my LG tv. I turned off the HDMI HD deep color setting on the tv. It no longer drops completely. I changed the setting last week and it’s been good so far. Kinda bunk I can’t use all the fancy settings on the TV, but until xfinity gets it together it will have to do.

On my Samsung UHD television the "UHD color setting" could be turned "off" or "on" for each individual HDMI port.  For viewing 4K /HDR over high-speed broadband it is always "on". You might check your TV manual to see if your LG functions the same.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: XG1V4 box HDMI handshake problem

My guess that is basically the same setting. Once I turned it off it’s now working. Unfortunately I’m sure it’s limiting the picture quality, but better that getting up every hour or so to unplug and plug in the hdmi cable
Contributor

Re: XG1V4 box HDMI handshake problem

Xfinity App. “My Account”

Contributor

Re: XG1V4 box HDMI handshake problem

I know that will most likely correct the issue. But, we shouldn’t have to do that. Comcast promised to fix this weeks ago.
Contributor

Re: XG1V4 box HDMI handshake problem

When and how did Comcast admit to the problem?  I have them out to my house three times and had two telephone conversations with their Technical Support never once did they admit to the problem.  In fact none of them (at home visits and telephone conversations) were aware of such an issue.   They blamed it on my TV and once blamed it on my utility company (PG&E) which I had them come out and said it had nothing to do with them.

So I am now living with just restarting my X1 box via the App every time it does not connect with the TV when I turn it on.  Not every time it’s turned on but periodically, usually every two to three days?

Highlighted
Frequent Visitor

Re: XG1V4 box HDMI handshake problem

Only pockets of Comcast people admit or seem to know about this. I have had agents offer to send someone out, send a replacement, or suggest that this was normal for the latest technology.

 

Mine will work fine for a few days and then exhibit the same symptoms. I have changed HDMI ports on the TV, changed which device gets turned on first, updated various firmware of AVR and TV. None of these has been a solution.

 

If there is a solution, I have not tried it or read it here.

Contributor

Re: XG1V4 box HDMI handshake problem

Thanks for respons   Same issue here.  Oh maybe someday will get fixed.

Frequent Visitor

Re: XG1V4 box HDMI handshake problem

I think I may have found a workaround. Last night before going to bed I powered down the box by saying "power down" into the voice remote. When I got up this morning the TV went on with no problems. If anybody else tries that please let us know the result.

Frequent Visitor

Re: XG1V4 box HDMI handshake problem

Here are a few observations:

1) A firmware fix has not been pushed out yet to my X1 box

2) The power saving mode on the X1 box is not working. The box does not power down automatically when the TV is off and I am not watching.

3) If I power down the box manually before going to bed, either through the voice command or on the power down menu, the box will wake up normally in the morning. That is a workaround that I am using now until this is fixed.

Contributor

Re: XG1V4 box HDMI handshake problem


@Anon1464678 wrote:

Here are a few observations:

1) A firmware fix has not been pushed out yet to my X1 box

2) The power saving mode on the X1 box is not working. The box does not power down automatically when the TV is off and I am not watching.

3) If I power down the box manually before going to bed, either through the voice command or on the power down menu, the box will wake up normally in the morning. That is a workaround that I am using now until this is fixed.

 

These are my observations:

With my X1 I am getting the firmware updates.   My X1 does power down when turned off. I usually turn my system off/ on  with one remote that activates the TV, X1 Box and Denon sound system.  When I tried turning the X1 off with the voice command then manually turning other components off I STILL have the problem.  But like I said previously not every time its turned on.  It happens every 2/3 days.

 

Regular Visitor

Re: XG1V4 box HDMI handshake problem

Same problem - sporadically (once every few days) get no or intermittent connection with white or black screen. Swapped out cables (4K-certified, tested by expert installer)/all device ports (BluRay, Apple TV) to localize problem to the cable box's HDMI port. Have the same problem with a non-4K satellite box, but not as frequently. Haven't contacted Comcast support yet. My best fix is to unplug the HDMI cable from the 4K X1 box, wait 15 s, and then reconnect. I have a Sony UHD 4K TV/Sonos PlayBase and otherwise get astounding picture quality and sound with all X1's 4K services (e.g. Netflix, Prime). I haven't tried tweaking the TV's or the box's settings yet. Thanks everybody for your helpful comments!!

Contributor

Re: XG1V4 box HDMI handshake problem

 

 

 

 


@V8_5-OH wrote:

Same problem - sporadically (once every few days) get no or intermittent connection with white or black screen. Swapped out cables (4K-certified, tested by expert installer)/all device ports (BluRay, Apple TV) to localize problem to the cable box's HDMI port. Have the same problem with a non-4K satellite box, but not as frequently. Haven't contacted Comcast support yet. My best fix is to unplug the HDMI cable from the 4K X1 box, wait 15 s, and then reconnect. I have a Sony UHD 4K TV/Sonos PlayBase and otherwise get astounding picture quality and sound with all X1's 4K services (e.g. Netflix, Prime). I haven't tried tweaking the TV's or the box's settings yet. Thanks everybody for your helpful comments!!


 

Unbelievable that comcast won't address the issue, or where I live even admit there is an issue.  I've had them out three times and they can do noting other than blame it on the TV.  Which after reviewing all the postings over the months tend to believe it is a comcast problem.  I have tried everything that has been posted over the months and still have the problem.  My TV is a Samsung.   By the way you can also retart the X1 box via the "My Account" Xfinity App.   For me its easier than unpluging at the box.  Keep me posted if you find a solution.

Expert

Re: XG1V4 box HDMI handshake problem


@rlee131 wrote:

 

 

 

 


@V8_5-OH wrote:

Same problem - sporadically (once every few days) get no or intermittent connection with white or black screen. Swapped out cables (4K-certified, tested by expert installer)/all device ports (BluRay, Apple TV) to localize problem to the cable box's HDMI port. Have the same problem with a non-4K satellite box, but not as frequently. Haven't contacted Comcast support yet. My best fix is to unplug the HDMI cable from the 4K X1 box, wait 15 s, and then reconnect. I have a Sony UHD 4K TV/Sonos PlayBase and otherwise get astounding picture quality and sound with all X1's 4K services (e.g. Netflix, Prime). I haven't tried tweaking the TV's or the box's settings yet. Thanks everybody for your helpful comments!!


 

Unbelievable that comcast won't address the issue, or where I live even admit there is an issue.  I've had them out three times and they can do noting other than blame it on the TV.  Which after reviewing all the postings over the months tend to believe it is a comcast problem.  I have tried everything that has been posted over the months and still have the problem.  My TV is a Samsung.   By the way you can also retart the X1 box via the "My Account" Xfinity App.   For me its easier than unpluging at the box.  Keep me posted if you find a solution.


Comcast has stated they are working on it. change to a live HDMI port and back to the DVR port or power  cycle the set top box until patched.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
New Poster

Re: XG1V4 box HDMI handshake problem

I have a brand new Sony XBR75X900F 4K TV and Inneos Real4K fiber connection. Same thing, next day when I turn on the TV... no signal. Thought it must be Inneos that was the problem and have swapped out two Comcast boxes waiting hours at the local store. Now find out that everyone else is having the same problem. Comcast employees know nothing about this apparently common issue. Very frustrating. Everyone is correct, the only real fix is to power cycle the box. I also have  ProControl 24 remote so I wonder if I can have Best Buy program that to power down the Comcast box at the same time I power down the TV and turn the box back on with the TV, that way a restart always invokes the handshake and I don't care then if they ever fix it. Will advise.

Contributor

Re: XG1V4 box HDMI handshake problem


@vandenburg wrote:

I have a brand new Sony XBR75X900F 4K TV and Inneos Real4K fiber connection. Same thing, next day when I turn on the TV... no signal. Thought it must be Inneos that was the problem and have swapped out two Comcast boxes waiting hours at the local store. Now find out that everyone else is having the same problem. Comcast employees know nothing about this apparently common issue. Very frustrating. Everyone is correct, the only real fix is to power cycle the box. I also have  ProControl 24 remote so I wonder if I can have Best Buy program that to power down the Comcast box at the same time I power down the TV and turn the box back on with the TV, that way a restart always invokes the handshake and I don't care then if they ever fix it. Will advise.


Ihave my Samsung TV, Denon Reciever and X1 box all set up so that the X1 remote turns on all three.   Handshake issue is still there about every 2 or three days for last few months.  I also set up a Logitech Remote that I never use anylong to turn on and off all three, Handshake issue is the same not difference if I use that remote or the one that came with the X1 box   I've also tried turning on X1 box, TV, and Sound Reciever Independently same problem every 2/3 days.    Tried pretty much everyting listed on this forum with same result.   There is a Handshake problem which appears to be with the X1 box.  I did find one person on this forum that said they did get comcast to indicate it was an issue with the X1.   Not sure where he lives but in my area three different techs that came here and four different phone support claim they know nothing   Very frustrating.   I have been using  the Xfinity App to restart the box but for me I found it is easier to just use the xfinity voice command "Restart X1" to get the process going and get it working.   Let us know if you find a soulution  

Expert

Re: XG1V4 box HDMI handshake problem

until resolved the easy way is to change the TV input HDMI port to another live device then back the the set top box. 



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: XG1V4 box HDMI handshake problem


@Rustyben wrote:

until resolved the easy way is to change the TV input HDMI port to another live device then back the the set top box. 


Tried that.  Same result   Handshake problem still there every couple days 

Expert

Re: XG1V4 box HDMI handshake problem


@rlee131 wrote:

@Rustyben wrote:

until resolved the easy way is to change the TV input HDMI port to another live device then back the the set top box. 


Tried that.  Same result   Handshake problem still there every couple days 


yes, that procedure just fixes the instant problem without a reboot nor loss of channel buffer



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: XG1V4 box HDMI handshake problem

I'm new to this forum. Does anybody know if Comcast ever replies to this or other forums? From some of the posts here, doesn't seem like Comcast's responses to direct inquiries are helping. Time to contact the CEO?

Expert

Re: XG1V4 box HDMI handshake problem


@V8_5-OH wrote:

I'm new to this forum. Does anybody know if Comcast ever replies to this or other forums? From some of the posts here, doesn't seem like Comcast's responses to direct inquiries are helping. Time to contact the CEO?


Comcast official employee said the engineers are working on the issue. I have one too. be patient.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Contributor

Re: XG1V4 box HDMI handshake problem


Have not seen @Rustyben wrote:

@V8_5-OH wrote:

I'm new to this forum. Does anybody know if Comcast ever replies to this or other forums? From some of the posts here, doesn't seem like Comcast's responses to direct inquiries are helping. Time to contact the CEO?


Comcast official employee said the engineers are working on the issue. I have one too. be patient.


I’ve never seen a reply.  If they did they would have addressed the problem and responsibility  if Comcast actually accepts responsibility. I have not seen anything

Expert

Re: XG1V4 box HDMI handshake problem


@rlee131 wrote:

Have not seen @Rustyben wrote:

@V8_5-OH wrote:

I'm new to this forum. Does anybody know if Comcast ever replies to this or other forums? From some of the posts here, doesn't seem like Comcast's responses to direct inquiries are helping. Time to contact the CEO?


Comcast official employee said the engineers are working on the issue. I have one too. be patient.


I’ve never seen a reply.  If they did they would have addressed the problem and responsibility  if Comcast actually accepts responsibility. I have not seen anything


this is primarily a customer helping customer forum. you can tweet @ComcastCares if you want an individual response with same information. we do our best to stay up to date in helping other customers.



I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Regular Visitor

Re: XG1V4 box HDMI handshake problem

Thanks! Greatly appreciate your efforts! BTW, except for this one glitch, my experience with X1 over the last 3 years has been fantastic.

Contributor

Re: XG1V4 box HDMI handshake problem

I have a Samsung Tv also and have tried all the mentioned possible fixes with no results and the handshake problem still exsits ! 

On Jan 31,2019 Comcast pushed thru a firmware update which was supposed to fix this problem. Sorry to say it changed the problem to now instead of a black screen when the tv is first turned on in the morning it now has a blue screen and the cable box still needs to be rebooted daily! Good job Comcast Enginerring, it's only been a year and you still haven't fixed the problem!!!!

 

JMG1951

Contributor

Re: XG1V4 box HDMI handshake problem


@jmg1951 wrote:

I have a Samsung Tv also and have tried all the mentioned possible fixes with no results and the handshake problem still exsits ! 

On Jan 31,2019 Comcast pushed thru a firmware update which was supposed to fix this problem. Sorry to say it changed the problem to now instead of a black screen when the tv is first turned on in the morning it now has a blue screen and the cable box still needs to be rebooted daily! Good job Comcast Enginerring, it's only been a year and you still haven't fixed the problem!!!!

 

JMG1951


Thanks for the info.  This morning went on ok, BUT for me does not mean it was fixed yet.  I get the issue every 2/3 days.  I did it yesterday but not today.   Just wondering what area do you have your service. I'm in the San Francisco Bay Area.   With all my contacts with Comcast they have never admited to a problem.  Always are ignorant it.  

Contributor

Re: XG1V4 box HDMI handshake problem

That’s what happens. Everyday few days. Comcast problem.
Contributor

Re: XG1V4 box HDMI handshake problem

I’m on the East Coast, NJ. It’s the new 4K DVR problem which I was told by a Comcast Supervior who has been addressing my issues. There waiting for Comcast Engineers to come up with a fix for the last year!
Contributor

Re: XG1V4 box HDMI handshake problem

I've had three XG1v4b DVR cable boxes in the last 2 weeks and all exhibit the same black screren picture at morning turn that you described on my 65" year old Samsung QLED TV. I had escalated to a supervior who arrived at my home last week and verified that it was a issue with the 4k box which they are aware off . There was a firmware update on Jan 31, 2019 for the Arris XG1v4 which was suppose to address the problem but it didn't do a thing for me except that black screen now sometimes turns into a blue screen. Find it hard to beleive that Comcast Enginnering have not come up with a fix after over a year of complaints. I have Comcast coming out this week to downgrade me to the older HD dvr box without 4k that I had before which worked great for over 3 years. I'm very disappoted about giving the 4k box back but it's too stressful dealing with this situation everyday!

Contributor

Re: XG1V4 box HDMI handshake problem

you can keep the 4k box, just go in and set it to 1080p